Subject: RE: beet recipes

From: [email-masked] (Barbara Hlavin)
Date: Sun, 6 Mar 1994 05:22:35 GMT

An extremely easy way to prepare beets is to stick them into an oven at 
about 400 degrees and bake for 40-50 minutes.  This eliminates most of 
the bleeding; they're easy to peel at this point and can be sliced or 
chopped for incorporation in some other dish.  

I like the flavor of beets just the way they are and they're quite good 
chilled and thinly sliced into a vegetable salad, or just cut into chunks 
and lightly drizzled with vinegar.

--Barbara

---

From: [email-masked] (Barbara Hlavin)
Date: Sun, 6 Mar 1994 05:22:35 GMT

--Barbara