Meadville Space Center

Project Apollo - NASSP => Support & Bugs => Topic started by: almostfm on August 01, 2006, 08:16:05 PM



Title: CTD when separating CM from SM
Post by: almostfm on August 01, 2006, 08:16:05 PM
I'm having a problem that I think might be a bug, but I didn't want to report it on the Sourceforge "bug tracker" unless it looks like an actual bug (and not a config issue or the ever popular "user error").

I'm running the May 4 build of the Orbiter beta, and the Virtual Apollo modules that were released July 31 (although the problem also happened in the previous release of the VA modules).

Things seem to be going along fine until it comes time to separate the CM from the SM.  If I momentarily flip the switches (click and release) the separation doesn't occur, but if I hold one of the switches in the "release" position for a second or so, I get the White Screen of Death, and it crashes to the desktop.

I've tried with the Apollo 7 Quickstart launch scenario, the Apollo 7 Virtual AGC launch scenario, and the Apollo 8 Virtual AGC launch scenario.

Is there anything else anybody needs to know about my setup, what I'm doing, etc?  My astronauts are getting pretty tired, and would really like to come home..

  thanks,
  Scott


Title: Re: CTD when separating CM from SM
Post by: movieman on August 01, 2006, 08:37:20 PM
Something is trying to use sat5probe.msh, which has been deleted. I'm guessing it's the seperated probe config file, and needs updating with the name of the correct mesh.

I'm not sure what the correct mesh is now, so add it to the sourceforge bug list.


Title: Re: CTD when separating CM from SM
Post by: almostfm on August 01, 2006, 08:55:34 PM
Something is trying to use sat5probe.msh, which has been deleted. I'm guessing it's the seperated probe config file, and needs updating with the name of the correct mesh.

I'm not sure what the correct mesh is now, so add it to the sourceforge bug list.

  Thanks, movieman!  I've added it to the list.

  Scott


Title: Re: CTD when separating CM from SM
Post by: Swatch on August 01, 2006, 11:13:31 PM
I should be able to fix this easily.


Title: Re: CTD when separating CM from SM
Post by: Swatch on August 01, 2006, 11:34:46 PM
FIXT!!!    :Jump534: :ROTFL3453:

(I think)....update your config folder and recompile new modules....Hopefully I fixed it.  (works on my end)


Title: Re: CTD when separating CM from SM
Post by: almostfm on August 02, 2006, 02:13:05 AM
FIXT!!!    :Jump534: :ROTFL3453:

(I think)....update your config folder and recompile new modules....Hopefully I fixed it.  (works on my end)

  OK--having me compile modules is a little like having a monkey take a look at your wristwatch :wink:, but thanks to the OrbiterWiki instructions, I got everything setup, compiled, and it works.  Many thanks, Swatch!


Title: Re: CTD when separating CM from SM
Post by: Swatch on August 02, 2006, 07:47:54 AM
WOW!  You did all that overnight?! (or in the past 12 hrs)  That's amazing!


Title: Re: CTD when separating CM from SM
Post by: almostfm on August 02, 2006, 11:27:32 PM
WOW!  You did all that overnight?! (or in the past 12 hrs)  That's amazing!

Well, it's really just reading the instructions, and knowing that since MS has a new version of VC++ Express, that you need to modify the directories to match where it loads stuff...

I might be dangerous if I knew what I was doing.

  thanks,
  Scott