Meadville Space Center

Project Apollo - NASSP => Support & Bugs => Topic started by: ADT on September 01, 2006, 02:37:19 PM



Title: Trouble Loading Orbiter
Post by: ADT on September 01, 2006, 02:37:19 PM
Hi Guys,

I have recently installed Orbiter + Project Apollo beta files on my new laptop, and Orbiter freezes on loading when reaching 'reentry.dds' on all Apollo scenarios. I have been beta testing Apollo for ages on my old PC, and I just dont understand it :cry: Any help would be very much appreciated! :)

Regards


Alex


PS. May be tomorrow before I respond, as I am way, way past my bedtime here in the UK!


Title: Re: Trouble Loading Orbiter
Post by: Tschachim on September 01, 2006, 03:59:46 PM
Hi ADT,

looks like a graphic driver problem at first glance, could you:

  • post your Orbiter.log
  • try with disabled visual effects
  • try different video settings
  • check if there's a new driver available for your graphic adapter

Cheers
Tschachim


Title: Re: Trouble Loading Orbiter
Post by: ADT on September 02, 2006, 10:08:00 AM
Hi Tschasim,

Thanks for the reply! My Orbiter log file:

Render device: Fullscreen 1440 x 900
Device has hardware T&L capability
Module Sun.dll [API v.050206]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
Module Mercury.dll [API v.050206]
VSOP87(B) Mercury: Precision 1e-005, Terms 167/7123
Module Venus.dll [API v.050206]
VSOP87(B) Venus: Precision 1e-005, Terms 79/1710
Module Earth.dll [API v.050206]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
Module Moon.dll [API v.041022]
ELP82: Precision 1e-005, Terms 116/829
Module Mars.dll [API v.050206]
VSOP87(B) Mars: Precision 1e-005, Terms 405/6400
Module Galsat.dll [API v.041022]
Module Jupiter.dll [API v.050206]
VSOP87(B) Jupiter: Precision 1e-006, Terms 1624/3625
Module Io.dll [API v.041022]
Module Europa.dll [API v.041022]
Module Ganymede.dll [API v.041022]
Module Callisto.dll [API v.041022]
Module Satsat.dll [API v.050206]
Module Saturn.dll [API v.050206]
VSOP87(B) Saturn: Precision 1e-006, Terms 2904/6365
Module Mimas.dll [API v.050206]
SATSAT Mimas: Terms 113
Module Enceladus.dll [API v.050206]
SATSAT Enceladus: Terms 33
Module Tethys.dll [API v.050206]
SATSAT Tethys: Terms 101
Module Dione.dll [API v.050206]
SATSAT Dione: Terms 59
Module Rhea.dll [API v.050206]
SATSAT Rhea: Terms 68
Module Titan.dll [API v.050206]
SATSAT Titan: Terms 100
Module Uranus.dll [API v.050206]
VSOP87(B) Uranus: Precision 1e-006, Terms 1827/5269
Module Neptune.dll [API v.050206]
VSOP87(B) Neptune: Precision 1e-006, Terms 391/2024
Finished initialising world
Finished initialising status
Finished initialising camera
Finished initialising panels
Finished setting up render state
ERROR: DDraw object is still referenced: 8
>>> ERROR: Destroy framework objects failed
>>>        [C:\Source\Orbiter\D3d7app.cpp / 613]

It may be worth noting that NASSP scenarios are the only ones which experience this error.

Thanks

Alex


Title: Re: Trouble Loading Orbiter
Post by: Swatch on September 02, 2006, 12:39:53 PM
where's the rest of your log file....that one is incomplete, it's missing the header.


Title: Re: Trouble Loading Orbiter
Post by: ADT on September 02, 2006, 02:43:15 PM
Apologies, I thought I was being helpful by leaving out the top bit!

**** Orbiter.log
Build May  4 2006 [v.060504]
Found 1 joystick(s)
Module OrbiterSound.dll [API v.041022]
Module MeshLand.dll [API v.050206]
Module ProjectApolloMFD.dll [API v.060425]

**** Creating simulation session
DirectDraw interface OK
Direct3D interface OK
Zbuffer: 32 bit
Render device: Fullscreen 1440 x 900
Device has hardware T&L capability
Joystick throttle: Z-AXIS
No joystick throttle control detected
ERROR: DInput error DIERR_OBJECTNOTFOUND
       [C:\Source\Orbiter\Orbiter.cpp / 1494]
Module Sun.dll [API v.050206]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
Module Mercury.dll [API v.050206]
VSOP87(B) Mercury: Precision 1e-005, Terms 167/7123
Module Venus.dll [API v.050206]
VSOP87(B) Venus: Precision 1e-005, Terms 79/1710
Module Earth.dll [API v.050206]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
Module Moon.dll [API v.041022]
ELP82: Precision 1e-005, Terms 116/829
Module Mars.dll [API v.050206]
VSOP87(B) Mars: Precision 1e-005, Terms 405/6400
Module Galsat.dll [API v.041022]
Module Jupiter.dll [API v.050206]
VSOP87(B) Jupiter: Precision 1e-006, Terms 1624/3625
Module Io.dll [API v.041022]
Module Europa.dll [API v.041022]
Module Ganymede.dll [API v.041022]
Module Callisto.dll [API v.041022]
Module Satsat.dll [API v.050206]
Module Saturn.dll [API v.050206]
VSOP87(B) Saturn: Precision 1e-006, Terms 2904/6365
Module Mimas.dll [API v.050206]
SATSAT Mimas: Terms 113
Module Enceladus.dll [API v.050206]
SATSAT Enceladus: Terms 33
Module Tethys.dll [API v.050206]
SATSAT Tethys: Terms 101
Module Dione.dll [API v.050206]
SATSAT Dione: Terms 59
Module Rhea.dll [API v.050206]
SATSAT Rhea: Terms 68
Module Titan.dll [API v.050206]
SATSAT Titan: Terms 100
Module Hyperion.dll [API v.050206]
SATSAT Hyperion: Terms 595
Module Iapetus.dll [API v.050206]
SATSAT Iapetus: Terms 605
Module Uranus.dll [API v.050206]
VSOP87(B) Uranus: Precision 1e-006, Terms 1827/5269
Module Neptune.dll [API v.050206]
VSOP87(B) Neptune: Precision 1e-006, Terms 391/2024
Finished initialising world
Module Atlantis.dll [API v.060425]
Finished initialising status
Finished initialising camera
Finished initialising panels
Finished setting up render state
**** Closing simulation session

Again, any help you guys can give me with this is much appreciated, as I am constantly
 in awe of the high standards which Project Apollo has now reached!

Alex


Title: Re: Trouble Loading Orbiter
Post by: Tschachim on September 02, 2006, 03:02:24 PM
...and what graphic adapter do you have?

Cheers
Tschachim


Title: Re: Trouble Loading Orbiter
Post by: ADT on September 03, 2006, 08:41:41 AM
I am using an ATI Radeon 1400 DDR 256mb card, and attempting to run orbiter with a resolution of 1400 * 900.

Thanks


Alex


Title: Re: Trouble Loading Orbiter
Post by: ADT on September 04, 2006, 11:19:53 AM
After much fiddling with the various video settings, I've found that Orbiter will now run Project Apollo only when I run it windowed. It seems i can just adjust the window size to fit my screen so problem solved. However, there may be a deeper issue with the inability to display at full screen?

Cheers guys! Appreciate your attention!


Alex


Title: Re: Trouble Loading Orbiter
Post by: Tschachim on September 04, 2006, 05:57:44 PM
Hm, looks really like a graphic adapter issue, did you try to update your driver?
Perhaps it's worth a try to insert

LOWRES 1
FDAIDISABLED 1


into the ProjectApollo\Saturn5 section of a scenario, so smaller meshes are used and the OpenGL FDAIs are disabled.

EDIT: ...and did you try to disable object and vessel shadows?

Cheers
Tschachim


Title: Re: Trouble Loading Orbiter
Post by: ADT on September 05, 2006, 12:19:44 PM
Hello Again,

Yeah, when I was fiddling around I disabled all visual effects and Orbiter still hung. However,as I mentioned once I set Orbiter to windowed mode, things run perfectly! In fact I am now achieving an extremely high frame rate, that eclipses what I used to get from my desktop machine.

As far as im concerned, this solution is good enough to run Orbiter and I really appreciate your help in trying to sort me out!

Regards


Alex


Title: Re: Trouble Loading Orbiter
Post by: Swatch on September 06, 2006, 11:50:17 AM
it might be tied into trying to render to widescreen resolutions, I've had issues with that before, but not quite as bad as what you are seeing.


Title: Re: Trouble Loading Orbiter
Post by: kappen on June 05, 2007, 04:04:12 PM
I know this topic is quite old but I had the same problem and maybe others too. Hope this helps.

Likewise, I could run the program in a window but I experienced total system stalls in full window.

Somehow, the entry under the video tag was reset to "RGB emulation" and I never looked at that
entry again because initially it showed the correct graphics adapter. Clicking on "always enumerate devices" made the choice available again and the program runs in full window mode.

This reset to RGB emulation never occurred to me with any other program but NASSP 7.0 beta.

However, I have no clue when this happens exactly.

Good luck, the NASSP 7.0 is worth it.

Regards,

kappen


Title: Re: Trouble Loading Orbiter
Post by: mikaelanderlund on June 22, 2007, 04:36:11 PM
Hi,

same problem here  :cry:. Orbiter freezes on loading when reaching 'reentry.dds' on all Apollo scenarios. I'm using nvidas latest driver.

Mikael


Title: Re: Trouble Loading Orbiter
Post by: Tschachim on June 22, 2007, 04:42:41 PM
That's perhaps a problem with your firewall/security software, dseagrav explains it like this:

The usual cause for this is when Project Apollo tries to open a listen port for the telemetry monitor (and mission control later), your firewall intercepts this action and opens a "Do you want to allow this?" type dialog box. The dialog box gets hidden BEHIND Orbiter's window, so the user thinks the app has frozen when it's waiting for your decision. Please check for that.

Cheers
Tschachim


Title: Re: Trouble Loading Orbiter
Post by: mikaelanderlund on June 22, 2007, 04:55:32 PM
Hi Tschachim,

yes you are right. I found the Norton dialog box when I run orbiter in window mod. When I disable Norton internet security it works :ThumbsUp432:.

Mikael



Title: Re: Trouble Loading Orbiter
Post by: dseagrav on June 22, 2007, 07:26:04 PM
yes you are right. I found the Norton dialog box when I run orbiter in window mod. When I disable Norton internet security it works
You shouldn't disable Norton entirely, just allow Orbiter to listen to its socket. They usually call it an exception.