Meadville Space Center
Welcome, Guest. Please login or register.
November 24, 2020, 01:32:45 AM

Login with username, password and session length
Search:     Advanced search
Gemini 060615 released!
25068 Posts in 2094 Topics by 2267 Members
Latest Member: Apollo Next
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP News & Discussion
| | |-+  Support & Bugs (Moderators: movieman, Tschachim, Swatch, lassombra)
| | | |-+  2 service modules?
« previous next »
Pages: [1] Print
Author Topic: 2 service modules?  (Read 1395 times)
bluespace88
Project Team Member
Full Member
****
Posts: 241



View Profile
« on: February 05, 2007, 11:40:47 AM »

I was coming back from the moon using the apollo 11 quickstart, latest beta, did all the checklists, and seperated from the service module to prepare for reentry.  Exited and reentered, and found another service module on the back of the cm, one that i couldn't seperate from.  Tried a quicksave from a little bit earlier, and the same thing happened. Did a quick test after launch and the bug didn't show up.  Not sure if docking and seperating from the lm has to do anything with this.





Logged
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #1 on: February 05, 2007, 11:50:25 AM »

Can you post a scenario (by using the "Attach" feature of this forum, click on "Additional Options..." on the reply screen)?

Cheers
Tschachim
Logged

bluespace88
Project Team Member
Full Member
****
Posts: 241



View Profile
« Reply #2 on: February 05, 2007, 12:00:43 PM »

Attached is all the quicksaves i used for the mission.  More of an apollo 10 mission than 11, as I didn't land on the moon, but still docked with the lm.  There is one scenario marked in there that I used to get the problem, and I think the last quicksave had the same problem when you entered in.  The one marked is saved before cm separation.  Just seperate, exit, and reenter to get the problem to show up.

* sm problem scenarios.zip (98.04 KB - downloaded 83 times.)
Logged
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #3 on: February 06, 2007, 02:38:38 PM »

Thanks a lot for reporting and for the scenarios, they were very useful, it's a long time ago since I flew a mission that far. Please try again with the beta modules pack of today, the bug should be fixed now.

The bug was related to the infamous "dockstate" (the insiders know what I mean), I rearranged the Saturn V CSM/LM separation stuff a little bit and removed that SetCSM2Stage() function, however the Saturn 1B / DM separation (ASTP) still needs fixing.

Cheers
Tschachim

PS: Next time you should try without CSM fuel cheating... Wink
Logged

bluespace88
Project Team Member
Full Member
****
Posts: 241



View Profile
« Reply #4 on: February 06, 2007, 05:05:29 PM »

Ok, i'll see if it pops up again.  Thanks

P.S.
This time I will, now that I know how to use IMFD...been a while since i flew a lunar mission on nassp5  Happy
« Last Edit: February 06, 2007, 08:07:37 PM by BlueDragon8144 » Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!