Meadville Space Center
Welcome, Guest. Please login or register.
October 31, 2020, 05:52:35 PM

Login with username, password and session length
Search:     Advanced search
Project Apollo Beta 7.0 released!
http://nassp.sf.net/wiki/Installation
25068 Posts in 2094 Topics by 2266 Members
Latest Member: twa517
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP News & Discussion
| | |-+  Support & Bugs (Moderators: movieman, Tschachim, Swatch, lassombra)
| | | |-+  Cannot compile
« previous next »
Pages: [1] Print
Author Topic: Cannot compile  (Read 2667 times)
Apassi
Full Member
***
Posts: 65


View Profile
« on: June 24, 2007, 10:25:32 AM »

Hi

What seems to be problem here (besides lack experience). I tried compile SIVb Classes and there was also something problems with saturn5nasp and Saturn1b classes.
I tried as a release too. No Joy. Using btw.Visual Studio 6

--------------------Configuration: SIVb - Win32 Debug--------------------
Linking...
LIBCMTD.lib(dbgheap.obj) : error LNK2005: _malloc already defined in MSVCRTD.lib(MSVCRTD.dll)
LIBCMTD.lib(dbgheap.obj) : error LNK2005: __malloc_dbg already defined in MSVCRTD.lib(MSVCRTD.dll)
LIBCMTD.lib(dbgheap.obj) : error LNK2005: _free already defined in MSVCRTD.lib(MSVCRTD.dll)
LIBCMTD.lib(dbgheap.obj) : error LNK2005: __free_dbg already defined in MSVCRTD.lib(MSVCRTD.dll)
LIBCMTD.lib(crt0init.obj) : error LNK2005: ___xc_z already defined in MSVCRTD.lib(cinitexe.obj)
LIBCMTD.lib(crt0init.obj) : error LNK2005: ___xc_a already defined in MSVCRTD.lib(cinitexe.obj)
LIBCMTD.lib(crt0init.obj) : error LNK2005: ___xi_z already defined in MSVCRTD.lib(cinitexe.obj)
LIBCMTD.lib(crt0init.obj) : error LNK2005: ___xi_a already defined in MSVCRTD.lib(cinitexe.obj)
MSVCRTD.lib(MSVCRTD.dll) : error LNK2005: __strnicmp already defined in LIBCMTD.lib(strnicmp.obj)
LIBCMTD.lib(dbgheap.obj) : warning LNK4006: _malloc already defined in MSVCRTD.lib(MSVCRTD.dll); second definition ignored
LIBCMTD.lib(dbgheap.obj) : warning LNK4006: __malloc_dbg already defined in MSVCRTD.lib(MSVCRTD.dll); second definition ignored
LIBCMTD.lib(dbgheap.obj) : warning LNK4006: _free already defined in MSVCRTD.lib(MSVCRTD.dll); second definition ignored
LIBCMTD.lib(dbgheap.obj) : warning LNK4006: __free_dbg already defined in MSVCRTD.lib(MSVCRTD.dll); second definition ignored
LIBCMTD.lib(crt0init.obj) : warning LNK4006: ___xc_z already defined in MSVCRTD.lib(cinitexe.obj); second definition ignored
LIBCMTD.lib(crt0init.obj) : warning LNK4006: ___xc_a already defined in MSVCRTD.lib(cinitexe.obj); second definition ignored
LIBCMTD.lib(crt0init.obj) : warning LNK4006: ___xi_z already defined in MSVCRTD.lib(cinitexe.obj); second definition ignored
LIBCMTD.lib(crt0init.obj) : warning LNK4006: ___xi_a already defined in MSVCRTD.lib(cinitexe.obj); second definition ignored
MSVCRTD.lib(MSVCRTD.dll) : warning LNK4006: __strnicmp already defined in LIBCMTD.lib(strnicmp.obj); second definition ignored
   Creating library Debug/SIVb.lib and object Debug/SIVb.exp
LINK : warning LNK4098: defaultlib "MSVCRTD" conflicts with use of other libs; use /NODEFAULTLIB:library
LINK : warning LNK4098: defaultlib "LIBCMTD" conflicts with use of other libs; use /NODEFAULTLIB:library
LINK : warning LNK4098: defaultlib "LIBCD" conflicts with use of other libs; use /NODEFAULTLIB:library
LIBCMTD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main
../../../../Modules/ProjectApollo/SIVb.dll : fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

SIVb.dll - 11 error(s), 12 warning(s)


Thanks for the help in advance.

Apassi
« Last Edit: June 24, 2007, 10:31:17 AM by Apassi » Logged
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #1 on: June 25, 2007, 09:19:27 AM »

I'm not sure what's wrong there, did you modify the project files (.dsp)? Perhaps it's worth to try to delete all .dsp files and do a CVS Update to get the latest version again just in case you changed something inadvertently.

EDIT: Another question: Was it working all the time and is now broken (perhaps since OrbiterSound 3.5) or did it never work?

Cheers
Tschachim
« Last Edit: June 26, 2007, 04:43:22 AM by Tschachim » Logged

Apassi
Full Member
***
Posts: 65


View Profile
« Reply #2 on: June 26, 2007, 01:25:24 PM »

Quote
I'm not sure what's wrong there, did you modify the project files (.dsp)? Perhaps it's worth to try to delete all .dsp files and do a CVS Update to get the latest version again just in case you changed something inadvertently.
Tried this. No go.

Quote
Was it working all the time and is now broken (perhaps since OrbiterSound 3.5) or did it never work?

Yes. couple of weeks ago I was able compile almost without problem. I have had troubles compiling with debug configuration some time now. Release conf. has been working fine until now.

I updated Orbitersound to 3.5 though. Hmm.. Troubles seemed to start after that  Confused
Im not able to test it for a while. Work,work,wooooork....  Bangs Head


Thanks

Apassi







 
« Last Edit: June 26, 2007, 01:35:31 PM by Apassi » Logged
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #3 on: June 26, 2007, 02:39:45 PM »

LIBCMTD.lib(crt0.obj) : error LNK2001: unresolved external symbol _main

If I read the compiler help correctly then you're trying to build an executable (.exe file) instead of a libary (.dll file), which is wrong and doesn't work because the main function is missing since libs don't have one.
...and this is configured in the .dsp files...  Confused

Cheers
Tschachim
Logged

Apassi
Full Member
***
Posts: 65


View Profile
« Reply #4 on: June 26, 2007, 02:58:23 PM »

As I remeber right, the compiler tab offered me only: Build SIVb.dll.
Ill look it tomorrow.

Many thanks for helping to figure this out.  Thumbs Up

Apassi
Logged
Apassi
Full Member
***
Posts: 65


View Profile
« Reply #5 on: June 27, 2007, 10:43:36 AM »

Tested with Orbitersound 3.0 and compiler gave:

 -------------------Configuration: SIVb - Win32 Release--------------------
Linking...
LINK : fatal error LNK1181: cannot open input file "OrbiterSoundSDK35.lib"
Error executing link.exe.

SIVb.dll - 1 error(s), 0 warning(s)
 Undecided

Aps
Logged
movieman
Moderator
Hero Member
****
Posts: 1710



View Profile
« Reply #6 on: June 27, 2007, 10:48:53 AM »

That's the orbiter sound 3.5 library, which you won't have with 3.0. Sounds like maybe the orbiter sound 3.5 code is pulling in Windows libraries which we don't want.

Have you considered building with the Visual C++ 2005 free version? That's what I've been using for ages and it just works Happy.
Logged
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #7 on: June 27, 2007, 10:50:10 AM »

There's a misunderstanding, you need to install OrbiterSound 3.5, but that shouldn't change your .dsp files / build configuration so that the linker wants to build an executable. I'm using VC6, too, and there's no problem. Perhaps re-doing the initial checkout helps: http://nassp.sf.net/wiki/Installation

Cheers
Tschachim
Logged

Apassi
Full Member
***
Posts: 65


View Profile
« Reply #8 on: June 27, 2007, 12:42:15 PM »

Hi

Quote
Perhaps re-doing the initial checkout helps: http://nassp.sf.net/wiki/Installation
 
Ill try that.

Thanks and have good vacation.   Thumbs Up
Aps
Logged
Apassi
Full Member
***
Posts: 65


View Profile
« Reply #9 on: July 20, 2007, 01:16:52 PM »

Ok. I got it working  Thumbs Up

Had to do initial checkout. Something was changed badly.

Thanks.

Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!