Meadville Space Center
Welcome, Guest. Please login or register.
May 26, 2020, 08:58:37 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the new Meadville Space Center forums!
25068 Posts in 2094 Topics by 2266 Members
Latest Member: twa517
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP News & Discussion (Moderators: movieman, Tschachim, Swatch, lassombra)
| | |-+  No RCS translations?
« previous next »
Pages: [1] Print
Author Topic: No RCS translations?  (Read 3356 times)
Antoo
Full Member
***
Posts: 10


View Profile
« on: October 02, 2015, 04:01:29 AM »


Hi everyone. I do not have any RCS translations problem, bus some people do!...
Here is the issue they are having : With all switches correctly set, in good scenarios, they never have any RCS responses when pressing their keyboard.
I even tested theire NASSP using screen share control, nothing...

Why is this happening? It looks to be a bug, because it don't happens to everybody. (for example, to me and some other users, RCS are working well!).

We tested on Windows7, 10, same problem to these people.

Any idea?
Thank you.
Logged
indy91
Hero Member
*****
Posts: 1316


View Profile
« Reply #1 on: October 02, 2015, 07:39:35 AM »

I've followed this issue on the French Orbiter forum. I can't contribute a solution, but what I have noticed, is that with the Manual Attitude switches set to ACCEL CMD no translation is possible. I'm not sure if I am missing something, but according to this: http://nassp.sourceforge.net/wiki/Image:Attitude.jpg it should be possible.

The only "easy mistake" I can think of that causes the issue is that the switch settings RCS CMD - ON and RCS TRNFR - SM weren't done.
Logged
Antoo
Full Member
***
Posts: 10


View Profile
« Reply #2 on: October 04, 2015, 08:50:40 AM »

We tried this, not working...
Thank you anyway  Happy !
Logged
indy91
Hero Member
*****
Posts: 1316


View Profile
« Reply #3 on: October 04, 2015, 09:53:51 AM »

I've just tried (one of) the scenarios where the problem occurs, called "Apollo 7 pour expérimenter les RCS". When I start up the scenario, set all Auto RCS Select switches to MNA and the Manual Attitude switch to RATE CMD instead of ACCEL CMD (as mentioned above), then I can use the translational thrusters. ACCEL CMD doesn't allow translations at the moment, if the RCS experts here (I am not one) decide this is a bug, it will be fixed. Translations with the RATE CMD settings should work though.

I do remember that some changes were made that caused automatic attitude maneuvers with V49 and the key PRO not to work at all for one or two snapshot releases. So which version of NASSP is the problem occuring with? I doubt the 2015-08-04 release on the NASSP website had this issue, but I'm not sure. The old 2012 version of NASSP should work and the newest snapshots, which you can find here: https://github.com/dseagrav/NASSP/releases should work, too.
Logged
eddievhfan1984
Hero Member
*****
Posts: 737



View Profile
« Reply #4 on: October 04, 2015, 03:11:07 PM »

I just ran through the SCS system documents. ACCEL CMD mode should not inhibit translation commands.
Logged
indy91
Hero Member
*****
Posts: 1316


View Profile
« Reply #5 on: November 05, 2016, 11:01:05 AM »

This is now finally fixed. Translation and rotation control have the same priority, but previously in ACCEL CMD mode only the rotational commands were processed. Now the thrusters can be requested on by any subsystem in ACCEL CMD mode, but I think the way it is programmed the ECA and CMC shouldn't be doing anything anyway. It looks to me like it is now working as specified in the ACS Control Capabilities figure in the AOH (http://nassp.sourceforge.net/wiki/File:Attitude.jpg).
« Last Edit: November 05, 2016, 11:05:22 AM by indy91 » Logged
indy91
Hero Member
*****
Posts: 1316


View Profile
« Reply #6 on: March 15, 2017, 09:07:46 AM »

Now I have actually fixed this issue. My previous fix caused ECA commands by the CMC or SCS to still be processed in ACCEL CMD mode. So the TD&E technique of letting the CMC hold attitude but pitch around 180° with ACCEL CMD mode in pitch didn't properly work.

What I have now done is move the translation handling completely from ECA to RJEC, where it belongs. Also, there seems to have been some code that prevents rotational and translation commands from fighting each other?! That is not the case in the real CSM. Rotational and translational commands both have the same priority and you can fire opposite thrusters by using the RHC and THC at the same time. So I have simplified the translation code a little bit. Translations in ACCEL CMD mode are now still working and ECA commands are inhibited in ACCEL CMD mode. That should be the realistic behavior.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!