Meadville Space Center
Welcome, Guest. Please login or register.
September 26, 2020, 04:44:10 AM

Login with username, password and session length
Search:     Advanced search
25068 Posts in 2094 Topics by 2266 Members
Latest Member: twa517
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP Development
| | |-+  Programming (Moderators: movieman, dseagrav, Swatch, lassombra)
| | | |-+  Virtual AGS
« previous next »
Pages: [1] Print
Author Topic: Virtual AGS  (Read 1050 times)
movieman
Moderator
Hero Member
****
Posts: 1710



View Profile
« on: May 06, 2006, 11:54:59 AM »

I've just added Virtual AGS to the LEM build. Currently it isn't wired up, just compiled in.

Someone who's building with VC7 or later may need to fix up the 64-bit constant definitions in the code. VC6 uses i64 on the end to specify a 64-bit constant, whereas I think later versions use the standard LL.

There's an ifdef VC7 in the code, but that needs to be replaced with a correct ifdef that's generated by VC7. I think it's something like MSC_VER, but I'm not sure which version is actually used.
Logged
movieman
Moderator
Hero Member
****
Posts: 1710



View Profile
« Reply #1 on: May 06, 2006, 12:08:52 PM »

Ok, it's _MSC_VER. I've checked in a version that I think will work.
Logged
movieman
Moderator
Hero Member
****
Posts: 1710



View Profile
« Reply #2 on: May 30, 2006, 07:42:36 PM »

BTW, I assembled the source files and put the binaries in the config directory. They're not being loaded yet.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!