Meadville Space Center
Welcome, Guest. Please login or register.
October 30, 2020, 12:18:12 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the new Meadville Space Center forums!
25068 Posts in 2094 Topics by 2266 Members
Latest Member: twa517
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP News & Discussion
| | |-+  Support & Bugs (Moderators: movieman, Tschachim, Swatch, lassombra)
| | | |-+  CTD when separating CM from SM
« previous next »
Pages: [1] Print
Author Topic: CTD when separating CM from SM  (Read 1725 times)
almostfm
Full Member
***
Posts: 48


View Profile Email
« on: August 01, 2006, 08:16:05 PM »

I'm having a problem that I think might be a bug, but I didn't want to report it on the Sourceforge "bug tracker" unless it looks like an actual bug (and not a config issue or the ever popular "user error").

I'm running the May 4 build of the Orbiter beta, and the Virtual Apollo modules that were released July 31 (although the problem also happened in the previous release of the VA modules).

Things seem to be going along fine until it comes time to separate the CM from the SM.  If I momentarily flip the switches (click and release) the separation doesn't occur, but if I hold one of the switches in the "release" position for a second or so, I get the White Screen of Death, and it crashes to the desktop.

I've tried with the Apollo 7 Quickstart launch scenario, the Apollo 7 Virtual AGC launch scenario, and the Apollo 8 Virtual AGC launch scenario.

Is there anything else anybody needs to know about my setup, what I'm doing, etc?  My astronauts are getting pretty tired, and would really like to come home..

  thanks,
  Scott
Logged
movieman
Moderator
Hero Member
****
Posts: 1710



View Profile
« Reply #1 on: August 01, 2006, 08:37:20 PM »

Something is trying to use sat5probe.msh, which has been deleted. I'm guessing it's the seperated probe config file, and needs updating with the name of the correct mesh.

I'm not sure what the correct mesh is now, so add it to the sourceforge bug list.
« Last Edit: August 01, 2006, 08:39:17 PM by movieman » Logged
almostfm
Full Member
***
Posts: 48


View Profile Email
« Reply #2 on: August 01, 2006, 08:55:34 PM »

Something is trying to use sat5probe.msh, which has been deleted. I'm guessing it's the seperated probe config file, and needs updating with the name of the correct mesh.

I'm not sure what the correct mesh is now, so add it to the sourceforge bug list.

  Thanks, movieman!  I've added it to the list.

  Scott
Logged
Swatch
Moderator
Hero Member
****
Posts: 1003


jasonims
View Profile
« Reply #3 on: August 01, 2006, 11:13:31 PM »

I should be able to fix this easily.
Logged

My Project Apollo Work:
CM Visual
 -VC (~75% complete: texture work beginning again; mesh-78%; texture-70%)
Propulsion Particle Improvements (Focused on S1B right now, BETA 1.0 has been commited)
New Docking Method (~50% complete: research complete; coding partially completed, testing not underway)

Future Work:  (if it's here, it's deemed unnecessary to upcoming release)

Older Work:  (if it's here, it's fair game to whoever wants to improve)
EMS Implementation (committed: minor flaws, but groundwork is there, needs extensive testing)
EMS scrolls (committed: not refined, but usable)
SM Visual (committed: mesh-finished, texture-60%; possibly revisited in future)
J2 Texture (commited: room for improvement)
LRV (committed: mesh-finished, texture-90%; in future a ground up rebuild may be in order, but not on my plans)
Swatch
Moderator
Hero Member
****
Posts: 1003


jasonims
View Profile
« Reply #4 on: August 01, 2006, 11:34:46 PM »

FIXT!!!    Jump ROTFL

(I think)....update your config folder and recompile new modules....Hopefully I fixed it.  (works on my end)
Logged

My Project Apollo Work:
CM Visual
 -VC (~75% complete: texture work beginning again; mesh-78%; texture-70%)
Propulsion Particle Improvements (Focused on S1B right now, BETA 1.0 has been commited)
New Docking Method (~50% complete: research complete; coding partially completed, testing not underway)

Future Work:  (if it's here, it's deemed unnecessary to upcoming release)

Older Work:  (if it's here, it's fair game to whoever wants to improve)
EMS Implementation (committed: minor flaws, but groundwork is there, needs extensive testing)
EMS scrolls (committed: not refined, but usable)
SM Visual (committed: mesh-finished, texture-60%; possibly revisited in future)
J2 Texture (commited: room for improvement)
LRV (committed: mesh-finished, texture-90%; in future a ground up rebuild may be in order, but not on my plans)
almostfm
Full Member
***
Posts: 48


View Profile Email
« Reply #5 on: August 02, 2006, 02:13:05 AM »

FIXT!!!    Jump ROTFL

(I think)....update your config folder and recompile new modules....Hopefully I fixed it.  (works on my end)

  OK--having me compile modules is a little like having a monkey take a look at your wristwatch Wink, but thanks to the OrbiterWiki instructions, I got everything setup, compiled, and it works.  Many thanks, Swatch!
Logged
Swatch
Moderator
Hero Member
****
Posts: 1003


jasonims
View Profile
« Reply #6 on: August 02, 2006, 07:47:54 AM »

WOW!  You did all that overnight?! (or in the past 12 hrs)  That's amazing!
Logged

My Project Apollo Work:
CM Visual
 -VC (~75% complete: texture work beginning again; mesh-78%; texture-70%)
Propulsion Particle Improvements (Focused on S1B right now, BETA 1.0 has been commited)
New Docking Method (~50% complete: research complete; coding partially completed, testing not underway)

Future Work:  (if it's here, it's deemed unnecessary to upcoming release)

Older Work:  (if it's here, it's fair game to whoever wants to improve)
EMS Implementation (committed: minor flaws, but groundwork is there, needs extensive testing)
EMS scrolls (committed: not refined, but usable)
SM Visual (committed: mesh-finished, texture-60%; possibly revisited in future)
J2 Texture (commited: room for improvement)
LRV (committed: mesh-finished, texture-90%; in future a ground up rebuild may be in order, but not on my plans)
almostfm
Full Member
***
Posts: 48


View Profile Email
« Reply #7 on: August 02, 2006, 11:27:32 PM »

WOW!  You did all that overnight?! (or in the past 12 hrs)  That's amazing!

Well, it's really just reading the instructions, and knowing that since MS has a new version of VC++ Express, that you need to modify the directories to match where it loads stuff...

I might be dangerous if I knew what I was doing.

  thanks,
  Scott
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!