Meadville Space Center
Welcome, Guest. Please login or register.
December 01, 2020, 10:47:43 AM

Login with username, password and session length
Search:     Advanced search
Project Apollo Beta 7.0 released!
http://nassp.sf.net/wiki/Installation
25068 Posts in 2094 Topics by 2267 Members
Latest Member: Apollo Next
* Home Help Search Login Register
+  Meadville Space Center
|-+  Project Apollo - NASSP
| |-+  Project Apollo - NASSP News & Discussion
| | |-+  Support & Bugs (Moderators: movieman, Tschachim, Swatch, lassombra)
| | | |-+  Strange problem with FPS
« previous next »
Pages: [1] Print
Author Topic: Strange problem with FPS  (Read 1260 times)
EirikV
Jr. Member
**
Posts: 4


View Profile
« on: September 08, 2006, 03:56:40 PM »

Hi guys,

I'm experiencing some strange problems with the newest NASSP installed (+patch).

My computer is new; Dell XPS 2gb ram, 3,2 ghz Pentium D processor, Nvida Geforce 7800 GTX 256 mb.. In other words, a computer that should be able to run orbiter smoothly. Happy
When I go to the NASSP Apollo panel (2D), my FPS suddenly drops from 60 in outside view, to 1-0 in 2d cockpit view. I can't use any of the switches (nothing happens when I click on them)...
I have tried numerous reinstallations, changing resolution (usually running 1900x1200), etc.. Any idea why this happens?


Thanks for a great addon!
Logged
Christophe
Project Team Member
Hero Member
****
Posts: 1072


View Profile Email
« Reply #1 on: September 09, 2006, 02:48:21 AM »

Hi EirikV

I experienced the same trouble last year with my previous computer. IT was a graphic card issue. Your PC is new but your graphic card driver may be old. Sometimes the default driver may be old. Did you tried to update it?
Logged
Christophe
Project Team Member
Hero Member
****
Posts: 1072


View Profile Email
« Reply #2 on: September 09, 2006, 02:50:51 AM »

It may be an issue with open GL. FDAI uses open GL on panel 2D. In this case, a better graphic configuration could solve the problem.
Logged
BigDAS
Sr. Member
****
Posts: 307



View Profile Email
« Reply #3 on: September 09, 2006, 06:56:06 AM »

Ah, I was wondeing about that myself, as I have the same problem. Alternatively, you can turn the FDAIGL mode off.

Logged

BigDAS

"We should, in my judgement, put a man on Mars by the end of this century"
Vice President Spiro T. Agnew - July 16, 1969
Tschachim
Project Apollo - NASSP
Administrator
Hero Member
****
Posts: 3700


nassp.sf.net


View Profile WWW
« Reply #4 on: September 09, 2006, 12:38:58 PM »

Yeah, to disable the OpenGL FDAIs insert

FDAIDISABLED 1

into the ProjectApollo\Saturn5 (or Saturn1b) vessel section of a scenario.

Cheers
Tschachim
Logged

BigDAS
Sr. Member
****
Posts: 307



View Profile Email
« Reply #5 on: September 09, 2006, 01:17:23 PM »

I suspect it has to do with page flipping, as the FADI 3D object is in a masked window. I tried all the nVidia Open GL settings with no result, and tried setting the screen resolution and color to the same as Orbiter, no joy, although the page flipping does seem to be faster, but still around 10-15 fps. It will only happen after several switches from an outside window view, like Left or Right Viewport or Overhead Viewport. If I leave the view in the Center Panel, the problem does not occur. Next step is to update my nVidia OpenGL drivers.


Logged

BigDAS

"We should, in my judgement, put a man on Mars by the end of this century"
Vice President Spiro T. Agnew - July 16, 1969
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.10 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!