Subject: Restaurants in Cairo, Egypt?

From: [email-masked]
Date: Mon, 9 Jan 1995 13:28:24

Fellow Gourmet Internauts:

Making a trip to Cairo Egypt in March and would appreciate any recommendations 
for restaurants there.  I will mainly be eating in homes (Egyptian home 
cooking is beyond belief and must be experienced) but may want to take friends 
out for dinner.  Any suggestions?

Tom Caceci

---

From: [email-masked] (Orie H Niedzviecki)
Date: 17 Jan 1995 23:35:17 GMT

[email-masked] wrote:
: Fellow Gourmet Internauts:

: Making a trip to Cairo Egypt in March and would appreciate any recommendations 
: for restaurants there.  I will mainly be eating in homes (Egyptian home 
: cooking is beyond belief and must be experienced) but may want to take friends 
: out for dinner.  Any suggestions?

: Tom Caceci

	The best food, in terms of excitement, is on the street - though 
I DON'T recommend eating it.  As for nice restaurants (that you would 
take someone out to), there is the eternally popular and touristy Felfela 
at 15 Hoda Sharawy St.  I have eaten there a few times and it is always 
fun.  Try the pigeon (ask them to take the head off first.)  But for 
really nice (and not Egyptian prices) and gourmet cuisine, I am afraid 
you will have to go to a big hotel - or ask your hosts.

--
|	The NIEDZVIECKIS - Orie and Jen
|		A house, a car, 2.7 kids, one cat and a dog