Subject: Who invented "French Fries"?

From: [email-masked] (Herbs WA)
Date: 2 Apr 1995 20:51:07 -0400

At one time I thought I knew the history of French Fries. But now, I'm not
so sure?

Were they invented in America, France, Belgium, or did some Aztec possibly
eat them (with Ketchup?) long before?

---

From: [email-masked] (jv)
Date: Tue, 04 Apr 1995 08:45:32 +0100

> eat them (with Ketchup?) long before?

The first written source we can find about "french frites" are situated in
Spain. In a monastery they wrote in their books how they used to boil
patotoes in oil. But the frenchfrite became very popular in Belgium, and
is therefore an belgian tradition.