Subject: Re: Why Not Eat Lungs?

From: [email-masked] (Tom Perigrin)
Date: 21 Nov 1994 15:56:14 GMT

Re: eating lung - I was under the impression that one of the main ingredients
in Haggis was lung?
	I used to smuggle McSween's hagggis out of Scotland past customs when
 I lived in Sweden, it's wonderful cold weather food.  Of course I can't eat
any of my favorite English/Swedish recipes here in Arizona, as it's too hot
for heavy food.
							Marti

---

From: [email-masked] (Diane Duane)
Date: Tue, 22 Nov 1994 10:37:41 GMT

In article <[email-masked]>, Ger Beerden ([email-masked]) writes:

>I'll try and find (and translate) a recipy for 'beuschel' for you, if 
>you want.  I know I have it somewhere in an old austrian cookbook.

Yes, please post that recipe!!  D.

                        Diane Duane
   part of the Owl Springs Partnership, Co. Wicklow, Ireland
 "A little science...a little magic...a little chicken soup."
             Also on Compu$erve: 73200,3112

---

From: [email-masked] (Chong Angela)
Date: 16 Nov 1994 04:57:27 GMT

Nick Maclaren ([email-masked]) wrote:
: In article <[email-masked]>,
: Robert And Cynthia Chiovoloni  <[email-masked]> wrote:
: >Herbs WA <[email-masked]> writes:
: > 
: >>We eat most animal organs, but not lungs.
: >>
: >>Is this a particularly American fetish. Are animal lungs eaten anywhere to
: >>anyone's knowledge?
: > 
Lungs are eaten in SE Asia
Angela

---

From: [email-masked] (Robert F. Jaffe)
Date: 20 Nov 1994 22:07:09 GMT

The lung thread has spawned a number of comments relating to 
the American (United States) distaste for foods not on the
rather limited list of American standards.  It would be 
appreciated if readers would post information as to the 
culinary limitations of other cultures.

rj