Subject: Re: Salsa recipe?

From: [email-masked] (Vicki Sarrio)
Date: 28 Jul 1995 17:42:15 GMT

In <[email-masked]>, [email-masked] (dugarm) writes:
>Any suggestions for a salsa recipe for canning?  
>I used one from the Blue Book last year and was 
>rather disappointed.

Well, there's two ways I can think of. My personal recipe took me a years to 
perfect and it's still somewhat dynamic, depending on personal tastes of those
eating it.
--------------------------------------------
Fresh chopped tomatoes
Fresh chopped jalapenos
About a dozen hot green chilis (not the Big Jim's -- they're too mild)
One or two habaneros
Half a dozen finger chilis (resemble scrawny jalapenos)
Green onions
One to two cloves of whole garlic
Tablespoon or two of finely diced carrot (preferably hot pickled)
Salt to taste
Pepper to taste

Use as much of each ingredient as you like to give the salsa the flavor and 
consistency you prefer. You need to experiment to get it where you like it. 
When it's how you like it, either put it in canning jars and refrigerate (if 
you don't want it mass produced) or process it like you would tomatoes. I
normally use fresh ingredients and make enough to last a few weeks instead of 
processing it unless I use home-canned stuff. If you can jalapenos, try 
putting a small green tomato, onion, and carrots in with the peppers then put 
those in your salsa. It's fantastic that way or straight from the jar. 
--------------------------------------------

Good luck :-)

vic
--
Folds, thrusts, and overturned beds are
all common in zones of orogeny.

---

From: Sanders Elizabeth R <[email-masked]>
Date: Sat, 29 Jul 1995 09:49:44 -0500

> I used one from the Blue Book last year and was 

Here is my salsa recipe...it has been handed down from 
Mother-in-law...try variations...they can be wonderful!

3 qts. peeled, chopped tomatoes
3 onions, chopped
3 jalapenos, seeded and chopped
3 cloves garlic, minced
3 sweet peppers (I use bell or banana)
2 T garlic powder
4 T vegetable oil (olive oil works)
5 T sugar (I leave out)
4 T vinegar
1 1/2 t. chili powder
1/2 t. black pepper
1 t. salt
pinch of oregano, thyme, marjoram

Simmer all ingredients in large pot for one hour.  Pour into jars while 
hot, seal and place in water bath for 20 minutes.

Variations-- I leave out the sugar and chili powder, oregano, thyme and 
marjoram.  

Sugar, if used, could probably be reduced.

--Beth
who has canned 25 quarts of salsa this summer!