Subject: Informations about HERBALIFE

From: [email-masked] (Bruno Battocletti)
Date: Wed, 20 Mar 1996 17:39:06 GMT

Can you help me to find the mail or e-mail address of the American
company who products the natural food line called Herbalife ? Does it
exist in USA ?

Thank in advance !

 --- Bruno.

---

From: [email-masked] (Foodwerks)
Date: 25 Mar 1996 19:40:12 -0500

I don't have the address, but the phone number is 310 216-9661.  

____________________________________________________
Mary C. Mulry
FoodWise, Inc.
P.O. Box 89
Hygiene, CO 80533

Consulting to the natural and organic foods and dietary supplements
industry on technical issues