Subject: Re: veganism is excellent

From: [email-masked] (caitlin)
Date: 23 Mar 1996 01:12:48 GMT

In article <[email-masked]>, [email-masked] says...
>
>In <[email-masked]> [email-masked] (Kevin

>>out of the ordinary.  The few vegans I know do seem a bit more pale
>but I 
>>really doubt it can be attributed to their diet.

>Comment: why not?  They may well be anemic.  Not to mention having fat
>that is orange-- something guaranteed to make you look a bit waxy if
>you have no tan. 
>
>                                 Steve Harris, M.D.
Hmmm, that's it. What an MD, scare people into thinking lack of meat = anemia. Amazing, My children 
and I get physicals every year, never been anemic. Best cholesterol level in town though. Anemia isn't 
just about iron, its about absorption and proper amount. Fact is heme iron is no magic anti-anemic cure 
and most people who eat meat don't absorb any more usable iron then vegans. Your theory has been 
debunked many many times. Fact is, vegetarism and veganism can be an extremely healthy diet (junk 
food vegetarians not included!) and the typical american diet can be extremely unhealthy. Physician, 
educate thyself.

---

From: [email-masked] (caitlin)
Date: 23 Mar 1996 01:06:23 GMT

In article <[email-masked]>, [email-masked] says...

>I've been a vegetarian (not vegan) for 15 years and my skin color is nothing 
>out of the ordinary.  The few vegans I know do seem a bit more pale but I 
>Kevin
>([email-masked])

Well, all the vegans I know are pretty darn health conscious and don't take chances with skin cancer. 
They (and my kids and I) all wear sunscreen outdoors... My one friend that doesn't looks just like 
everyone else.

There is a condition that will temporarily turn your skin orangish if you consume massive quantities of 
beta carotene, that's just if you started living on carrots... :)

cate

---

From: [email-masked] (Dave Clarke)
Date: Sat, 23 Mar 1996 21:37:43 GMT

[email-masked](Kelly) wrote:

>Caitlin:

>I became an ovo-lacto vegetarian about six years ago.....would like to
>take the next step, but....MAN!  the thought of no cheese....i dunno. 
>it hasn't been the slightest challenge for me to give up eating
>"anything with a face," in spite of my meat-and-potatoes upbringing,
>but i'm having a REAL challenge with the next phase.  i know all that
>fat isn't a positive addition to my diet.

>And....admittedly, i slip into the "junk food" category at times.

>any thoughts or suggestions to make the next step easier?

>by the by....i was anemic before i became a vegetarian and no
>self-respecting blood bank will accept my donation.  ha ha.  just
>started taking colloidal minerals....do you think this will help with
>my "iron-poor blood"?

>Kelly

Think of the calves taken from the mother at a very early age to keep
her lactating. (Every year!)

The calves have to be slaughtered - there are too many of them to put
back into milk production. And all the males are surplus too.

Go on just grit your teeth and do it. It really is worthwhile!

Best wishes and good luck.

Dave Clarke (a vegan for 22 years)

---

From: [email-masked](Kelly)
Date: 23 Mar 1996 03:35:39 GMT

Caitlin:

Kelly

---

From: [email-masked] (Don Brady)
Date: Mon, 25 Mar 1996 16:23:00 GMT

>>any thoughts or suggestions to make the next step easier?

You may be worrying about missing the calcium or protein in dairy products.
If so, both concerns can be allayed.  Leafy green vegs such as kale are an
excellent source of calcium.  And protein will be ok if you grains and
beans.

>>started taking colloidal minerals....do you think this will help with

You need to figure out why you are anemic.  You could have a B12-absorption
problem for example (lack of intrinsic factor).  Even non-vegetarians can
have this and if so it is very serious eventually.  Easily fixed too by
taking 1000 mcg B12 orally daily.   But it could be something else.

Men should not take iron as it is almost impossible for them to have a
deficit of that unless they are bleeding internally.

---

From: [email-masked] (KCB)
Date: Mon, 01 Apr 1996 14:29:42 GMT

>excellent source of calcium.  And protein will be ok if you grains and

If you are going to be eating a lot of beans, make sure that you cook
them properly. Beans contain trypsin inhibitors which tend to destroy
the enzymes which break down the proteins in the digestive canal, and
so prevent them from being absorbed. There are also haemoglutinins
which are bad for you, I forget exactly why, except that they attach
themselves to the digestive canal and damage it. Raffinose is the
least of your problems, it only causes flatulance.  

THE BLITHE SPIRIT
"I'll thank you for your time
and you can thank me for mine"  Rodrigues