Subject: Re: mozzarella kind of italian cheese

From: Alfonso Brancaccio <[email-masked]>
Date: Fri, 26 Apr 1996 10:19:42 +0200

Hi
 
if you want save other on this cheese you go to alt.mcdonalds.cheese

ALFONSO

---

From: Alfonso Brancaccio <[email-masked]>
Date: Fri, 26 Apr 1996 10:20:32 +0200