Subject: WTB Small honey extractor (used)

From: [email-masked] (Cliff Johnson)
Date: Mon, 10 Jun 1996 16:08:18 GMT

I am seeking a used manual or powered honey extractor for use on a
small honey farm.  Please respond by email since I do not regularly
access  news groups.
Cliff Johnson [email-masked] (Studio City,CA)

---

From: [email-masked] (Cliff Johnson)
Date: Mon, 10 Jun 1996 16:20:32 GMT

>Cliff Johnson [email-masked] (Studio City,CA) 
My phone number is:  818-761-5665; FAX 818-761-9501.