Subject: price of beeswax?

From: Larry F <[email-masked]>
Date: Thu, 13 Jun 1996 22:29:42 -0600

Hi, 
I'm new to this group, hope this is on topic.
  Does anyone know the current going price for beeswax?
I hav'nt sold any for 10 years or so and hav'nt kept track of the price.

---

From: "Theodore V. Fischer" <[email-masked]>
Date: Fri, 14 Jun 1996 10:16:49 -0400

> I hav'nt sold any for 10 years or so and hav'nt kept track of the price.

I got US$2.25/lb when I sold a batch in January.

---

From: [email-masked] (BusyKnight)
Date: Thu, 13 Jun 1996 03:17:27 GMT

>I hav'nt sold any for 10 years or so and hav'nt kept track of the price.
   
What continent are you on?

---

From: [email-masked]
Date: 13 Jun 1996 12:39:18 -0700

In article , Larry says...