Subject: Re: What if plants......

From: [email-masked] (Gerald W. Roe)
Date: 19 Mar 1995 19:15:08 GMT

Necessary? To whom? I think it would be a mistake to assume that
everything exists purely for the benifit of humans and will go
away when no longer "needed".
-- 
Trans-Pacific Nursery        Rare and Exotic Plants
Email catalog available      Timber Press books discounted

---

From: [email-masked] (Gerald W. Roe)
Date: 19 Mar 1995 19:15:08 GMT