Subject: Vitamin C (Ascorbic Acid) in plants

From: Stafford Crossman <[email-masked]>
Date: Wed, 24 Apr 1996 22:01:15 GMT

What is the role of Vitamin C or Ascorbic acid in plant growth and other 
related functions?

---

From: [email-masked](Michael L Roginsky )
Date: 1 May 1996 21:07:16 GMT

In <[email-masked]> Stafford Crossman
>What is the role of Vitamin C or Ascorbic acid in plant growth and
other 
Looking from the other side, Rosa Rugosa pods have a very high content
of ascorbic acid, called "natural" by some humanists. I just puzzle
about the "unatural" ascorbic acid. Is there a supernatural compound?

Cheers........Micro, alive and not a microbe!