Subject: WANTED: plantseeds from all over the world

From: [email-masked] (Guenther TREYTL)
Date: 17 Jun 1995 18:52:26 GMT

Hello !
who knows where in the world are agencies
or companies which have a 'seed-bank'
and sell exotical plantseeds?
answer please to
[email-masked]
Guenther TREYTL

---

From: [email-masked] (Irsides)
Date: 21 Jun 1995 23:25:57 -0400

Try this companies.
1-SEEDCO
20253 Elfin Forest rd.
Escondido, CA.- 92029
USA
(619) 471-1464

2-SELECT SEEDS
P.O. Box 319
Alamo, Texas- 78516
USA
(210) 464-2357

3- TROPICAL PLANT & SEED LOCATORS
Mail Drawer 1000
Delray Beach, FL- 33447-1000
USA
(407) 278-6004

4- MISTLETOE
780 North Glen Annie Rd.
Goleta, CA- 93117
USA
(805) 968-4818

Good luck.

Sid Gardino
[email-masked].
plants