Subject: Seagrasses of the Andaman Sea

From: [email-masked] (kcampbel)
Date: 20 Jul 1995 20:29:24 GMT

I am a Canadian fisheries biologist who is going to Trang Province in S. Thailand.  Does anyone know which species of seagrasses are found in the region?
Can anyone suggest a good reference on this subject?
Thank you Kathy.

---

From: [email-masked]
Date: Fri, 21 Jul 95 22:47:00 PST

HI Kathy! Do you know of P.G. Harrison in the Botany Department at UBC? He
is an expert on Zostera a west coast seagrass. Perhaps you could contact him
for seagrass references.   P.S. If you need someone to steer your boat in
the Andaman Sea give me a posting!  Ted.