Subject: Plants of Mexico

From: [email-masked] (Jan Collins )
Date: 14 Jul 1995 13:08:53 GMT

Am searching of books/papers/journals/etc. on the flora of Mexico. 
(Didn't find one even while there)  Can you suggest?
J Collins

---

From: Lisa Bush <[email-masked]>
Date: 14 Jul 1995 15:52:19 GMT

You might want to do a author search for Rogers McVaugh. He has written several volumes 
on the flora of Mexico. Specifically, I think, Jalisco.