Subject: plant images

From: [email-masked] (Plannerguy)
Date: 11 Apr 1995 18:02:44 -0400

Does anyone know where I could access a database on the internet that has
plant descriptions along with plant image files associated with them?

---

From: [email-masked] (Mike)
Date: 14 Apr 1995 02:28:09 GMT

>plant descriptions along with plant image files associated with them?

The University of Georgia has a fantastic internet tour of the greenhouses.
Unfortunately, I do not know the URL address.