Subject: lead accumulation in plants

From: Mitch Beauchamp <[email-masked]>
Date: 17 Jul 1995 02:17:44 GMT

Searches for information on lead or heavy metal accumulation in plants seems to end up with articles on lead stories in the journalistic sense or rock bands.  There seemed to be some body of information of the selective uptake of heavy metal and, particularly, lead (Pb) by certain plants.  Any leads (no pun intended) in the right direction would be helpful for someone just a notch above novice on the gopher and www.
R. Mitchel Beauchamp  [email-masked]

---

From: [email-masked]
Date: Wed, 26 Jul 95 21:22:39 -0500

The May (or June ?) issue of Environmental Science and Technology had a number
of
articles about Pb and Brassica (sp?).  These were very interesting and had
good bibliographies.
Later, Ed