Subject: Re: Lavender cultivars??

From: Talya Proctor <[email-masked]>
Date: 31 Oct 1995 21:31:53 GMT

Karen, 
I have a feeling that your cultivars are just natural mutations that 
have possibly sprung up from seed. Hopefully they will propagate from 
cuttings, because I seriously doubt that they will come true from seed. 
Good luck. Jim Talley, Houston

---

From: Talya Proctor <[email-masked]>
Date: 31 Oct 1995 21:31:53 GMT

Karen,