Subject: Ginseng seeds

From: [email-masked] (Marianne Ellegaard)
Date: Thu, 4 May 1995 13:51:23

I am looking for a source of seeds of Panax ginseng or P. quinquefolia. I do 
not need very many. Can anybody help me with this?

Marianne Ellegaard

---

From: [email-masked] (Conrad Richter)
Date: Sun, 07 May 95 08:39:56 EDT

> not need very many. Can anybody help me with this?

We offer both species.  You can request a snail-mail catalogue by 
emailing to: [email-masked].

RICHTERS HERBS                     | Info:                 [email-masked]
Goodwood, ON  L0C 1A0, Canada      | Catalog Requests:  [email-masked]
Tel +1-905-640-6677  Fax 640-6641  | What's New for '95:    [email-masked]