Subject: Re: Queen Ann's Lace as an ornamental?

From: [email-masked] ("Roger Whitehead")
Date: Wed, 5 Jun 1996 08:50:43 GMT

> Never trust common names.

Absolutely. In Britain, "Queen Anne's Lace" normally refers to Cow 
Parsley - Anthriscus syvestris (aka Kecks, Devil's Meat and about thirty 
other names).

Roger

- - - - - - - - - - - - - -

Roger Whitehead,
14 Amy Road, Oxted, Surrey RH8 0PX, England
Tel: +44 (0)1883 713074; Fax: +44 (0)1883 716793
.

---

From: [email-masked] ("Roger Whitehead")
Date: Wed, 5 Jun 1996 09:45:36 GMT

Oops! That should, of course, be Anthriscus sylvestris. (Don't know what 
the 'l' I'm doing some days.)

Roger

Roger Whitehead,

---

From: [email-masked](Michael L Roginsky )
Date: 8 Jun 1996 22:08:51 GMT

In <[email-masked]> [email-masked]
>the 'l' I'm doing some days.)
Roger, Roger! By the way it was imported to the US from England if I am
correct. It is a roadside plant, blooming now at N34.5 deg latitude.

Micro....alive and not a microbe!