Subject: help...need some seeds

From: "Brian T. Sabus" <[email-masked]>
Date: Fri, 19 May 1995 16:58:08 GMT

Would anybody out there be willing to give me some information on where I 
could get the following seeds?

1. Leucopremna mexicana
2. Alpinia galenga
3. Curcuma amada
4. Curcuma heyneana
5. Curcuma zedoaria
6. Curcuma aromatica
7. Curcuma aerginosa
8. Kaempferia galanga
9. Artemisa monosperma

Thanks for the help.

---

From: [email-masked] (Tim Barkley)
Date: 20 May 1995 02:47:20 GMT

> could get the following seeds?
You can order #'s 2 and 9 and also a 'Curcuma domestica' (and hundreds of
other fasinating herbs) from:

Companion Plants
7247 N. Coolville Ridge Rd.
Athens, Ohio  45701
(614) 592-4643

Hope this helps.
Tim Barkley