Subject: LOTUS SEEDS

From: [email-masked] (Peter Schmidt)
Date: 13 Jul 1995 19:22:16 GMT

I would like grow some Lotus plants, but have no success in get the 
seeds (from India) to germinate. Any ideas or suggestions ?

---

From: [email-masked] (charles dunn)
Date: 15 Jul 1995 09:10:19 -0500

Did you nick or file the seeds?

Peter Schmidt ([email-masked]) wrote:
: I would like grow some Lotus plants, but have no success in get the 
: seeds (from India) to germinate. Any ideas or suggestions ?