Subject: Plant Tissue Culture

From: [email-masked] ("Elizabeth Mathew")
Date: 21 Mar 1995 09:32:54 -0800

Hello,
     I am interested in obtaining addresses and phone numbers of
plant tissue culture departments/labs located in California area.  I
am looking for a job in the plant tissue culture field.

Thanks.

Elizabeth Mathew
e-mail:[email-masked]

---

From: [email-masked] (William Hurst)
Date: 24 Mar 1995 11:59:17 -0800

Call suzan Coopersmith at CloneTech 805-386-5195, tell hel bill hurst 
from hardy diagnostics sent you, Good luck!

---

From: [email-masked] (William Hurst)
Date: 24 Mar 1995 11:59:17 -0800