Subject: Martha Washington Geraniums

From: [email-masked] (HAUGELAND)
Date: 28 May 1995 22:27:30 -0400

Can anyone please provide me with Cultural Information on Growing Martha
Washington Geraniuns in a Greenhouse environment

Terry Hauge

---

From: [email-masked] (ruffel)
Date: 1 Jun 1995 12:07:12 GMT

>Washington Geraniuns in a Greenhouse environment

where do you live.??