Subject: Scientific Names of Elodea, Camboba

From: [email-masked] (Mary Elyse Lucero)
Date: 17 Oct 1995 21:03:03 GMT

Does anyone know the Scientific names (Genus and species) of the  common 
elodea (also called Anachris) and Camboba plants grown in aquariums?  

Thanks

Mary

---

From: [email-masked] (Harold Slater)
Date: 18 Oct 1995 22:58:49 GMT

Mary Elyse Lucero ([email-masked]) wrote:
: Does anyone know the Scientific names (Genus and species) of the  common 
: elodea (also called Anachris) and Camboba plants grown in aquariums?  

Elodea canadensis

Cabomba aquatica

---

From: pete <[email-masked]>
Date: Fri, 20 Oct 1995 11:30:33 GMT

>: elodea (also called Anachris) and Camboba plants grown in aquariums?  

Although I am no expert on plants, the Cobomba I use in my tank
is another species..Cobomba Carolina

Pete

---

From: [email-masked] (Maarten van Helden)
Date: 20 Oct 1995 11:31:32 GMT

In article <[email-masked]>, [email-masked] says...
>elodea (also called Anachris) and Camboba plants grown in aquariums?  
It probably is "Eleodea canadensis", but there are a few other species also 
used in aquaria) and Cabomba has a number of species, including "Cabomba 
aquatica". A good book on aquarium plants should give you all the details.

Maarten
-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++
||\\  //||  Dr. Maarten van Helden
|| \\// ||  Dept. of Entomology
||  \/  ||  Wageningen Agricultural University
||||||||||  Binnenhaven 7, 6709 PD
||      ||  Wageningen, the Netherlands
||      ||  Tel +31-317-485118 Fax +31-317-484821
||      ||  Email: <[email-masked]>
++++++++++++++++++++++++++++++++++++++++++++++++++++++++