Subject: herbal course lecturers wanted

From: Jhn wilkinson <[email-masked]>
Date: 6 May 1995 21:46:42 GMT

For weekend course in herbs and pharmacognosy, to be held in London,
june/july 1995. Topics will include chinese and indian herbal 
medicine, ethnobotany, herb growing, botany and chemistry of 
medicinal plants, edible wild foods and many other topics. 
lectureres in some of these topics are still needed

---

From: Adam Van Wirdum <[email-masked]>
Date: 13 May 1995 00:17:56 GMT

Jhn wilkinson <[email-masked]> wrote:
> lectureres in some of these topics are still needed.

sounds great. see the list of lecturers for the recent Australian herbalists Association
Confrence all were great
Michael
TFG