Subject: Re: Cycas

From: Helen+Paul <[email-masked]>
Date: 24 Jun 1996 06:26:11 GMT

Cycas revoluta is a pretty common cycad found in nurseries in Brisbane, 
Australia. It can be in full sun or part shade, indoors is OK, moderate 
watering (ensure good drainage, less water indoors), apply general 
fertilizer (eg. pelletised chook manure, say, 1 handful) twice a year.  
It is slow growing, but the leaf shape/texture makes the species a good 
feature plant for a 'tropical' look.  I is relatively frost and drought 
hardy, but UK... don't know.

Good luck

Paul Kristiansen
Dept. of Natural Resources
Brisbane, Australia

---

From: Hawaii Space Center <[email-masked]>
Date: 28 Jun 1996 07:59:05 GMT

Do not overwater
Full sun
Winter indoors
Slow grower
Fertilize with a little fish emulsion
in growing season.
Careful with the thorns.
Last but not least next time but from
"good company" they will give you
complete instructions. Check a Gardening
Encyclopedia at the Library; that will help
a lot.
Happy gardening, Sam