Subject: Scientific names hard to find

From: "Tom Skj�nberg" <[email-masked]>
Date: 29 Mar 1996 13:10:57 GMT

A friend of mine is an avid stamp-colletor and at the same time very 
interested in plants. She has a colletion of stamps with plants and have 
been able to classify most of them. But a few stamps puzzels her since 
they don't carry any scientific names.

The problems are:

PLANT         COUNTRY
-----         ---------
adua          Somalia
ghaf tree     Arab Emirates
izaqueante    St. Tome & Principe
pessego       -same-
untue         -same-
modowa tree   Papua & New Guinea
poponjoche    Nicaragua

Does anyone out there have any hints to these plants ???

Regards,
Tom Skjonberg, Denmark.

---

From: [email-masked](Michael L Roginsky )
Date: 31 Mar 1996 13:17:31 GMT

>they don't carry any scientific names.
Tom I do not, but my cyberbuddy Julius will. He is a professor emeritus
of botany. His hopage in the web is: http://144.174.177.33/~Julius.hmtl

give him a try.........:)Micro.