Subject: Peter Paul's nursery ??

From: [email-masked] (Bruce M. Marshall)
Date: 3 Apr 1996 08:57:25 -0500

Does anyone have a phone number or address for Peter Paul's nursery ?
They specialize in "carniverous" plants, Venus fly traps and the like.
Or does anyone know another nursery that carries these plants?

Thanks,
Bruce
-- 
Bruce M. Marshall  [email-masked]  voice 423 481 0990  fax 423 481 8039

---

From: [email-masked] (Jim Crahan)
Date: Thu, 04 Apr 1996 05:55:03 GMT

>Bruce

Bruce,

 http://www.indirect.com/www/bazza/cps/faq/faq.html

This is a site with WAY more information than you ever wanted to know
about CP's

Jim Crahan
Stevens Point, WI

---

From: [email-masked] (Cathy Czapla)
Date: 4 Apr 1996 04:12:13 GMT

Peter Paul's Nurseries
4665 Chapin Road
Canandaigua, NY  14424-8713
Phone 716-394-7397
Brochure free

Another good source:

California Carnivores
7020 Trenton-Healdsburg Road
Forestville, CA  95436
Phone 707-838-1630
Informative catalog $2.00

Hope this helps, 
Cathy

-- 
********************************************************************
 GREEN WORLD:  News & Views for Gardeners Who Care About The Earth
  PO Box 418, Randolph VT 05060       [email-masked]
********************************************************************