Subject: CAN SOMEONE HAVE ADDRESS FOR BURGESS SEED & PLANT CO?

From: [email-masked] (Jeanne Johnson)
Date: 17 May 1996 12:12:33 GMT

If you have the address, I think its in IL please Email me at
[email-masked]

Thank you.

JJ

---

From: [email-masked] (m.lee)
Date: Sun, 19 May 1996 18:32:02 GMT

Jeanne Johnson ([email-masked]) wrote: 
: If you have the address, I think its in IL please Email me at
: [email-masked]

: Thank you.

: JJ

Last one I've got is

	905 Four Seasons Road
	Bloomington, IL 61701

ml