Subject: Herbarium paper;

From: Shawn A Jalbert <[email-masked]>
Date: Mon, 29 May 1995 12:31:30 -0400

I was wondering if anybody knew a company from which I could purchase some 
herbarium paper from. I usually buy it from my school but now that I am 
home for the summer I am in desperate need of some more. By herbarium 
paper I mean the paper used to mount dried plant specimens.

Any help would be greatly appreciated,
Thank You
Shawn Jalbert
[email-masked]

---

From: [email-masked] (Gordon T. Uber)
Date: Wed, 31 May 1995 15:48:34 GMT

You can get herbarium paper from
Carolina Biological Supply
2700 York Road
Burlington NC 27215

1-800-334-5551

66-3200 100% rag 11x16.5" $25.75/100
66-3205 50% rag $18.95
66-3210 $12.95
Prices 1994, add shipping and handling.

Also try Ward's Natural Science Establishment
PO Box 1712 Rochester NY 14603
716-467-8400 (as of 1970)

Hope this helps.

Gordon Uber
Palo Alto, CA

Shawn A Jalbert ([email-masked]) wrote:

: I was wondering if anybody knew a company from which I could purchase some 
: herbarium paper from. I usually buy it from my school but now that I am 
: home for the summer I am in desperate need of some more. By herbarium 
: paper I mean the paper used to mount dried plant specimens.

: Any help would be greatly appreciated,
: Thank You
: Shawn Jalbert
: [email-masked]

---

From: Dennis Marelli <[email-masked]>
Date: 3 Jun 1995 01:03:06 GMT

>Carolina Biological Supply

How about:

Herbarium Supply Company
3483 Edison Way
Menlo Park, CA  94025

(800) 348-2338
(415) 366-8868
(415) 366-5492 FAX

Hope this helps, happy pressing.

                             Dennis