Subject: BLIGHT

From: William LeBlanc <[email-masked]>
Date: 13 Jul 1995 06:34:25 GMT

Hi All
Blight...so I am told is a fungus that is treeated in the spring when the new growth appears.
Is there anything else I can do before spring? It is on a large willow
tree that sits in the middle of my yard. I don't want to lose it.
Is there anything I can do to help it through to spring.

This seems a good place to ask about fungi.
Thanks for any help you can give me.
Bill

[email-masked]

---

From: Gary Poyssick <[email-masked]>
Date: 19 Jul 1995 13:53:03 GMT

Try Daconil. Wet the ground all around the tree. If that fails, use 
Subdue. It's very expensive (about $20 to treat the tree) but it is 
highly effective against most blight.