Subject: Looking for LEMON BALM OIL ? <<<<<<<<<<<=------------

From: [email-masked] (Kennyc)
Date: Sat, 11 Mar 1995 10:34:41 GMT

Could any one assist me with a location for info on the 
plant `Melissa Officinalis' and it's product Lemon Balm Oil?

ta Kennyc.

---

From: [email-masked] (Rick Popham)
Date: 17 Mar 1995 04:09:19 GMT

>plant `Melissa Officinalis' and it's product Lemon Balm Oil?

Try jumping onto alt.folklore.herbs 
Wendy
-- 

   *==*
 * ---- *
 -*RIFF*-  [email-masked]
 * ---- *
   *==*