Subject: Chinese "Monkey Tree"

From: [email-masked] (Al Ross)
Date: Wed, 24 May 1995 09:49:32 +1000

A friend brought back some seeds from a lady's yard in Washington state that 
she called chinese monkey tree.   Can anyone give info on it?

Thanks in advance

Al Ross

---

From: [email-masked] (MarvinS106)
Date: 26 May 1995 23:49:09 -0400

There is a fabulous Chinese Monkey Tree in a nursery just south of Seaside
Oregon near the Cannon  Beach turnoff.  It is one of the most magnificent
trees I have ever seen.

SS