Subject: EPSOM SALTS FOR HOUSEPLANTS

From: [email-masked] (Alex King)
Date: 31 Jul 1995 18:22:06 -0700

Can someone please post the proper formula for applying Epsom Salts 
(Magnesium Sulphate) to house plants so as to increase their chlorophyll 
content and hence "green them up." 
Thank You,
Alex de Moura King
[email-masked]

---

From: Gary Poyssick <[email-masked]>
Date: 12 Aug 1995 14:28:25 GMT

Mix equal amounts of the salt with water, making a slushy mix. Pour 
directly into the center of the plant. As far as I know this is ONLY 
GOOD FOR PALMS or CYCADS that are yellowing. It can kill many other, 
less salt-tolerant species. Be careful.