Subject: anyone familiar with herbicide 2,4-D ??

From: Seon Hooi Chua <[email-masked]>
Date: Fri, 5 Apr 1996 06:50:53 +1000

Could anyone please provide me with any info on this Chemical
2,4-dichlorophenoxyacetic acid. It is a herbicide.. also commonly known as
2,4-D.

thanks.
regards,
sean

---

From: [email-masked]
Date: Sat, 06 Apr 1996 17:00:46 GMT

>sean

Works really well on dandelions.  I used to work with a lawn
maintenance company, and we applied 2-4-D mecoprop at the beginning of
summer on our customers yards.  Sorry I can't supply any technical
information for you.

DAve