Subject: Hibiscus not flowering

From: [email-masked] (IOS User)
Date: 6 Jun 1995 00:10:57 GMT

I just bought a Hibiscus plant.  It has a lot of foliage and buds, but 
only one of them flowered. Any suggestions or explanation?

E-mail or post here , thanks.

---

From: [email-masked] (Richard Mello)
Date: 16 Jun 1995 02:14:08 GMT

1) hibiscus need lots of sun, and should be in direct sunlight for most 
of the day, as long as the outside temperature is warm enough.

2) They also need PLENTY of water and should be watered EVERY day.

3) The foliage should be sprayed with water EVERY day. This especially 
will promote flowering.

RJM