Subject: Monkeyface

From: [email-masked] (Al Ross)
Date: Wed, 24 May 1995 09:51:09 +1000

I bought a plant in LA several years ago that was called Monkey Face. It was 
the only name that the garden shop knew it by. I haven't been able to fine any 
info on it....HELP.

Al Ross

---

From: [email-masked] ('Toby' H D Bradshaw)
Date: 24 May 1995 14:00:11 GMT

In article <[email-masked]>,
>the only name that the garden shop knew it by. I haven't been able to fine any 

Could be one of the ~140 species of Mimulus, one of whose sections
is Simiolus.

-Toby Bradshaw
[email-masked]