Subject: Plant Growth Regulators - Is there a NewsGroup?

From: Iskren Sergiev <[email-masked]>
Date: 24 Jun 1996 09:20:43 GMT

Hi to all
Does anyone know in which NewsGroup I can find
information about Plant Growth Regulators. 
Is there such a NewsGroup?
Thanks, Iskren

---

From: J Kroin <[email-masked]>
Date: 26 Jun 1996 02:46:19 GMT

>Is there such a NewsGroup?
You can find a highly technical email group located in the UK at
http://www.plant-hormones.bbsrc.ac.uk/

this group is quite sophisticated. most members of the group are
university researchers. nice people!

regards
Joel 

-- 
  ******************  Hortus USA Corp. ***************** 
   PO Box 1956 Old Chelsea Station, New York NY 10113 USA
          Rhizopon AA Dry Powders & Tablets for Solutions
                Plant Growth Regulator-Rooting Hormones
  ****************  [email-masked]  **************