Subject: HUDSONIA

From: [email-masked]
Date: 13 AUG 95 13:18:28 GMT

I am looking for a LARRY MORSE.  I am interested in reading your
doctoral dissertation on Hudsonia, but am having trouble finding
it.  If you are out there, would you please contact me?

Or, if someone else is out there who can supply me with the
reference I need, it would be greatly appreciated.  I understand
this was published in the Contrib. Gray Herbarium about 20 years ago.

Thank you!! //Janine Beckert.

---

From: [email-masked] (Kathy Bilton)
Date: 14 Aug 1995 11:54:59 GMT

[email-masked] wrote:
: I am looking for a LARRY MORSE.  I am interested in reading your
: doctoral dissertation on Hudsonia, but am having trouble finding
: it.  If you are out there, would you please contact me?

Call the Nature Conservancy in Arlington, VA.

--Kathy

Kathy Bilton   [email-masked]   http://www.fred.net/kathy/ ......O`-o.......
 <a href="http://www.fred.net/kathy/at.html">Appalachian Trail Home Page</a>