Subject: carnivorous plants

From: [email-masked] (Edmund Lee Jon Deoon)
Date: 7 Jun 1995 02:51:11 GMT

doesanyone knowwhere i can get a good source or catalogue of carnivorous 
plants?

---

From: "Dale M. Benham" <dbenham@hobbes>
Date: Thu, 8 Jun 1995 13:04:12 -0500

Try this WWW site.

http://cvp.onramp.net:80/feedme/feedme.html