Subject: Edible Yucca leaves?

From: Carol Hanny <[email-masked]>
Date: 13 Jun 1996 11:35:19 GMT

I bought some "edible yucca leaves" at Stop and Shop the other day.  
Well, I can't find any info about them.  I have books that talk about 
the flowers, fruit and roots, but not the leaves.  I tasted them raw, 
muciligeous (sp?).  Does anyone have any info on them?

Thanks,

Carol

---

From: [email-masked] (CDesley)
Date: 18 Jun 1996 09:05:56 -0400

I've eaten green yucca fruits before in salad.  They weren't too bad and
I'm still alive. Can't vouch for leaves though.