Subject: Electric Heating Panels for germinating/propagating

From: Greg Revell <[email-masked]>
Date: Tue, 24 Sep 1996 15:03:06 +0100

Hotbox Heaters have unique aluminium foil heating system for giving
germinating and propagating temperatures can be seen at:-

http://www.ukexnet.co.uk/hort/hortbox/

Already in use in 17 countries.
Distributors wanted in many countries.
-- 
Greg Revell

---

From: Greg Revell <[email-masked]>
Date: Wed, 25 Sep 1996 19:08:07 +0100

In article <[email-masked]>, Greg Revell
<[email-masked]> writes
>Distributors wanted in many countries.

Sorry the correct URL is http://www.ukexnet.co.uk/hort/hotbox/

-- 
Greg Revell