Subject: Wanted: Information on Low TCH Hemp legalization

From: [email-masked] (Thomas and Dawn Lundvall)
Date: Sat, 23 Mar 1996 20:19:59 -0500

I have seen posts on Low TCH hemp used for a legal cash crop.  I was asked
at a recent political meeting to put of some of the information together. 
I would appreciate any information you might have for me.

E-mail at [email-masked]
Thank you in advance.

---

From: [email-masked] (SherryR915)
Date: 5 Apr 1996 20:59:52 -0500

We passed a bill 108 - 33 in the Vermont House to legalize industrial hemp
(test plots), and it's being considered in our Senate this week April 8th.
I could give you lots more, e-mail me back. [email-masked]