Subject: Coverslips

From: [email-masked] ()
Date: Tue, 1 Feb 1994 22:51:44 GMT

Does anyone know a good supplier of small coverslips (round, diameter <10mm)
for growing cells on etc?

---

From: [email-masked]
Date: Sun, 6 Feb 94 11:30:14 +500

>for growing cells on etc? 

Bellco has several sizes 10 and 12 for sure and I think smaller
-----------------------------------------------------------------------
Joel Lowy				The usual disclaimers.
Physiology Dept.
AFRRI, 8901 Wisconsin Ave., Bethesda, MD 20889-5603, USA 				 	
[email-masked]
301-295-1790  FAX 301-295-0313
-----------------------------------------------------------------------