Subject: Best, cheapest recombinant interleukin-2?

From: [email-masked] (Helgi Briem Magnusson)
Date: 2 Feb 1994 15:55:07 GMT

Hello out there.
   I was asked to post a query about the best and cheapest
sources of recombinant interleukin-2 (IL-2).  I realize
that the best may not be the cheapest.  Any info would
be appreciated.

Regards, Helgi Briem
Institute for Experimental Pathology
Keldur
University of Iceland

---

From: "Dr. Colin R.A. Hewitt" <[email-masked]>
Date: 2 Feb 1994 17:20:56 -0000

Date:          2 Feb 1994 15:55:07 GMT
From:          [email-masked] (Helgi Briem Magnusson)
Reply-to:      [email-masked] (Helgi Briem Magnusson)
To:            "bionet.cellbiol mail newsgroup" <[email-masked]>
Subject:       Best, cheapest recombinant interleukin-2?

Hello out there.

Regards, Helgi Briem

I get clinical gradehuman  rIL-2 from the local hospital pharmacy dept.  It is called 
aldesleukin (Proleukin) and is made by Eurocetus UK. I don't have their address, 
sorry. One dose is 18 million units and costs only #140. I use it at 20 units/ml and it 
works as well as 20 units/ml Boehringer rIL-2 . (18 million units of Boehringer would 
cost tens of thousands of #).

Good luck

Dr. Colin R.A. Hewitt
University of Leicester/MRC
Centre for Mechanisms of Human Toxicity
Hodgkin Building
PO Box 138
Lancaster Rd
LEICESTER
LE1 9HN
U.K.

Phone +44 (0)533 525587
Fax +44 (0)533 525616
E-Mail [email-masked].