Subject: Re: litchi Trees, all info on

From: [email-masked] (Richard Cline)
Date: Mon, 10 Jun 1996 11:35:45 -0800

In article <[email-masked]>, cdownes wrote:

> Im after any information on the Litchi Tree belonging to the
> Sapindaceae family. It is classified as Litchi chinenisis.
> Any info on growing, climate, cultivation and harvesting would be
> appreciated. Email to     [email-masked]
> Regards Chris.  

Check the California Rare Fruit Growers
http://www.crfg.org?

They are very informative on many plants.

____________________________________________
[email-masked]
"My words mean exactly what I choose them to mean."  Humpty Dumpty
____________________________________________

---

From: [email-masked] (chris downes)
Date: Sat, 08 Jun 1996 08:39:10 GMT