Subject: Re: FOUND: Nature's perfect plant food?

From: [email-masked] (Albert /adelman)
Date: 13 Jul 1995 08:53:38 GMT

I'm interested. What is this stuff aand where do I get it??

---

From: [email-masked] (LUIGI CPA)
Date: 22 Jul 1995 17:02:56 -0400

please let me know thanks ???