Subject: Disease Resistance Apples

From: Mark Scarinzi <[email-masked]>
Date: Wed, 1 Mar 1995 08:47:05 -0500

Which of the following apples would you recommend for taste
and long keeping?
Liberty
Nova Easygro
Dayton
Henry Kohankie
Jonafree
William's Pride
Black Twig
Cockles's Pippen
Spartan
Redfree
Egremont Russet
Ellison's Orange
Grenadier

---

From: [email-masked] (larry mawby)
Date: Sun, 05 Mar 1995 20:14:03 -0600

i'm growing only a few of the varieties listed, but like liberty and
spartan for taste. neither is particularly long-keeping, and liberty is
significantly more disease-resistant than spartan.

-larry