Subject: litchee trees

From: TODD PUTNAM <[email-masked]>
Date: Fri, 11 Oct 1996 23:47:22 +0000

I live in Ca, does anyone know where I could find a litchee tree for 
backyard collection

---

From: [email-masked] (DGholston)
Date: 13 Oct 1996 13:04:19 -0400

Message-ID: <[email-masked]>

>I live in Ca, does anyone know where I could find a litchee >tree for
backyard collection

Three California sources that I am aware of:

Pacific Tree Farms
4301 Lynwood Dr.
Chula Vista, CA 92010
(619) 422-2400
They will ship

Roger and Shirley Meyer
16531 Mt. Shelly Circle
Fountain Valley, CA 92708
(714) 839-0796

Exotica Rare Fruit Nursery
2508-B East Vista Way
Vista, CA 92085
(619) 724-9093

Also see CRFG Fruit Fact on Litchi at our Web Site listed below.

Don Gholston
California Rare Fruit Graowers
http://www.crfg.org/