Subject: Yellow Citrus Leaves

From: [email-masked] (SteveC9291)
Date: 6 Sep 1996 14:09:03 -0400

I have 10 potted orange seedlings that are outside for the summer. 
The leaves on several of the trees are turning yellow.  I suspect a
nutrient deficiency but am not sure what it might be.  I fertilized with
Miracle Grow (very lightly) in the spring and early summer but not since. 
I am in Denver Colorado, zone 4.

---

From: Lykos <[email-masked]>
Date: Fri, 13 Sep 1996 23:06:42 -0700

> I am in Denver Colorado, zone 4.

Try chelated iron added directly to soil.