Subject: Re: fish fertilizer

From: [email-masked] (DGholston)
Date: 14 Sep 1996 12:17:24 -0400

>Does anyone have any experience with liquid fish >fertilizer? I would
like to talk to anyone who markets, >sells or uses the stuff.

I use it all the time. What would you like to know about it? Fish emulsion
is an ideal nonburning fertilizer for container material.

Don Gholston

---

From: [email-masked] (Paul Stewart C/O ABIOGEN)
Date: Fri, 13 Sep 96 22:27:54 GMT

Does anyone have any experience with liquid fish fertilizer? I would like to 
talk to anyone who markets, sells or uses the stuff.

Thank You,

Paul Stewart
RR #2 Vernon Bridge
Prince Edward Island
CANADA   C0A 2E0
[email-masked]