Subject: Re: Need tree catalog !

From: [email-masked] (Michael Huffman)
Date: Mon, 12 Dec 1994 00:19:41 -0600

In article <[email-masked]>, [email-masked] (Jon
Charles Gilliam) wrote:

> 
>    Another good source is the Arbor Day Foundation, but I don't have
> their address with me.  Their prices are very reasonable, and the 
> quality is also good.
> 

I believe the address to be:

National Arbor Day Foundation
100 Arbor Avenue
Nebraska City, NE 68410

(402) 474-5655

-- Mike!

---

From: [email-masked] (Harold Slater)
Date: 20 Dec 1994 01:23:33 GMT

Frank Concannon. ([email-masked]) wrote:
: Could someone please post address for a reliable mail-order supplier of
: trees.

A good source of unusual as well as the common is Woodlanders.
They have a good selection of interesting natives as well as non-natives.
There Oak selection (as one example) is quite good.

    Woodlanders
    1128 Colleton Ave.
    Aiken, SC 29801
    PH/FAX (803) 648-7522

    descriptive (well done) catalog $2.00

Harold

---

From: advanced digital networks <[email-masked]>
Date: 27 Dec 1994 16:48:00 GMT

---

From: advanced digital networks <[email-masked]>
Date: 27 Dec 1994 16:51:13 GMT

>     descriptive (well done) catalog $2.00
Another good source for trees is MUSSER NURSERIES in Penna.

---

From: [email-masked] (Kdcutler)
Date: 8 Jan 1995 15:20:42 -0500

FORESTFARM (990 Tetherow Rd., Williams, OR 97544) has just about
everything.
Karan Davis Cutler, HARROWSMITH COUNTRY LIFE

---

From: [email-masked] (Kdcutler)
Date: 8 Jan 1995 15:20:42 -0500