Subject: RE: Hostas in Mass.

From: [email-masked] (erweaver)
Date: 6 Mar 1995 19:46:36 GMT

X-Newsreader: WinVN 0.92.2

For Testbed:

  A very fine source for Hostas in Mass. is:

                 R. Seawright
                 201 Bedford Rd.
                 Carlisle, MA   01741

             PH: (508) 369-2172

  They have approx. 150 different Hostas not to mention about 650
 daylilies. For the rest of us they also do mailorder.
  I have plants from there and was very pleased. The Hostas were 
 container grown not single eyes. My sister lives near there and 
 has visited. I'm told it is fascinating.
  Hope this helps unless your looking for Hostas "en masse".

                                    Jennifer

---

From: [email-masked] (erweaver)
Date: 6 Mar 1995 19:46:36 GMT

For Testbed:

                 R. Seawright
                 201 Bedford Rd.
                 Carlisle, MA   01741

             PH: (508) 369-2172

                                    Jennifer