Subject: Re: Getting rid of yarrow

From: [email-masked]
Date: 2 Mar 1995 00:12:18 GMT

>   [email-masked] (B.P.) writes:
>  Our neighbor said we'd be sorry about all that yarrow that we
>  planted, and now we know why!  Any tips to erradicate yarrow?
>  
>  Specifically, it's Yarrow Archillea, Pearl variety.
>  
>  The roots looks like morning glory, and its spreading profusely.
>  Thanks,
>  -B+B
>  
>  
>>>>
Having tried to eradicate the yarrow, we have come to the conclusion that selling our house and moving may be the only 
way to get away from it!
Ellen Cicero                       716-394-8453
115 Beal St.             Heart of the Finger Lakes                     
Canandaigua, Ny 14424      "do it right the first time!"

---

From: Anne Ferrugio <[email-masked]>
Date: 5 Mar 1995 23:18:24 GMT

>  The roots looks like morning glory, and its spreading profusely.

Flatheaded yarrow shouldn't be a problem. Volunteers can be pulled
easily, especially when small.  Cut off flowers before they go
to seed.

Good luck.

Annette Sloan
[email-masked]

---

From: Anne Ferrugio <[email-masked]>
Date: 5 Mar 1995 23:18:24 GMT

Good luck.

Annette Sloan
[email-masked]