Subject: Re: Copper tape for slug control?

From: [email-masked] (Chris Boake)
Date: 19 Feb 1995 11:59 EST

In article <[email-masked]>, [email-masked] (Tom Rudnick) writes...
>B Kelly ([email-masked]) writes:
> >> I recently noticed an ad in a gardening magazine for copper tape which is
>> supposed to repel slugs.

THe new issue of Organic Flower Gardening says that it is effective.
They also point out that you can cut yourself on it, so be careful.
My favorite anti-slug treatment was in the "letters" section of the
magazine -- feed the suckers to your pet pirahnas!
--Chris

---

From: [email-masked] (Harold Slater)
Date: 2 Mar 1995 00:59:15 GMT

: : Where can I get copper tape for slug control?  Is it available at
: : hardware stores?

Natural Insect Control here in Canada sells a product called Snail-Barr
It's a copper-alloy strip. It's a 3" flexible barrier that can be used on
raised beds, around trees etc.. It supposedly lasts for years.
20' strip with clips is $19.99 CDN ($1.50 US <GGG>) $12.00 US. They have it
in 50' and 100' strips too.

Natural Insect Control           They also have lots of amazing
R.R. #2                          parasitic/predatory bugs.
Stevensville, Ontario
L0S 1S0  
FAX (905) 382-4418  (catalog free)

******************************************************************************
Harold Slater / Botanika Bromeliads/ Toronto /Canada 
[email-masked]    FAX (416)698-9333