Subject: cycads

From: [email-masked] (Wayne Hughes)
Date: 4 Mar 1995 22:13:29 GMT

Does anyone know of a business selling a wide range of cycad
  seeds, preferably mail order?  I'm particularly interested
  in the cycads forming ovulate sporophylls, as well as cones.

  Thanks
  Wayne

---

From: [email-masked] (Karen Fletcher)
Date: 5 Mar 1995 11:06:07 GMT

Wayne Hughes ([email-masked]) wrote:
:   Does anyone know of a business selling a wide range of cycad
:   seeds, preferably mail order?  I'm particularly interested
:   in the cycads forming ovulate sporophylls, as well as cones.

:   Thanks
:   Wayne

             Cycad Gardens
             4524 Toland Way
             Los Angeles, CA 90041
             Catalog: SASE        
             213-255-6651, Fax: 213-344-0858
             Offerings: cycads

             Endangered Species             
             P.O. Box 1830                  
             Tustin, CA 92681-1830          
             Catalog: $6                    
             714-544-9505                   
             Offerings: bamboos, cycads, palms
             Comments: the catalog has descriptions and some photos, a
             separate price list is available free

>From the *SOURCES* catalog index on The Garden Gate.  Cheers!

--
Karen Fletcher                                     [email-masked]
==========================================================================
The Garden Gate            http://www.prairienet.org/ag/garden/homepage.htm
The Garden Gate at SunSITE  http://sunsite.unc.edu/garden-gate/homepage.htm
The Garden Spider's Web    http://mirror.wwa.com/mirror/garden/spdrsweb.htm

---

From: [email-masked] (Karen Fletcher)
Date: 5 Mar 1995 11:06:07 GMT

:   Thanks
:   Wayne

             Cycad Gardens
             4524 Toland Way
             Los Angeles, CA 90041
             Catalog: SASE        

             Endangered Species             
             P.O. Box 1830                  
             Tustin, CA 92681-1830          
             Catalog: $6                    
             714-544-9505