Subject: Re: Poor Soil

From: [email-masked] (Jerry Heverly)
Date: 16 Feb 1995 21:23:57 -0800

Jeck1 ([email-masked]) wrote:
: I just moved to this house last year and my garden was pathetic. The spot
: I choose for a garden had lots of sand, was acidic, and little topsoil.
: I've been saving compost, but the garden's big and my compost will take a
: long time to catch up. The surrounding trees have lots of Oaks, so it
: contributes to the acid.
: I am contemplating hauling in some horse manue, but I've always dreaded
: that because of the weeds. I usually try to stay as much organic as
: possible, but we wasted a lot of time last year with this soil. I've heard
: that composting the manue can kill the seeds but have never tried it. Any
: Ideas?
If your pile is hot(generally at least one cubic yard in size with a good 
C:N ratio) you'll kill your weed seeds.
Jerry Heverly, Instr. of hort, Diablo Valley College, Pleasant Hill, CA
-- 

Jerry Heverly, Oakland, CA

---

From: [email-masked] (spudnik1)
Date: 20 Feb 1995 08:49:43 GMT

In article <[email-masked]>, [email-masked] (Jeck1) s
I also just moved to a new house and the soil is terrible. I've had the same problems you have. I saw an article in one of my magazines which pictured a beautiful yard that was filled with all sorts of perennials. The owner said that she had poor clay soi
l and just dug holes larger than required and filled them with potting soil. I don't know how well this will work, but I'm willing to try for lack of a tiller or compost as of yet.