Subject: seedlings for kids

From: [email-masked] (Joel Golden)
Date: Wed, 8 Mar 1995 12:36:51

What's a good plant for a class of kids to sprout seeds?

---

From: [email-masked] (Michael E. Matthews)
Date: Thu, 9 Mar 1995 16:43:05 GMT

I recommend radish seeds, since they go from seed to finished
edible product in less than a month, germinate quickly, are
easy to grow, and the plant stays small. They don't need summer
heat to thrive, so it is easier to fit into a school schedule.
(A dwarf snow pea is also a possiblility, though it gets much
larger.) It may take two or three months (assuming you don't
eat the radish) to get the whole life cycle of seed to seed,
but that is still much shorter than with most things other than
beans and cucumbers, which need lots of space. You get lots of
seeds to a package, too.

Michael in central VA