Subject: Expert Primula growers???

From: [email-masked] (Shauna Rabinowitz)
Date: Sun, 05 Mar 1995 11:07:20 -0400

I was looking through the Thompson ansd morgan catalog and sawe some
wonderful rare primroses. They are, of course, from seed. Anyone have any
good tips on how to get them started well and their overall
treatment???Thank you much. shauna

---

From: Susan Sanders <[email-masked]>
Date: 6 Mar 1995 19:47:59 GMT

In article <[email-masked]> Shauna
>wonderful rare primroses. They are, of course, from seed. Anyone have any

I can't help with your actual question, but can offer that Siskiyou Rare
Plant Nursery in Washington (the state) offers some rare primroses as
plants.  I don't have their address with me but can get it for you if you
want it.  What species are you interested in?             -Sue Sanders

---

From: Susan Sanders <[email-masked]>
Date: 6 Mar 1995 19:47:59 GMT