Subject: Clematis sources?

From: [email-masked]
Date: 7 Mar 1995 18:28:37 GMT

Does anyone know a US source for any of the following large-flowered Clematis hybrids:

Belle Nantaise
James Mason
Peveril Pearl
Silver Moon
Vino

Any help would be much appreciated!

TIA

S. Andrew Schulman
Seattle (USDA Zone 8, Sunset Zone 5)

_____________________________________________________________________

S. Andrew Schulman                             Voice: (206)545-1117                        
Springwood Associates, Inc.                      FAX: (206)545-1107     
Seattle, WA                                       
[email-masked]                       All the usual disclaimers.      
______________________________________________________________________

---

From: [email-masked] (B GOOGLE)
Date: 8 Mar 1995 21:33:55 -0500

I believe Jackson and Perkins has Vino