Subject: Foxglove afterlife?

From: [email-masked] (Tane Russell)
Date: 28 Feb 1995 20:43:49 GMT

I bought a dozen Digitalis Purpurea last spring and
they bloomed beautifully.  I kept them deadheaded, until
the last batch so they could reseed.

My understanding of biennuals is that after they
bloom, they die.  All but one of last years plants
is starting to grow again this spring. I will
definately keep them if they will bloom again this
year. Do some biennuals bloom for more than one season?

Tane Russell

---

From: [email-masked] (TIGIBSON)
Date: 2 Mar 1995 14:54:32 -0500

the plants have babies without reseeding. but the 2nd year plants that
bloomed for me last year were only 4' tall, not 6-7'.
tigibson

---

From: [email-masked] (Bob Beer)
Date: 1 Mar 1995 01:27:32 GMT

Digitalis purpurea is strictly speaking a biennial but sometimes it will 
survive longer; there are also some completely perennial varieties.  You 
may have got lucky.  :)

bob

In article <[email-masked]>,

---

From: [email-masked]@cruzio.com [Bob Shelby]
Date: Mon, 6 Mar 1995 05:54:44 GMT

Yes, actually in an environment which it likes, foxgloves can be perennial. 
I have never had them last for more than three years, though, and so far have 
had no luck with them reseeding themselves -I think they will do this in a 
totally undisturbed place, which my garden isn't, as I am always adding 
compost and such...
However, collecting the seeds and then planting them can be fun
-Maura ([email-masked])

---

From: [email-masked]@cruzio.com [Bob Shelby]
Date: Mon, 6 Mar 1995 05:54:44 GMT

---

From: [email-masked] (Diana Foss)
Date: 8 Mar 1995 09:33:17 -0800

>year. Do some biennuals bloom for more than one season?

I have some digitalis plants starting their fourth year, and they're
still alive. The flowers were smaller last year, but they're
hanging in there. I plant new ones every year, so there are always
some coming into their peak.

BTW, I've never had any foxgloves reseed, although everything I've
read claims they reseed freely. How freely, in others' experience?

		Diana Foss, in San Jose, CA

-- 
Diana Foss                                                 [email-masked]

The Rikitandoo! Now what is that? It's something made by the Princess Pat.
It's red and gold, and purple, too. That's why it's called the Rikitandoo.