Subject: Ranunculus and Winter

From: [email-masked] (Chris Eykamp)
Date: 4 Apr 1995 16:40:41 GMT

Can anyone tell me if Ranunculus can survive the winter in Portland, OR?

Thanks!

chris eykamp

---

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:53:03 GMT

>Can anyone tell me if Ranunculus can survive the winter in Portland, OR?

If you mulch them well, they should be fine.  Otherwise, just 
dig them up each fall and replant each spring.

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 6 Apr 1995 01:20:47 GMT

In <[email-masked]> [email-masked] (Glen Bolen) writes: 

>
>Chris Eykamp ([email-masked]) wrote:
>:Can anyone tell me if Ranunculus can survive the winter in Portland, OR?
>
>What is Ranunununcululus?
>--
>----------------------------------------------------------------------------
>Glen Bolen
>Assistant Regional Planner
>[email-masked]
>
>The views expressed are my own and do not reflect the opinions of 
>my employer, METRO.
>

A group of semi-hardy, semi-evergreen plants grown mainly for
their flowers.  The most common type is the "turban" flowered
type which blooms in late spring / early summer.

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:53:03 GMT

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 6 Apr 1995 01:20:47 GMT

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:53:03 GMT

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 6 Apr 1995 01:20:47 GMT

Chris Owens

---

From: [email-masked] (Glen Bolen)
Date: 5 Apr 1995 19:21:38 GMT