Subject: growing freesia from seed

From: [email-masked] (Chazlitt)
Date: 24 Mar 1995 17:59:48 -0500

Has anyone out there tried this?  I got some seeds at a local greenhouse
and it talks about setting it (seeds) in a peat compost for 2 weeks then
sowing--Huh?  After taht the seed should grow into bulbs which can be
planted.  This is an interesting exercise in growing from seed.  Would
appreciate any advice someone out there might have!

---

From: [email-masked] (Fat Lenny)
Date: 29 Mar 1995 02:43:09 GMT

In <[email-masked]> [email-masked] (Chazlitt) writes: 

>sowing--

I directly planted seeds in park starts seed starters and had a very hi 
germination rate as does everything i use in the park starts.