Subject: Re: Windbreaks

From: [email-masked] (Christine Owens)
Date: 22 Mar 1995 02:06:49 GMT

In <[email-masked]> [email-masked] (Tim Hack) writes: 

>
>I would like to know what species of trees would be best for a windbrek. 
>I live on the border between zones 4 & 5 and my soil has a Ph of 6.4.
>

Try planting poplars -- they grow fast -- then pine trees.  By the
time the poplars die off in 15-20 years, you will have a great pine
windbreak.

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 22 Mar 1995 02:06:49 GMT

Chris Owens