Subject: Dwarf Rhodo Sources?

From: [email-masked]
Date: Fri, 31 Mar 1995 23:39:36 GMT

Any good sources for dwarf rhodos... they seem to like my cold, windy
NYC rooftop, but they're hard to find in nearby garden centers..

---

From: Paula M Craft <[email-masked]>
Date: Mon, 3 Apr 1995 20:52:43 -0600

The April Horticulture has an article on dwarf rodies.  If you are unalbe 
to obtain it, e-mail me and I'll send the source list.

- Paula M. Craft
[email-masked]

---

From: Paula M Craft <[email-masked]>
Date: Mon, 3 Apr 1995 20:52:43 -0600

- Paula M. Craft
[email-masked]

---

From: Paula M Craft <[email-masked]>
Date: Mon, 3 Apr 1995 20:52:43 -0600

- Paula M. Craft
[email-masked]