Subject: Browallia seed panic

From: "t.r." <[email-masked]>
Date: 23 Mar 1995 07:27:49 GMT

TRYING to start browallias from seed ...
after relying several summers on the nurseries...
but it's been 2 weeks now, indoors, & not a sprout
yet! Anybody know, is browallia supposed to be
slow to germinate ... or worse yet a low germination
rate?

t.r.

---

From: [email-masked] (Diveanddig)
Date: 27 Mar 1995 12:46:23 -0500

Surface sow the seed - just press in the soiless plant mix, seal in
plastic bag, and germinate in bright place at 70 -75F.  
Bill Bird