Subject: Re: Sub-tropical bulbs

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:20:48 GMT

In <[email-masked]> [email-masked] (Liz Runciman) writes: 

>
>I've been asked by a friend who has moved to Brisbane for a suggestion
>list of sub-tropical bulbs.  I am compiling a list of the usual things
>like clivia, agapanthus and cyrtanthus, but I wonder if anyone in the
>area could suggest varieties of spring-flowering bulbs like daffodils
>which tolerate a humid sub-tropical climate.  
>
>Thanks
>
>Liz
>
>
>Liz Runciman               Adelaide
>[email-masked]        South Australia        
>
>

Most of the spring-flowering bulbs are that way because they
need a period of cold dormancy -- definitely not available to
your friend.  All of the tender bulbs, as well as lillies will
do well.

Chris Owens

---

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:20:48 GMT

Chris Owens

---

From: [email-masked] (charles dunn)
Date: 6 Apr 1995 04:37:19 -0500

Most spring-flowering bulbs do not do well in a sub-tropical climate.  They
require chilling to form flowers buds.  Calla lilies, cannas, crinum lilies,
cymbidium orchids, amaryllis, all sound like good bets.  If it gets dry in
the summer, lycoris and blood lilies work.

---

From: [email-masked] (Christine Owens)
Date: 5 Apr 1995 07:20:48 GMT

Chris Owens

---

From: [email-masked] (charles dunn)
Date: 6 Apr 1995 04:37:19 -0500

---

From: [email-masked] (Liz Runciman)
Date: Mon, 03 Apr 1995 21:55:27 +1100

Thanks

Liz

Liz Runciman               Adelaide