Subject: growing freesia from seed

From: [email-masked] (Chazlitt)
Date: 24 Mar 1995 17:59:48 -0500

Has anyone out there tried this?  I got some seeds at a local greenhouse
and it talks about setting it (seeds) in a peat compost for 2 weeks then
sowing--Huh?  After taht the seed should grow into bulbs which can be
planted.  This is an interesting exercise in growing from seed.  Would
appreciate any advice someone out there might have!

---

From: [email-masked] (Gerald W. Roe)
Date: 25 Mar 1995 19:03:33 GMT

Be patient. You can certainly grow bulbs from seed, but it may
take the bulbs several years to grow to flowering size.
-- 
Trans-Pacific Nursery        Rare and Exotic Plants
Email catalog available      Timber Press books discounted