Subject: Sources for perennial plants

From: [email-masked] (Laurie Cousart)
Date: 24 Mar 1995 15:55:17 GMT

Would appreciate any recommendations for buying perennial plants and
shrubs by mail.  I know about Bluestone but cannot find an 800 number so
that would be really helpful.

thanks!

---

From: [email-masked] (HollyTW)
Date: 24 Mar 1995 18:50:15 -0500

Here ya go!

Bluestone Perennials
800-852-5243

Happy gardening!
Holly

---

From: [email-masked] (HollyTW)
Date: 24 Mar 1995 18:50:15 -0500

Here ya go!

Bluestone Perennials
800-852-5243

Happy gardening!
Holly