Subject: Re: What's BLOOMIN' in your part of the land?

From: [email-masked] (June Lemieux)
Date: Thu, 23 Mar 1995 01:00:06 GMT

We have Johnny Jump Ups in Carleton Place (near Ottawa) too!  I t
grow while the snow is onthe ground!

---

From: [email-masked] (Robert C. Vaiden)
Date: 23 Mar 1995 20:30:11 GMT

Spring Beauty (Claytonia virginica) just opened today in my yard.

Also, the first of my wild tulips will open today (Turkestanica
and Pulchella Violacea).  Thunderstorm, rain and hail last
night!    First of the season..so things should take off now!

Bob Vaiden   Urbana, Ill.