Subject: Recommend knee pads?

From: Paula M Craft <[email-masked]>
Date: Fri, 24 Mar 1995 20:24:08 -0700

I'm looking forward to my second knee surgery soon and it's definite I'm 
in the market for knee pads.  Does anyone have a favorite type that don't 
bind in back and are well padded?  And I have skinny legs so velcro 
closures are best although I would replace buckles if the pads were 
good.  Any suggestions?

"It wasn't a mispent youth, just a busy one."

- Paula Craft
[email-masked]

---

From: Ed Karch <[email-masked]>
Date: 25 Mar 1995 05:04:07 GMT

Paula M Craft <[email-masked]> wrote:
> bind in back and are well padded?  
> 
I found knee pads like the workmen use who do flooring at my local home center. 
These have a hard outer shell with soft padding inside and close with two 
velcro straps. If you drop down on a small stone the hard shell comes in handy.

---

From: [email-masked] (Christine Owens)
Date: 25 Mar 1995 17:07:10 GMT

>"It wasn't a mispent youth, just a busy one."

Having arranged for the extensive surgical rearrangement
of my body many years ago (ski accident), I can sympathize.
I have tried several different brands of commercial knee
pads, and never found one that a) stayed put, b) did not
bind in back.  My solution is a cotton bath mat which I
fold in thirds lengthwise, and move with me as I go;
and a gardening stool.

Chris Owens

---

From: [email-masked]
Date: Mon, 27 Mar 95 11:16:39 EST

>fold in thirds lengthwise, and move with me as I go;
 
A sports injury so many years ago (swimmer hangs from tree
on ski slope) taught me to be kind to my knees.  Like Chris
knee pads have never worked well for me.  I've found relief
with a foam pad about 18 x 6 inches.  It's thick, soft and
conforms to an uneven surface and when I sink in to it seems
to provide side support.  I know it's good for when I walk
away for another task my garden cat immediately takes my
place. - and I feel guilty removing him.
Should I get him a pad of his own?
 
Dave Vanderhoof

---

From: [email-masked] (CT)
Date: 28 Mar 1995 01:23:23 GMT

>> Like Chris
>to provide side support.  

I buy 9 x 16" foam pads cheap at those large "land-fill-in-the-making" 
stores like KMart. Probably a couple of dollars in their "garden" 
section.  Another option is the foam canoe seat pads sold by outdoor
rec suppliers like LLBean. (These are urethane covered foam and cost
more; but you get the logo, don't forget).  CT  [email-masked]

---

From: [email-masked]
Date: 27 Mar 95 21:12:23 -0600

> Should I get him a pad of his own?

Of course you should, Dave!  What sort of person did your cat pick???
;-)

Or you could try my solution:  My favorite pair of gardening
jeans has BIG patch pockets on the knees, into which I slip
a couple of very large heavy-duty kitchen sponges (well, mine
were actually sold as horse-washing sponges, but details, details!)

Kay Klier  [email-masked]