Subject: Azaleas

From: [email-masked] (Michael Harris)
Date: 15 Mar 1995 03:23:05 GMT

I'm new to Atlanta and azaleas in the garden.  Please advise the proper 
time to fertilize (before or after the flowering season) and what type to 
use.
Reply here or to [email-masked].
Thank you in advance, Michael Harris in Atlanta (3/14/95)

---

From: [email-masked] (kathy morgan)
Date: Wed, 15 Mar 1995 22:21:09 GMT

Michael Harris ([email-masked]) wrote:
: I'm new to Atlanta and azaleas in the garden.  Please advise the proper 
: time to fertilize (before or after the flowering season) and what type to 
: use.

As to the timing, I was told to wait until after the flowering season
so as to not stimulate new growth that would "cover up" the flowers.

Kathy