Subject: Horticulture, Landscape Gardening Books FS

From: Errol Porter <[email-masked]>
Date: Fri, 7 Apr 1995 09:25:45 -0400

Horizon Books now has an E-mail catalogue of 167 well-described
interesting and out-of-print books on Agriculture, Horticulture,
Landscape Gardening, Country Living, Birds and Plants. 

They were published between 1807 and the present, priced between $10 and
$1100 and include some hard to find items. 

If interested, please E-mail us directly (not the list).  Thank you. 

Errol Porter
Horizon Books	   rare & out-of-print  |  Travel, Voyages & Exploration
[email-masked]       (416) 226-4282	|  Natural History

---

From: [email-masked] (Gerry Roe)
Date: Tue, 11 Apr 1995 04:17:40 GMT

Please send me your email catalog of books. Thank you.