Subject: Re: I need nitrogen?!?

From: [email-masked] (AGodston)
Date: 23 Mar 1995 22:00:00 -0500

Also, take a soil sample and send it to your local extension service. 
They'll tell you very specifically what you need!  Good luck!

---

From: [email-masked] (AGodston)
Date: 23 Mar 1995 22:00:00 -0500