Subject: Re: PHONE #/ADDRESSES?

From: [email-masked] (CLNichols)
Date: 4 Apr 1995 20:49:22 -0400

Scoutland wrote:
:I would appreciate any help in locating the Siskiyou Rare Plant Nursery
in
:Washington; or the Bluestone Perrenials in Ohio.  Phone or address would
:be great.

Bluestone Perennials:  1-800-852-5243, 7211 Middle Ridge Road, Madison,
Ohio 44057

Cindy

---

From: [email-masked] (Scoutland)
Date: 3 Apr 1995 23:24:32 -0400

I would appreciate any help in locating the Siskiyou Rare Plant Nursery in
Washington; or the Bluestone Perrenials in Ohio.  Phone or address would
be great.

Scoutland

---

From: [email-masked] (CLNichols)
Date: 4 Apr 1995 20:49:22 -0400

Scoutland wrote:

Cindy

---

From: [email-masked] (CLNichols)
Date: 4 Apr 1995 20:49:22 -0400

Scoutland wrote:

Cindy

---

From: [email-masked] (Bob Batson)
Date: 6 Apr 1995 18:49:05 GMT

Scoutland ([email-masked]) wrote:
: I would appreciate any help in locating the Siskiyou Rare Plant Nursery in
: Washington; or the Bluestone Perrenials in Ohio.  Phone or address would
: be great.

	SISKIYOU RARE PLANT NURSERY		[CAT - $2, $5 overseas]
	2825 Cummings Road
	Medford, Oregon 97501
	Tel: (503) 772-6846

--
--------------------------------------------------------------------
Bob Batson				L 39 12 14 N  94 33 16 W
[email-masked]			Kansas City
[email-masked]			USDA zone 5b
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Under the most controlled conditions, the experimental apparatus will
do exactly as it pleases.

---

From: [email-masked] (Bob Batson)
Date: 6 Apr 1995 18:49:05 GMT