Subject: Angelica

From: [email-masked] (Wendy Taylor)
Date: 2 Apr 1995 14:05:03 -0400

In rec.gardens [email-masked] (Jim Mc7951) said: 
>Can anyone tell us of a source for Angelica? We really want to grow it but

>can't seem to find it. 
>Also, any hints on growing would be appreciated. Thanks in advance. 
 
Angelica (Angelica archangelica) is a biennial hardy through 
about zone 4. It is best when it's given partial shade and 
grown in moist, fertile soil. It becomes a huge plant in it's 
second year with 2 foot long, bright green leaves topped by 
yellowish green flower heads in midsummer. 
 
Angelica seeds have a very short viability period, usually only 
a few weeks. It's probably better to start with a plant instead 
of trying to buy seeds. Once the plant has become established, 
self sown seedlings should provide plenty of future plants. 
 
Although the plant is a biennial, it is sometimes possible to 
get a third year if you remove any flowers as they begin to 
appear. 
-- 
Wendy                  |Free email herb plant & 
Harbor View Garden Co. |seed catalog available  
[email-masked]  [email-masked]

---

From: [email-masked] (Jim Mc7951)
Date: 1 Apr 1995 06:59:22 -0500

Jim and Linnea McClellan
Jim McClellan

---

From: [email-masked] (Wendy Taylor)
Date: 2 Apr 1995 14:05:03 -0400

---

From: [email-masked] (cornell chesnik)
Date: 8 Apr 1995 01:45:45 GMT

>Also, any hints on growing would be appreciated. Thanks in advance.

Try Nichols garden Nursery. They are located in Oregon.
Their address is:
		Nichols Garden Nursery
		1190 North Pacific Highway
		Albany, Oregon 97321-4598

Their phone number is 503-928-9280.
Hope this helps.
Cornell

---

From: ettings <[email-masked]>
Date: Wed, 19 Apr 95 22:47:04 -0500

>>Can anyone tell us of a source for Angelica? We really want to grow it but
 
Richters Herb Catalog has it, goodwood, Ontario, Canada LOC 1A0.  You can
also order by e-mail at [email-masked].  They have it in seed form,
and also plant and dried-root form.