Subject: Re: Flower and Garden Shows

From: Susan Sanders <[email-masked]>
Date: 20 Mar 1995 14:54:06 GMT

In article <[email-masked]> Garbo02, [email-masked]
writes:
>I am looking for larger Flower & Garden Shows in the U.S.  ---  Love the

Well, the Ann Arbor Flower Show, put on by the University of Michigan's
Matthaei Botanical Garden (in association with other groups, I think)
will be this Thursday thru Sunday, March 23rd-26th.

---

From: Susan Sanders <[email-masked]>
Date: 20 Mar 1995 14:54:06 GMT