Subject: Sea Crop?

From: [email-masked] (BEN LIM)
Date: Mon, 20 Mar 1995 16:50:39 -0600

Does anyone know what Sea Crop is?

What is it good for and where can I buy some?

Thanks.

Ben 
[email-masked]

---

From: [email-masked] (D.F.S.)
Date: 22 Mar 1995 17:43:25 GMT

[email-masked] wrote:
: Help!  What is the frost free date for Salt Lake City, Utah?
: I'm speaking about the Valley, not up on the bench or foothills.
: My daughter who lives there called seeking gardening help and
: I am creating a seed starting and set-out plan for her.
: A father must respond to a daughter's request.
:  
: I left Salt lake City many, many years ago and seem to recall a
: tradition of June snows.  Not being much of a gardener at the time
: it had little impact on me - but I know differently now.
:  
: Suggestions from Salt Lake gardners would be most welcome.
:  
Hard to say.
The last frost last yr or the year before was march 12th.
I have USDA maps that say Apr 15.
The guy at Utah State Univ. Extension service says may 15th.
It snowed last night and will even harder in the next few days, so they say.
It is supposed to get down to 27 Deg Saturday.

I may be pushing it but I am going to try for the april date and cover
some things just to be safe.

Marc Christensen

---

From: [email-masked] (john shakula)
Date: 22 Mar 1995 00:20:50 GMT

The usual date of last killing frost for most of the Salt Lake Valley
is May 15.

It is traditional to plant frost tender plants such as tomatoes on
Memorial Day weekend.  Of course, many people plant earlier but they 
usually acknowlege that they're prepared to replant after a hard frost.
A little snow the first week of May is not uncommon (imagine red tulips
bending over under the weight of snow in the blossom) but this 
year has been quite warm (it's in the 60's today).  I've seen very 
hard frosts even into the first week of June, but this year I'm going
to plant early.

JR  
    Draper, Utah, USA
    [email-masked]                    

: Thanks,
: Dave Vanderhoof
:

---

From: [email-masked]
Date: Tue, 21 Mar 95 13:11:57 EST

Help!  What is the frost free date for Salt Lake City, Utah?
I'm speaking about the Valley, not up on the bench or foothills.
My daughter who lives there called seeking gardening help and
I am creating a seed starting and set-out plan for her.
A father must respond to a daughter's request.
 
I left Salt lake City many, many years ago and seem to recall a
tradition of June snows.  Not being much of a gardener at the time
it had little impact on me - but I know differently now.
 
Suggestions from Salt Lake gardners would be most welcome.
 
Thanks,
Dave Vanderhoof

---

From: [email-masked] (D.F.S.)
Date: 22 Mar 1995 17:43:25 GMT

Marc Christensen

---

From: [email-masked] (john shakula)
Date: 22 Mar 1995 00:20:50 GMT

JR  
    Draper, Utah, USA

---

From: [email-masked]
Date: Tue, 21 Mar 95 13:11:57 EST

Thanks,
Dave Vanderhoof