Subject: When to prune flowering cherry?

From: Jeff Martini <[email-masked]>
Date: 28 Mar 1995 16:55:34 GMT

When is the best time to prune a flowering cheerry tree?
I have  a 10ft Kwanzan Cherry that's pushing out buds now.
Should I wait until after the flowers have faded?
Is the same true for flowering fruit trees (peach, apricot)?
Your advice is appreciated.

Jeff
MA zone 6

---

From: [email-masked] (Cara Anthony)
Date: Thu, 30 Mar 1995 23:16:52 -0800

> Your advice is appreciated.

I'm no expert but I thought pruning was supposed to be done at the end of
the season, after all flowering and fruiting has occurred, and the weather
is getting colder.  Otherwise you will be cutting back while the tree has
its "juices flowing" which can damage it.  Can anyone corroborate this
info?
Cara Anthony