Subject: Re: Avocados - anyone?

From: [email-masked] (rrrrrrrrrr)
Date: Thu, 23 Mar 1995 08:17:35 +0100

In article <[email-masked]>, [email-masked] (Fred
Kirshman) wrote:

> Have been so far successful in growing an avocado from seed to 
> repotting.  However, lately it has been losing its leaves and wonder 
> what is the best light, indoor or outdoor and or feed to restore its 
> vigor.  Also what are its watering needs.? Thanks.

My avocado's are also going great guns. An avocado from seed may take 7 to
10 years to fruit. They prefer outside light and need frequent watering
but not too much. They also suffer from root rot so it's best if they are
mulched well hence reducing watering needs, and if planted in the soil you
should plant them in a built up mound. Mine love chicken manure.

Good Luck
Marnie Nelson
> -- 
> __________________________________________________________
> A foolish consistency is the hobgoblin of little minds.
>                         
>                                 Ralph Waldo Emerson
> 
> Fred Kirshman      [email-masked]     Santa Cruz, CA
> __________________________________________________________

---

From: [email-masked] (rrrrrrrrrr)
Date: Thu, 23 Mar 1995 08:17:35 +0100

Good Luck
Marnie Nelson