Subject: Dicentra assistance, please

From: [email-masked] (HollyTW)
Date: 1 Apr 1995 08:27:43 -0500

I was thrilled to find my 2nd year Dicentra with buds on it's
three-inch-tall person this morning.  I've not had good luck with these in
the past and really would like to succeed this year.  Mine is planted in a
very shady spot on the east side of the house.  What does it need to live
long and prosper?

Thanks in advance for all help!

Holly

---

From: [email-masked] (Gerald W. Roe)
Date: 1 Apr 1995 19:50:53 GMT

Your location for the Dicentra sounds right. It should have soil
that is rich and moist, but also light, pourous, and well-drained
so that water does not stand around the roots.
-- 
Trans-Pacific Nursery        Rare and Exotic Plants
Email catalog available      Timber Press books discounted