Subject: Bulbs and moving

From: [email-masked] (Daniela Sciaky)
Date: 13 Mar 1995 02:36:12 GMT

I'm moving in July to Albany, NY environs and I have just dug up some
mammouth Asiatic lily bulbs (here in Cincinnati, OH). Is it possible to
preserve the bulbs for transport or should I just return them to the
garden? How are these bulbs split?

Daniela Sciaky

---

From: [email-masked] (Christine Owens)
Date: 15 Mar 1995 11:40:36 GMT

>garden? How are these bulbs split?

Powder them with sulphur, and store in cool, dry, sand.  Plant 
when you get to NY.  Bulbs make bulblets, which can be split
off.  The main bulb should not be split.

Chris Owens