Subject: Re: Going NATIVE

From: [email-masked] (Bob Batson)
Date: 11 Mar 1995 19:25:44 GMT

Steve Graf ([email-masked]) wrote:
: I have recently developed an interest in species azaleas of which I have 
: 2 that grow very well in my garden.  I would be interested if anyone could 
: tell me where I might purchase native "species" azaleas suitable for USDA 
: zone 4/5.  Lots of nurseries seem to have hybrids but not species azaleas :(.
: Especially great would be locations in Quebec, Vermont, or New York State.
: Thanks in advance.  Steve

Wayside Gardens sells a few. Contact them at Hodges, SC 29695-0001.

--
--------------------------------------------------------------------
Bob Batson				L 39 12 14 N  94 33 16 W
[email-masked]			Kansas City
[email-masked]			USDA zone 5
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Under the most controlled conditions, the experimental apparatus will
do exactly as it pleases.

---

From: [email-masked] (Glenna Mileson)
Date: Fri, 10 Mar 1995 05:24:47 GMT

>Steve Graf, [email-masked] writes:
>>2 that grow very well in my garden.  I would be interested if anyone
>could 
>>tell me where I might purchase native "species" azaleas suitable for
>USDA 
>>zone 4/5.  Lots of nurseries seem to have hybrids but not species
>azaleas :(.
>

The Rhododendron Species Botanical Garden
PO Box 3789
Federal Way, WA  98063-3798
(206)838-4646

It's also a wonderful garden to visit.

---

From: [email-masked] (Ketzel Levine)
Date: 11 Mar 1995 02:51:18 GMT

Lots of nurseries seem to have hybrids but not species azaleas :(

I LOVE THESE PLANTS but know primarily wholesale growers who don't ship.
Catalogs to try include:
                  
                  Roslyn Nursery (Long Island) 516-484-1555
                  Greer Gardens (Eugene,OR) 503-686-8266
                  Forestfarm (OR) 503-846-6963

Someone who might help further is Jim Plyler at Natural Landscapes.
He's one of THE native woodie growers in this area: 610-869-3788.
He's a one-man band & might be hard to reach (and probably doesn't ship)
but it's worth the try...he carries at least 15 species.  all the best, kl