Subject: Blue Poppies

From: [email-masked]
Date: Thu, 23 Mar 95 10:00:22 CDT

Does anyone know of a source for blue poppies in the US?  seeds or plants are 
OK.  PS would they be hardy in the Minneapolis/StPaul area?

---

From: [email-masked] (Gerald W. Roe)
Date: 25 Mar 1995 19:11:32 GMT

I can provide you with a source of Meconopsis spp., but most
references do not list hardiness as lower than zone 6 for any
species, and most are listed as zone 7. I don't know your zone,
but it sounds like lower than that. Email me if you want to try
it anyway. Caveat: they are generally considered difficult to get
established, but then may be rampant. 
-- 
Trans-Pacific Nursery        Rare and Exotic Plants
Email catalog available      Timber Press books discounted