Subject: Re: Looking for Ponderosa Lemon Tree

From: [email-masked] (Jeremy D. Buckley)
Date: Mon, 20 Mar 1995 21:50:35 -0500

In article <[email-masked]>, David Kowalczyk
<[email-masked]> wrote:

> I hope this is the right newsgroup for this question.
> I was a the Spring Garden and Flower Show at Bayside Expo Center 
> here in Boston this past weekend.  In the amateur section was 
> displayed a Ponderosa Lemon Tree. The lemons were the size of
> grapefruits. As a kid, my parents has one, which they told me
> they got in Colorado.
> So I decided I would like to get one and try growing it myself
> as a container plant.  I have looked in Brecks, Burpee and 
> Wayside for either seeds or established plants. But no luck.
> Does anyone know of a place through which I could order seeds
> or an established plant?

Try:

Logee's Greenhouses
141 North Street
Danielson, CT 06239
(203) 774-8038

They sell plants.  I think they also have a variegated version of the
Ponderosa Lemon.

-- 
Jeremy Buckley                               [email-masked]
BTG, Inc., Vienna, VA                        (703) 734-6863

---

From: David Kowalczyk <[email-masked]>
Date: Mon, 20 Mar 1995 14:28:45 GMT

Dave

---

From: [email-masked] (Judy Karpen)
Date: Wed, 22 Mar 1995 20:00:49 +1026

> Does anyone know of a place through which I could order seeds

Well Sweep Herb Farm
317 Mt Bethel Ave. 
Port Murray NJ 07865
(908) 852-5390

Catalog is $2; they have good stuff IMHO. Cant ship to CA, AZ, OR, or WA though.

Also Edible Landscaping in Afton VA (they have an 800 number but i cant
find it right now) has an incredible selection of fruit producing trees &
shrubs, including the Ponderosa lemon. I've gotten bit by the dwarf citrus
bug, alas, and they've been REALLY helpful in feeding my addiction ;^>
(and giving me free advice on culture etc, which was much appreciated).
Hope this helps!

-- 
Judy Karpen                        "The line between scientific genius and 
[email-masked]      obsessive fanaticism is a fine one." --
Naval Research Lab               line from The Brain that Wouldnt Die
Washington DC                         garden: Zone 7 (Maryland)

---

From: [email-masked] (Judy Karpen)
Date: Wed, 22 Mar 1995 20:00:49 +1026

Well Sweep Herb Farm
317 Mt Bethel Ave. 
Port Murray NJ 07865
(908) 852-5390