Subject: Re: Radichio

From: ettings <[email-masked]>
Date: Fri, 7 Apr 95 00:14:02 -0500

Hpulizzi <[email-masked]> writes:
 
>Interested in growing radichio in the Middle Atlantic region.  Where do
>you get seeds?  Any advice or experience welcome.
 
Most catalogs that sell vegetable seeds sell radicchio.  Sometimes it's
listed in their "European"-or-"Vegetables from around the World"-or
whatnot section.  I tried it last year, and it was pretty easy, and
very good.
 
Carol

---

From: ettings <[email-masked]>
Date: Fri, 7 Apr 95 00:14:02 -0500

Carol

---

From: ettings <[email-masked]>
Date: Fri, 7 Apr 95 00:14:02 -0500

Carol