Subject: Re: Where to find Sweet Woodruff

From: [email-masked] (O3194)
Date: 23 Mar 1995 19:23:25 -0500

I was surprised not to find it offered in my catalogs. A neighbor gave me
some last spring. Here in Denver, it didn't do much last summer but this
spring its popping up all over at the base of a tree. After reading
letters though I'll keep it watered well, I have it mixed in with some
mints. 
good luck

---

From: [email-masked] (O3194)
Date: 23 Mar 1995 19:23:25 -0500