Subject: Re: Sweet Woodruff Seed

From: [email-masked] (Mark Foster)
Date: 28 Mar 1995 20:15:42 GMT

I found Sweet Woodruff seeds at a local discount lumber chain - Menards.
The packets were labeled "Plantation Seed Co. Easton, MA".  My question is
HOW DO YOU GET THEM TO GROW.  Rosetta Clarkson in "Herb's their culture and
uses" claims they require over a year to germinate.  Is anyone aware of a
method of inducing germination in a shorter time period?   Thanks, Mark Foster

---

From: [email-masked] (Pat and George Kiewicz)
Date: Wed, 29 Mar 1995 23:41:10 GMT

Mark Foster ([email-masked]) wrote:
: I found Sweet Woodruff seeds at a local discount lumber chain - Menards.
: The packets were labeled "Plantation Seed Co. Easton, MA".  My question is
: HOW DO YOU GET THEM TO GROW.  Rosetta Clarkson in "Herb's their culture and
: uses" claims they require over a year to germinate.  Is anyone aware of a
: method of inducing germination in a shorter time period?   Thanks, Mark Foster

According to the book 'From Seed to Bloom' Sweet Woodruff is easy to germinate,
but the seed must be fresh.  

The seed should be pre-chilled for 8-10 weeks before sowing.  
Surface sow the seed in pots, seal them in plastic bags,
and refrigerate for two weeks.  After that, the seeds need 
to be exposed to light, and kept at 50 degrees F.  
(Well, 'easy' must be a relative term.) 

Pat in Plymouth MI
-- 
                           ====================
        We do not speak for the Suburban Communications Corporation.
	The Suburban Communications Corporation does not speak for us.

---

From: [email-masked] (Pat and George Kiewicz)
Date: Wed, 29 Mar 1995 23:41:10 GMT

Pat in Plymouth MI

---

From: [email-masked] (Pat and George Kiewicz)
Date: Wed, 29 Mar 1995 23:41:10 GMT

Pat in Plymouth MI