Subject: Re: Bearded Iris Question

From: [email-masked] (Only Jules)
Date: 15 Mar 1995 09:36:00 -0500

I get my information from Cooley's Gardens Iris Newsletter (comes free
after I ordered a couple Iris last year).  First thing in spring is to
remove mulch (2 months before last frost date).  Anyway, address: 
Cooley's Gardens, 11553 Silverton Road NE, PO Box 126-NL,  Silverton, OR 
97381-0126.  Their Iris catalog is in color -- beautiful.

---

From: [email-masked] (TIGIBSON)
Date: 15 Mar 1995 18:50:21 -0500

i too am in zone 5 and at this time of year i pull mulch off (after snow
melts) and admire all the little shoots.
that's it's for a long time, these plants aren't high maintenance.
tigibson