Subject: Mexibell Sweet pepper

From: [email-masked] (Al R. Krismer)
Date: 26 Mar 1995 01:09:17 GMT

I would like to know if anyone has a seed source for the hyb. sweet
pepper (bell pepper) Mexibelle? I cannot find it this year in any
of the major seed catalogs. It is similar to the bell pepper only
hot.

Al

---

From: [email-masked] (Lynn Edwards)
Date: 25 Mar 1995 22:03:28 -0800

Al R. Krismer ([email-masked]) wrote:

: I would like to know if anyone has a seed source for the hyb. sweet
: pepper (bell pepper) Mexibelle? I cannot find it this year in any
: of the major seed catalogs. It is similar to the bell pepper only
: hot.

I have two sources:

The Pepper Gal                      Note:  This is new in their '95
P.O. box 23006                             catalog.  No description
Ft Lauderdale, Florida 33307               available since I only
Tel: 305-537-5540                          have a '94 catalog and a
Fax: 305-566-2208                          '95 short list.

Plants of the Southwest
Agua Fria, Rt 6, Box 11A
Santa Fe, New Mexico 87505
Tel: 800-788-SEED (orders - 24 hours 7 days - 
                   $20.00 Min order for Credit 
                   card orders [no minimum for check]) 
Tel: 505-471-2212 (questions, problems [9-5, M-F])
Fax: 505-438-8800

P of SW Description (of MexiBell V6101):

   A Hybrid.   The ribs inside this pepper give it a mild hot flavor.  
   The lobed fruits form abundantly on 2 ft. plants.  Use to add a 
   bit of heat to any recipe calling for sweet peppers.  Great for 
   stuffing.  (75 days from transplants).

   Packet (50 seeds) $1.25
   Plant $2.25

I've ordered from both companies with no problems.  Pepper gal has the 
biggest variety for peppers but you have to pay to get a catalog (even if 
you ordered big time the year before).  Plants of the SW will send a catalog 
for free on request, and also sells plants for those getting a late start.

--- Lynn Edwards
    Los Altos, California, USA