Subject: Re: Russian Olive in the PNW?

From: [email-masked] (Christine Owens)
Date: 22 Mar 1995 01:19:48 GMT

In <[email-masked]> [email-masked] (Matt Baney) writes: 

>
>I am thinking of planting a couple Russian Olives in my 
>back-yard?  Any comments or thoughts about Russian Olives?
>What caught my attention about them was that the catalog
>said they were heat and drought resistant, and were hardy
>and would tolerate poor soils and conditions?
>I live in the Seattle/Puget Sound area.
>thanks
>matt
>---------
> Matt Baney        Kent, Washington      [email-masked]
>  On the Internet people may not be able to tell if you're a 
>      dog or a fox, but they will know if you're an ass.
>------------
>
>--
> Matt Baney                               [email-masked]
>"All solutions should be as simple          I think having
>as possible, and no simpler!                opinions is stupid!
>     A. Einstein."
>

Well, I have seen some growing in Bellingham, so I guess
you could give it a shot; but Kent really doesn't have
drought and heat problems.

Chris Owens

---

From: [email-masked] (Carol Brandt)
Date: 23 Mar 1995 17:46:25 GMT

Why not use a native plant that is well-adapted to your area?  Russian
olives are from the Mediterrean.  Go to a local nursery and see what
native plants they sell from the NW coast.

Russian olive was widely planted in the SW as a wind break, but now it
has taken over thousands of miles along riparian habitats, resulting in
the loss of native vegetation.

---

From: [email-masked] (john shakula)
Date: 25 Mar 1995 02:54:44 GMT

Here in Utah, many (including yours truly) consider the Russian Olive
a noxious weed tree.  I am totally befuddled why anyone in the Pacific
Northwest would want to plant this species when there are so many fine 
trees which would thrive there.  

Anyone who wants a Russian Olive should come to Utah with a truck 
and a shovel and take all he/she wants for free!  

JR  
    Draper, Utah, USA
    [email-masked]                    

Carol Brandt ([email-masked]) wrote:
: Why not use a native plant that is well-adapted to your area?  Russian
: olives are from the Mediterrean.  Go to a local nursery and see what
: native plants they sell from the NW coast.

: Russian olive was widely planted in the SW as a wind break, but now it
: has taken over thousands of miles along riparian habitats, resulting in
: the loss of native vegetation.

---

From: [email-masked] (Christine Owens)
Date: 22 Mar 1995 01:19:48 GMT

Chris Owens

---

From: [email-masked] (Carol Brandt)
Date: 23 Mar 1995 17:46:25 GMT

---

From: [email-masked] (john shakula)
Date: 25 Mar 1995 02:54:44 GMT

JR  
    Draper, Utah, USA