Subject: Re: Advise needed on new Prunus Mt. Fuji

From: Susan Sanders <[email-masked]>
Date: 31 Mar 1995 14:35:39 GMT

In article <[email-masked]> LeVan Tran, [email-masked]
writes:
>About 2 weeks ago I planned a 25 gallon Prunus Mt. Fuji -- double white, 
>light pink followering cherry.   It's about 6 feet height.   

I had one for many years (actually it's still there; I moved) and never
fertilized it.  It did just fine and bloomed heavily every year.         
      -Sue Sanders

---

From: [email-masked] (LeVan Tran)
Date: 30 Mar 1995 21:14:27 GMT

Anyway,  I would like to know when I should start fertilizing the tree.

Thank you very much in advance

LeVan
(Milpitas/San Jose, California, Zone 9)