Subject: Fertilizing perennials (Rockery in particular)

From: [email-masked] (Grahame Rumsby)
Date: Mon, 13 Mar 1995 14:01:55 UNDEFINED

I planted a rock garden last year which is approximately 50 -60' in 
length..............
I was wondering what type of fertilizing should be done in the spring with 
these plants which are now beginning to see the light of day after the snow 
has melted...

Grahame

---

From: [email-masked] (Christine Owens)
Date: 15 Mar 1995 12:03:55 GMT

>these plants which are now beginning to see the light of day after the snow 

Manure tea has always worked well for me in areas where
I couldn't spread compost.

Chris Owens