Subject: Re: hands like sandpaper - help?

From: [email-masked] (Major)
Date: 5 Apr 1995 00:20:08 GMT

In <[email-masked]> [email-masked] (Meredith Morris-Babb) writes: 

>
>
>>In article <[email-masked]>
>
>>>> > what remedy can you suggest for mudbathed hands?
>>               {edited}
>> 
>>Bag Balm!  Try Bag Balm, your hands will love it.
>>And so will your . . . .
>
>
>Ditto Dan's rec on the Bag Balm!  FYI, Bag Balm is a cream used by
>cattlepersons and farmers to keep the the udders of cows smooth and suptle -
>and easily able to expand for the milk production.  you can find it a feed
>stores, or vet schools.  there is some other stuff there called Hoof majic
>that is great for your nails!
>
>Meredith
>

Norwegian formula Neutrogena, unscented, keeps my paws smooth. I've had
friends who swear by the "teat" balm suggested by Meredith.

---

From: [email-masked] (Judith C. Price)
Date: Mon, 3 Apr 1995 17:56:15 GMT

When I have rough hands, I use a tip from Mary-Ellen's Handy
Hints books.  She recommended it for smells like garlic on the
skin, but I think it works for that because it takes off the top
layer of skin.

At the sink, put a small pile of salt in your palm, dampen with
lemon juice (bottled works fine).  Rub the resulting paste all
round your hands, concentrating on the worst spots, but not being
too hard on the tender.  Rinse off, then apply vaseline or, in
less extreme cases, hand lotion.

This even works on the top, dirty layer of blackheads (uck!)
I don't find it irritating, unless I rub too hard, and it
leaves my hands nice and smooth,

Judith

---

From: [email-masked] (Major)
Date: 5 Apr 1995 00:20:08 GMT

---

From: [email-masked] (Judith C. Price)
Date: Mon, 3 Apr 1995 17:56:15 GMT

Judith