Subject: What is mushroom compost supposed to be?

From: [email-masked] (Liz Farrell)
Date: 27 Feb 1995 18:29:38 GMT

I ordered mushroom compost and came home to
a pile very raw, maggot/fly-filled horse manure.
Hence my question: What is mushroom compost supposed
to be?  I've always received well-composted steer
manure before.

Liz

---

From: [email-masked] (Hedlund)
Date: Tue, 28 Feb 1995 19:35:06 -0700

>From what I understand, it is manure that has had mushrooms grown in it. 
Supposedly, it has a PH closer to neutral than other composts, and a
higher microorganism population.  I know people who swear by it, though I
personally am still somewhat skeptical.

...-Dal (posting from my wife's account)
-- 
 - Tammy                       [email-masked]