Subject: azaleas

From: [email-masked]
Date: Wed, 3 May 1995 07:16:40 EST

How far apart should I be planting 1 gallon azaleas?
john pettey
davidsonville, md

---

From: [email-masked] (BEL2)
Date: 4 May 1995 15:23:11 -0400

a max of 18" on center and they should be triangularly spaced if you have
more than one row.  If you need to figure out how many 1 gal azaleas you
need calculate the sq footage and multiply by .5 for 18" o.c., .738 for
15" o.c., 1.15 for 12" o.c.
bl