Subject: Re: "Worms Eat My Garbage"

From: [email-masked] (PVTS)
Date: 30 Dec 1994 00:11:49 -0500

This book is available from Gardener's Supply Company at 802 863 1700.
Mail address is 128 Intervale Rd.  Burlington, VT 05401

---

From: [email-masked] (Glenn Harvey)
Date: Sat, 31 Dec 1994 22:05:05 GMT

In article <[email-masked]>, [email-masked] (Dick Lucas) says:
>
>
>Hi:  Does anyone know of a source for the book "Worms Eat My Garbage" by
>Mary Appelhof?  

>Dick Lucas   [email-masked]
>

The book may be ordered from Nichols Garden Nursery, 1190 North Pacific Highway, 
Albany, Oregon  97321-4580.  The cost is $8.95 plus $2.25 shipping & handling.
Their phone number is (503)928-9280  9 am to 5 pm Pacific Time.
Their fax number is (503)967-8406.  

I have had a worm bin for about a year.  Works great.  Hope this helps you.

Glenn Harvey
[email-masked]