Subject: Mycology Books

From: [email-masked] (Mark Spear)
Date: 24 Sep 96 15:16:53 -0700

Does anybody know where I can get a copy of Domsch et al. Compendium 
of Soil Fungi, 1980. Academic Press.

This has been harder than I would have guessed.  Any help would be 
apppreciated.

    ---- Mark

	[email-masked]

---

From: [email-masked] (Mara Linaberger)
Date: 24 Sep 1996 16:38:18 -0700

I once recieved a catalog of mycological books from:

Raymond M. Sutton Jr.
430 Main Street
Williamsburg, KY  40769
(606)549-3464 (day) or (606)549-2288 (evenings)
			(606)549-3464 (evenings)
FAX: (606)549-3469

The catalog had extensive listings of books out of print!  Good luck!
-Mara