Subject: Book on mushroom stamps

From: [email-masked] (Arpad Jaromy)
Date: 10 Jul 1995 13:54:00 -0400

:Looking for the Stanley Gibbons Thematic Catalogue: Collect Fungi on Stamps.
Where can I buy it?
Do you have any information?
Arpad

---

From: [email-masked] (RRudine)
Date: 18 Jul 1995 19:18:26 -0400

I share Arpad's Mycophilatelic predilection and request.
DOGFISHTUI