Subject: Help: Address of American Society of Agronomy

From: [email-masked] (S.M.Singh)
Date: Tue, 16 May 95 11:43:32 GMT

Hello there,

I am looking for the email and address of the American Society of Agronomy
and the Indian Phytopathological Society.

If anyone has the same please email me or post on the newsgroup.

Thanx in advance.

 Sheo M. Singh.

---

From: [email-masked] (Jessie Micales)
Date: Tue, 16 May 1995 12:46:59 GMT

> Sheo M. Singh. 

American Society of Agronomy
677 S. Segoe Rd.
Madison, WI  USA
53711
phone - 608-273-8080