Subject: Re: SOMA

From: [email-masked] (Arpad Jaromy)
Date: 20 Apr 1996 13:54:38 -0400

In <[email-masked]> [email-masked] (JStock6360) writes:
I'm looking for the book SOMA! Where can a get it and how much?

>I'd like to contact some Amanita muscaria experts or those who are
>interested and knowledgable of Wasson's theories.

---

From: [email-masked] ("K N and P J Harris")
Date: Sun, 28 Apr 1996 08:56:34 GMT

Evelyn Waugh will be delighted since he popularised the word even if he 
did not invent it.
Peter Reading, UK.