Subject: Chanterelles - Vancouver B.C.

From: <[email-masked]>
Date: 10 Aug 1995 00:15:20 GMT

Found a few pounds of Chanterelles last weekend in
North Vancouver. VERY firm and VERY tasty.

Paul

---

From: [email-masked] (Richard Winder)
Date: Thu, 10 Aug 1995 15:11:46 GMT

>North Vancouver. VERY firm and VERY tasty.

Yeah, we've got a few early ones that have popped up here on the Island
after all the rains hit.  -RSW

  RICHARD WINDER                    Title: Research Scientist
  Canadian Forest Service           Phone: (604) 363-0773
  Victoria, B.C.                    Internet: [email-masked]