Subject: fungi in martinique ?

From: <[email-masked]>
Date: 10 Sep 1995 15:18:12 GMT

Hi,
who knows something about mushrooms in martinique ? 
any keys, pictures, floras are welcome
i spend my holidays there and want to know what i can expect there
leaving end sept.
thanks, trix, berne, switzerland

---

From: [email-masked] (UNICORNbag)
Date: 12 Sep 1995 11:32:20 -0400

Try Rainforest mushrooms
P.O. Box 377
Roseau,
Dominica, West Indies
809 449 1836

Lou Hsu
[email-masked]