Subject: Peziza repanda edibility?

From: "Ralph D. Arnold" <[email-masked]>
Date: Sun, 19 Mar 95 22:45:54 PST

Arora in "Mushrooms Demystified" describes Peziza repanda as being edible.
Any experience with eating it?  Or culturing it?
Thanks!
Ralph Arnold [email-masked]

---

From: [email-masked] (MYCOCHEF)
Date: 21 Mar 1995 10:15:42 -0500

i know of some who use these as garnishes, cut into strips, similar to
adding aleuria aurantia in salads in the same manner.  David Arora would
not himself seek out a meal of these. . . .