Subject: The curse of the mummy

From: [email-masked] (David Pinero)
Date: 19 Jun 1996 00:43:36 GMT

I have heard recently discussions about the legendary "King Tut's curse" 
that claimed the lives of Lord Carnarvon (spelling?) and Carter as being 
probably fungus related. I have heard some speculations are about 
Aspergillus flavus or maybe Coccidioides immitis (Is it only new world 
fungus?). Anybody has some idea about this?

David

---

From: Fred Dickey <[email-masked]>
Date: Mon, 24 Jun 1996 22:22:32 -0700

Probably not Coccy.  Maybe Histoplasma?  Or..TB?  
OUR FUNGI ARE PERFECT!
 K. Clark  Gen-Probe R&D