Subject: Mycological Societies near Cupertino, CA

From: [email-masked] (Tom Santos)
Date: 1 May 1995 19:10:06 -0400

Are there any mycological societies that hold meetings (and outings) near
Cupertino, CA?  If so, please tell me their phone numbers and/or
addresses.

Thanks!

-Tom-

---

From: [email-masked] (BrianMc)
Date: 6 May 1995 10:40:32 -0400

Either the Fungus Federation of Santa Cruz, or the Mycological Society of
San Fransisco:

Fugus Federation of Santa Cruz
1305 Cliff Dr.
Santa Cruz, CA 95062-3722

Mycological Society of San Fransisco
P.O. Box 882163
San Fransisco, CA  94188-2163
----------------------------------------------------------
| Brian McNett                  e-mail: <[email-masked]>
| Editor: MycoInfo         Submissions: <[email-masked]> 
|        Promoting Mycology in the Online Community