Subject: Portabella mushrooms

From: [email-masked] (David Pinero)
Date: 15 Jan 1996 03:09:28 GMT

Can somebody tell me the scientific name of this species?

---

From: [email-masked] (UNICORNbag)
Date: 15 Jan 1996 18:19:10 -0500

Agaricus brunnescens, the common button mushroom , allowed to open, I
believe..
Lou Hsu
[email-masked]