Subject: Hawaiian field guide

From: [email-masked] (Bob Galvan)
Date: 10 Aug 1995 01:40:56 -0700

I'm going to Hana, on the wet side of Maui in a few weeks, and I'd like 
to study up on the fungi I might find there.   Can anyone recommend a book?

Bob Galvan
[email-masked]

---

From: [email-masked] (JMiller592)
Date: 10 Aug 1995 18:53:12 -0400

Try

 STEVENS, F.L.: Hawaiian Fungi. (Bishop Mus.Honol. 1925). 35 
figs  10 pls. Reprint. (009424)                                          
$70.00

Not quite a field guide but maybe of interest.  Possibly obtain from 

Koeltz Scientific Books
1911 N. Duncan Road
Champaign, Illinois 61821
phone 217 355 9331