Subject: Mutinus elegans

From: Kevin McCluskey <[email-masked]>
Date: 30 Oct 95 10:52:06 CST

Recently I received several queries about ridding an area of this
attractive fungus. The affected area is 30' X 60' and is apparently
mulched with wood chips.  The owner is interested in suppressing the 
production of fruiting bodies.  Any ideas?

---

From: [email-masked] (George Riner)
Date: Tue, 31 Oct 1995 05:01:40 GMT

My experience is that this lasts for one season.  Just live with it
for this year and it'll blow over.  Same for Phallaceae...