Subject: Mycology listserv?

From: [email-masked] (Michael Adams)
Date: 28 Mar 1995 22:26:00 GMT

Please, if there is a listserv related to Mycology, would someone be kind 
enough to point me at it? Thanks, all!

Mike.

---

From: [email-masked] (Richard Byrd)
Date: 29 Mar 1995 05:37:55 GMT

>enough to point me at it? Thanks, all!

If you get a positive answer to this will you relay the info to me also
please?  Thanks.