Subject: Info. on fungicide

From: NNBt <[email-masked]>
Date: 12 Sep 1995 16:56:30 GMT

I would appreciate if some one provides me information on
where I can get the following fungicides from.  
Kitazin P (IBP, s-benzyl diisopropyl phosphorothiolate)
edifenphos
Hinosan.
Any information would be helpful.
Thanks in advance
Boomi

---

From: NNBt <[email-masked]>
Date: 13 Sep 1995 18:35:05 GMT