Subject: Mushroom equipment

From: [email-masked] (Jason Dobranic)
Date: 13 Jul 1995 12:38:17 -0700

Hello,
	Can anyone recommend the best company to buy mushrooms growing
equipment and supplies from? I am in the Toronto, Canada so is there any 
in the area?

Thanks!
Jason

---

From: [email-masked] (_doc_)
Date: 14 Jul 1995 09:32:15 -1000

In article <[email-masked]>,
>equipment and supplies from? I am in the Toronto, Canada so is there any 

I dont know any in your area, however I would higghly reccomend:

Fungi Perfecti
P.O. Box 7634
Olympia, WA 98507 USA
(206) 426-9292

This company was founded/is run by Paul Staments and his family.  The 
catalog is filled with just about everything you need.

Mike

---

From: [email-masked] (UNICORNbag)
Date: 14 Jul 1995 18:59:59 -0400

Western Biologicals Ltd.-Aldergrove, BC- 604 856 3339 Bill Chelmers