Subject: Kombucha

From: [email-masked]
Date: Tue, 29 Aug 95 22:48:58 PDT

I have several colleagues who drink a tea in which the Kombucha fungus has 
grown.  This concoction is sometimes called "Manchurian Tea" and has reported 
beneficial health effects.  Does anyone have info pro or con about this 
practice?

---

From: [email-masked] ("K N and P J Harris")
Date: Wed, 30 Aug 1995 20:47:02 GMT

Try Cixnews alt herbs, they wouldn't dream of drinking anything else, or 
so you would think.
Peter. Reading, UK.