Subject: Edible & Poisonous Mushrooms of Canada

From: [email-masked]
Date: 18 Oct 1994 11:54:07 -0700

Excuse me if I am breaking any unwritten rules (and please
let me know [politely] if I am as this is all new to me).
 
We have several new copies of "Edible and poisonous mushrooms
of Canada" 326 pgs. by J.W. Groves, 1981 printing, available
for exchange only, one per person.  Is there any interest?
 
Scott Redhead

---

From: [email-masked] (RBruhn2513)
Date: 23 Nov 1994 10:45:27 -0500

In article <[email-masked]>, [email-masked] writes:

Please email me a [email-masked] with availability and cost of
this book.
Thanks,
Roger Bruhn (on my wife's account: [email-masked]