Subject: Genetic Engineering. Was Dennis Avery (fwd)

From: Victor Guest <[email-masked]>
Date: Sat, 02 Aug 1997 12:42:10 WST

To: Recipients of CHRM-GENERAL <[email-masked]>
Message-ID: <[email-masked]>
X-Gateway: [email-masked]
Errors-To: [email-masked]
Precedence: bulk
Lines: 14

Subject: Genetic Engineering. Was Dennis Avery

Is anyone aware of a good book/web site/listserv
which discusses critically and thoughtfully
the impacts of genetic engineering? 

Jim Wright
Box 129
Lougheed Alberta Canada
T0B 2V0
403 386-2479

---

From: sal schettino <[email-masked]>
Date: Mon, 4 Aug 1997 08:53:43 -0700 (PDT)

my homepage has a lot of GEN. Eng. links.
http://www.rain.org/~sals/my.html
On Sat, 2 Aug 1997, Victor Guest

> the impacts of genetic engineering? 

Sal Schettino,Organic Farmer,don't panic eat organic,[email-masked]
or check out my homepage:            http://www.rain.org/~sals/my.html    .