Subject: Equador locations/info wanted

From: "Mark J. Dixon" <[email-masked]>
Date: Tue, 21 May 1996 19:51:32 +0000

I have a Net-less friend who is off to Huigra (4-5 hours from Guayquil on
the Pacific Coast) in Equador at the end of June.  He is looking for good
Leps-spotting places to visit and any good books on information about
Equador, its Leps, Tarantulas, Beetles etc.

Can anyone out there help?

Regards,
Mark Dixon
Homepage: http://dialspace.dial.pipex.com/mark.dixon/
(one day it will be good..)

---

From: "Mark J. Dixon" <[email-masked]>
Date: Mon, 24 Jun 1996 23:15:03 +0000

Hi Charlie,

My firend is off this Friday,  so any more exact details you could provide
would be gratefully received..

At 13:50 03/06/96 EDT, you wrote:
>Dept. of Biology, Univ. of Louisville, Louisville, KY 40292
>PHONE: (502) 852-6771
>
>The best spot I know up from Guayaquil is the one I just returned
>[snip]
>moths, and birds.  Let me know if further information needed.

---

From: "Charles V. Covell Jr." <[email-masked]>
Date: Mon, 24 Jun 1996 21:21:42 EDT

Dept. of Biology, Univ. of Louisville, Louisville, KY 40292
PHONE: (502) 852-6771
That's about all I can pinpoint.  Another idea is to go to Tena or Puyo,
stay in a cheap hotel, and find the nearest trail through a rain forest
habitat, which are getting harder to find nowadays.

Charles V. Covell Jr.   [email-masked]
Dept. of Biology, University of Louisville
Louisville, KY 40292-0001   PHONE: (502) 852-6771 (office)
(502) 852-0725 (FAX); (502) 456-6122 (home).  "So many bugs..."