Subject: wtb: Ernst J. Dornfield. 1980. The Butterflies of Oregon.

From: [email-masked] (Carol Witham)
Date: 1 Apr 1996 00:11:38 GMT

If you have a copy you would like to sell, please email me.
Carol Witham   --->   [email-masked]

---

From: Stephanie McKown <[email-masked]>
Date: Tue, 2 Apr 1996 15:06:05 -0500

have a copy...not selling at this time.