Subject: journal of tropical lepidoptera

From: Ken Adams <[email-masked]>
Date: Wed, 1 May 1996 10:39:07 GMT+120

Can anybody out there tell me how to get hold of the Journal of
Tropical Lepidoptera
----------------------------------------------------------------------
Ken Adams
Zoology Department
University of Fort Hare
P Bag X1314
Alice, SOUTH AFRICA

Phone (W) 0404-2337
Fax (W) 0404-31669, 0404-31643
e-mail [email-masked]
----------------------------------------------------------------------

---

From: Henry Brodkin <[email-masked]>
Date: Wed, 1 May 1996 02:44:08 -0700

> Can anybody out there tell me how to get hold of the Journal of

They have a neat Home Page at: http://www.troplep.org - if you can set
your browser.
I'd get the address for you - but I can't reach the page right now.
Cheers1
--
               Hank Brodkin, Marina Del Rey, CA
                  33.58'24"N  118.27'39"W
             For Info on the Calbird-L Mail List
               Send mailto:[email-masked]