Subject: need info on Eacle imperialis pini?

From: Patrick Marceau <[email-masked]>
Date: Sat, 7 Dec 1996 10:15:04 -0400

I need information on Eacle imperialis pini

1. Recognition marks between Eacle imperialis pini and Eacle imperialis.
2. Habitat and food plants
3. Distribution
4. Flight time (hours)

Thank
Write directly to: [email-masked]

---

From: Paul Opler <[email-masked]>
Date: Mon, 9 Dec 1996 09:09:50 -0700

Try the new book on North American Saturniidae by Tuskes et
         al. just published by Cornell Univity Press. Paul Opler