Subject: Re: (no subject)

From: Chaweewan Hutacharern <[email-masked]>
Date: Sat, 8 Jul 1995 05:58:26 +0700

Anybody please tell me how to be a member list of the Annal Rev.
Entomology.Thank you.
Chaweewan

---

From: [email-masked] (DanauSakai)
Date: 10 Jul 1995 23:33:34 -0400

Write to Annual Reviews, Inc.  4139 El Camino Way, P.O. Box 10139, Palo
Alto, CA 94303-0139, USA.  Tele:  (415)493-4400.
You will be put on their annual mailing list for each volume.  You get a
10% discount for early payment.  You can remit via plastic $.