Subject: Re: Nomophila noctuella migrating

From: Lawrence Simons <[email-masked]>
Date: 25 Jun 1996 00:27:03 GMT

Dear Group:

I am seeking information pertaining to a month I recently found here in the Atlanta,GA area..
It is apporximately 2 inches long.  Viewing downu upon the wings, it has a pattern much like  a 
cowery seashell, mainly white with  small black boxes filled with white or off-white roundish 
centers.  The belly is pure white with two lateral rows of 5 black spotss.

Any information provided would certainly be appreciateed

Lon Simons
[email-masked]

---

From: John Himmelman <[email-masked]>
Date: Tue, 25 Jun 1996 13:49:03 -0400

Could it be Ecpantheria scribonia (Giant Leopard Moth)?  They tend to be very
"tame" and will latch onto your fingertip for as long as you would like.

John Himmelman, CT USA
[email-masked]