Subject: Re: Caterpillar I.D. help

From: Nathan Schiff <[email-masked]>
Date: Wed, 26 Jul 1995 18:01:02 -0400

Its probably Datana integerrima  family Noctuidae.  The walnut moth.  Nathan

---

From: [email-masked] (ARBORGUY)
Date: 26 Jul 1995 20:04:37 -0400

Kinda sorta sounds like a Tussock moth, Be careful not to touch it, they
have been Known to raise hell with our skin.