Subject: Mail Order Suppliers (2nd of Several -- long)

From: [email-masked] (Stuart Friedberg)
Date: 30 Dec 92 05:40:48 GMT

I have ordered successfully from each of these companies.

Stu Friedberg ([email-masked])

Blue Ridge Machinery and Tools, Inc.

  Lathes, milling machines, presses, brakes, from puny to industrial.
  Accessories and parts for popular machines from Myford, South Bend,
  Atlas, Sherline, Emco-Maier, etc.
  Hand tools and books of interest to hobbiests and professionals.
  Woodworking power tools
  Steel, brass, aluminum, tool steel in small quantities.

  110 page catalog

  PO Box 536
  2806 Putnam Avenue
  Hurricane, WV  25516
  800-872-6500
  304-562-3538
  304-562-5311 (fax)
  Credit cards, COD's up to $200
  M,W,F 9-5 EST, Tu,Th 9-9 EST

Enco Manufacturing Co.

  Lathes, milling machines, etc, from small to large NC machines.
  Hand tools, cutting tools, storage cabinets, shop supplies
  Maker (not just distributer) of turret bed lathes

  230 page catalog

  13 stocking locations, main site in Chicago, IL (addresses not handy now)
  800-873-6260 (24 hr orders, automatically routes to closest location)
  800-873-6264 (fax, also auto routes)
  Credit cards, COD's up to $500, discount for pre-pay by check
  $25 minimum order
  Customer service & Chicago showroom M-F 7-midnight CST, Sa 8-4 CST, Su 9-4 CST

Kitts Industrial Tools

  Cutting tools, hand tools, air tools, supplies
  Quality ranges from ultra-classy, great deals, garbage-at-any-price import

  150 page catalog

  22384 Grand River Avenue
  Detroit, MI  48219
  800-521-6579
  313-538-2585
  313-538-6499 (fax)
  Credit cards, COD's
  $25 minimum order
  M-Sa 9-5 EST

Industrial Pipe and Steel Co.

  Cutting tools, hand tools, air tools, lathes, milling machines, you name it
  Shop supplies, tool and die maker supplies, you name it.
  Metal of all sorts, you name it.  New and used press die sets.
  Surplus rounds and plates.  Buy by the foot, buy by the pound.
  (I have had them send me 1.25" long slices off a Schedule 80 6" steel
  pipe with no questions asked.)  Most of their metal stock is not
  listed in the catalog(s).  Call and ask what they've got.
  Definitely oriented toward professional users, not hobbiests.
  Full line distributors for most instrument makers, Starrett, Mitutoyo, etc.
  Quality ranges from ultra-classy, great deals, garbage-at-any-price import

  Small catalog several times a year, 200 page catalog once or
  twice a year, and a 750 page full-line catalog once every five
  years.  They came out with a full-line catalog in 92.  Get one if you can.

  9936 E. Rush Street
  South El Monte, CA  91733
  800-423-4981
  818-443-9467
  818-579-4602 (fax)
  Credit cards, COD's
  M-F 7:30-4:30 PST, Sa 7:30-1 PST

Wholesale Tool  (MY FAVORITE)

  Broader selection of hand tools, fewer large machines than IP&S.  Fork lifts.
  No bulk metals, but tool steel, shim stock, threaded rod, etc.
  Vast selection of cutting tools and grinding wheels.  Scattering of
  interesting surplus items.
  Definitely oriented toward professional users, not hobbiests.
  Full line distributors for most instrument makers.

  500 page full line catalog twice a year.  You have to order by 8 digit
  stock number, so copy carefully.  :-)

  6 locations, main site in Warren, MI.  Most items at most locations,
  some items in Michigan only, very few at other locations only.
  Credit cards, COD's with some payment restrictions
  $25 minimum order

  PO Box 68
  Warren, MI  48089-0068
  12155 Stephen Drive
  Warren, MI  48089-3962
  800-521-3420
  800-521-3661 (fax)
  313-754-9270
  313-754-8652 (fax)

  PO Box 481
  Stoughton, MA 02072-0481
  1234 Washington Street (Route 138)
  Stoughton, MA 02072-3345
  800-343-1008
  617-344-0338
  617-341-0617 (fax)

  PO Box 700
  Brandon, FL  33509-0700
  9212 Adamo Drive
  Tampa, FL  33619-2631
  800-237-4689
  813-623-3099
  813-623-5816 (fax)

  PO Box 470952
  Tulsa, OK  74147-0952
  9909 East 55th Place
  Tulsa, OK  74146-6404
  800-331-4075
  918-627-2240
  918-627-2044 (fax)

  PO Box 240965
  Charlotte, NC  28224-0965
  4200 Barringer Drive
  Charlotte, NC  28217-1512
  800-438-3580
  704-527-4071
  704-523-7960 (fax)

  8100 Pinemont Drive
  Houston, TX  77040-6522
  800-231-4585
  713-895-7777
  713-895-8113 (fax)

---

From: [email-masked] (Henry E. Schaffer)
Date: Thu, 31 Dec 1992 02:14:48 GMT

No one has mentioned:

Harbor Freight Tools
3491 Mission Oaks Blvd.
Camarillo, CA  93011-6010
800 423 2567

  They mostly sell cheap tools.  Usually cheap = inexpensive, 
sometimes cheap = junky.  All (or most all) imported.  They
are best for items which have a lot of metal in them and for
which fine/precision is not your main objective.  They have
really great buys on anvils, cold chisel sets, screwdriver
sets, tinsnips, crowbars, ... and free shipping (other than 
a $2.95 handling fee) for orders over $50.

--henry schaffer