Subject: Looking for SKF

From: [email-masked] (Chris Luchini)
Date: Mon, 21 Dec 1992 23:15:18 GMT

Does anyone know the US distributor for SKF
machine tools? I'm looking for a 15mm x 1mm thread pitch
taper and plug tap. They supposidly have it in stock.

-c
*1110 W. Green/Urbana IL 61801/217-333-0505/[email-masked]

---

From: [email-masked] (Jack Schmidling)
Date: 29 Dec 92 23:00:27 GMT

By the strangest coincidence, I was in the bus yellow pages under bearings
and founr SKF Industries Rolling Meadows... 708 394 0066

js