Subject: Re: Need Harbor Fr. phone #

From: [email-masked] (Joe Landau)
Date: Thu, 23 Sep 1993 04:43:08 GMT

In article <[email-masked]>, [email-masked] ([email-masked]) writes:
>I lost my catalog for Harbor Freight.  Could someone E-mail the
>800 number?  Thanks

800 423 2567

---

From: [email-masked] (Soren LaForce)
Date: Fri, 24 Sep 1993 17:25:00 GMT

In article <[email-masked]>, [email-masked] (Joe Landau) writes...
>>I lost my catalog for Harbor Freight.  Could someone E-mail the

Just call (800) 555-1212 for 800 information.

--Soren            [email-masked]