Subject: Knife Making

From: [email-masked]
Date: 7 Sep 93 20:10:15 -0800

My husband is interested in finding information on knife making 
and for Canadian suppliers of knife making supplies and tools.

Mary Street			[email-masked]

---

From: [email-masked] (Steve Lindsay)
Date: Thu, 9 Sep 93 02:23:04 GMT

>Mary Street			[email-masked]

Here are two, not Canadian though.

Koval Knives 
460D Schrock Road
Columbus, Ohio 43229
800 556 4837

K & G Finishing Supplies
P.O. Box 458
Lakeside, Arizona 85929
800 972 1192

---

From: [email-masked] (Geoffrey Keyes)
Date: Thu, 9 Sep 1993 15:27:05 GMT

There are two US mags that deal with knives and their makers.
"Knife Illustrated" and "Blade".  KI is the best (IMHO) for suppliers and
such.  One of the gun mags also publishes a "Best of" once a year and it has
suppliers of tools, steel, finished blades, and all that kind of stuff.

Geoff Keyes

---

From: [email-masked] (Steve Lindsay)
Date: Thu, 9 Sep 93 02:23:04 GMT

Koval Knives 
460D Schrock Road
Columbus, Ohio 43229
800 556 4837

K & G Finishing Supplies
P.O. Box 458
Lakeside, Arizona 85929
800 972 1192

---

From: [email-masked] (Geoffrey Keyes)
Date: Thu, 9 Sep 1993 15:27:05 GMT

Geoff Keyes