Subject: mini-torches

From: [email-masked] (Amanda M Powell)
Date: 21 Nov 1993 18:34:43 GMT

just wanted to find out what kind of experiences people have had with 
mini-torches that run on butane...

---

From: [email-masked] (Amanda M Powell)
Date: 21 Nov 1993 18:40:29 GMT

ignore it