Subject: Metric screws

From: [email-masked] (Jeff Sweeney)
Date: Mon, 24 Jan 1994 22:00:27 GMT

I'm looking for metric screws, oval head, 3x0.5, 3-5mm long. Does
anyone know of a good source?
-- 

Jeff                                     [email-masked]

---

From: [email-masked]
Date: 24 Jan 94 21:18:33 PST

> anyone know of a good source?

Small Parts Inc.
13980 N.W. 58th Court
P.O. Box 4650
Miami Lakes, FL 33014-0650

(305) 557-8222 (Voice)
(800) 423-9009 (FAX)

If you can settle for stainless steel, they have what you want.
The shortest they have in that size is 10mm.   The part
number is Q-MMOX-3-10O.   $2.08/10   $4.55/25   $15.62/100
                     ^
               "O" for "Oval"

If you would prefer nylon, the part number is Q-MMN-3-6O (6mm long).
$1.17/10   $2.05/25   $6.00/100   $25.89/1000

--  Alan E. Frisbie               [email-masked]
--  Flying Disk Systems, Inc.
--  4759 Round Top Drive          (213) 256-2575 (voice)
--  Los Angeles, CA 90065         (213) 258-3585 (FAX)