Subject: Re: Silver Prices

From: [email-masked] (bill nelson)
Date: Wed, 10 Nov 1993 06:02:55 GMT

[email-masked] (Marc Edgar) writes:
: Greetings,
: 
: I hope I am not taking up too much bandwidth to ask
: something that is sort of in the FAQ and sort of not.
: 
: I would like some Christmas orniments out of Sterling
: silver.  The only supplier that I have dealt with is 
: Rio Grande.  Their going for 6", 22 gauge sheet stock is the
: market price + $5.00 +- per oz  + $1.50 handling + $4.00 postage.
: 
: Is this a reasonable price for a 5 oz order?  Any suggestions 
: on where to go for a better price?

That sounds about normal for a small order.  You may be able to get
down to spot + $2 or thereabouts for 100+ ounce orders.  Find out
where they have their price breaks. Sometimes, it pays off to make
a larger purchase.

Bill

---

From: [email-masked] (Neil R. Marsh)
Date: 9 Nov 1993 21:38:19 -0800

In article <[email-masked]> [email-masked] writes:

> 
> I hope I am not taking up too much bandwidth to ask
> something that is sort of in the FAQ and sort of not.
 
        Don't sweat it, this ain't comp.os.linux.help. ;) 

> I would like some Christmas orniments out of Sterling
> silver.  The only supplier that I have dealt with is 
> Rio Grande.  Their going for 6", 22 gauge sheet stock is the
> market price + $5.00 +- per oz  + $1.50 handling + $4.00 postage.
> 
> Is this a reasonable price for a 5 oz order?  Any suggestions 
> on where to go for a better price?

        I've not bought much sheet this year, but Rio's always been com-
petitive.  You might check TSI, Inc., 800/426-9984.  Sometimes they beat 
Rio, sometimes they don't.  I usually use them because I'm frequently in 
Seattle anyhow and can save P&H by going to their showroom.
 
        How hard would it be to collect fabrication fee tables from 
several suppliers and post an average in the FAQ?  Even just the entries 
for sheet, round, half-round, & square wire, and plain bezel stock would 
be useful info.  (Individual suppliers might balk at us publishing their 
catalog info, but if we come up with an average from several of them they 
should have nothing to gripe about.  It's a thought.)

Cheers!
Neil
--
------------------------------------------------------------------------
Neil Marsh  [email-masked] -or- [email-masked]  Chehalis, WA USA