Subject: Re: Titanium quest

From: [email-masked] (Eric Perozziello)
Date: Sat, 19 Feb 94 04:05:17 GMT

[email-masked] (Angela Voll) writes:
>Gary Paisley ([email-masked]) wrote:
>
>: >[email-masked] (Blake Werner)
>: >Organization: Pharmacology @Cornell
>: >I am in search of 4" Titanium rd. stock for a large fly reel.
>
> I am also searching for ti. Anyone know of a company(s)
>in Canada that sell "scrap" titanium? Also I am searching
>for 8000 aluminium ??? That or decent quality "scrap"
>7075 would be nice also.

I wouldn't doubt it if your local steel supplier has it. Our
local place (Allen Steel, Redwood City, northern california)
has lots of Aluminum alloys, titanium stock, and stainless
(300 and 400 series).  They also carry lots of scrap along
these lines.   (Maybe it's just because this area is so
heavily "semiconductor industrialized".)

-Eric

-- 
Why would CONGRESS specifically EXEMPT themselves from the Clinton
health care plan if it's "such a good deal" for the average American?
Maybe it's NOT such a good deal afterall.  Look in the mirror to see who pays.
(REFERENCE: S.1227, introduced by Sen. G. Mitchell.) Truth hurts, eh Willy?

---

From: [email-masked] (Eric Murray)
Date: Sun, 20 Feb 1994 00:03:12 GMT

>heavily "semiconductor industrialized".)

What's the usual price for scrap aluminum?  When I bought some
from Allen Steel, it was $3.50/lb, which seemed like a lot to me.

--
  Eric Murray                                             [email-masked]
      "Archiving the net is like washing toilet paper!"- Leader Kibo

---

From: [email-masked]
Date: 21 Feb 1994 01:52:20 GMT

>from Allen Steel, it was $3.50/lb, which seemed like lot to me.

The world price for prime aluminum is less that $ 1300.00 per 
metric ton or less than $ .60 per pound.  Scrap is always less.
Right now UBC's (used beverage containers, i. e. cans) is about
$ .40 per pound.  All other scrap has about the same value.  If you
are buying, not selling, you will of course pay more for something
that is useful to you, for something besides remelting.  I would
say that if you pay more than $ 1.00 per pound for scrap aluminum
then you are getting ripped off.

Keep in mind that price are market driven and aluminum is in the level
of high over supply because of the large amounts of metal coming out
of Russia.  They are no longer running one of the worlds largests aluminum
industries to make aircraft but are selling the base metal for
hard currency.  Major aluminum companies world wide are currently
reducing their smelting production by large amounts and I think
that the price will rise.  (Most if not all producers are lossing
big $$$$ on aluminum smelting right now, market forces at work.)
While those of us who use the metal like low prices I would like the
aluminum industry to at least be makeing some money, or I will not have
a job.  To be realistic base metal prices need to be about $0.70 per pound.
Useful forms, sheet, plate, extusions, tubing, etc. will of course
be more because of the fabrication cost beyond smelting.

Dave Smucker, (ALCOA, Mechanical Engineering, Flat Rolled Products)

---

From: [email-masked] (Michael J. Edelman)
Date: 21 Feb 1994 14:12:13 GMT

>from Allen Steel, it was $3.50/lb, which seemed like a lot to me.
You have to differentiate between scrap, which is cheap, and finished stock
trimmings. Scrap is indeed well under $1.00/lb, but you will pay much more 
than this for odd sizes of finished stock- but still less than for custom
sized orders. 

I notice that the regular suppliers of finished stock to the hobby industry
sell aluminum for around $6-7/lb; I can buy trimmings at a local non-ferrous
supplier for $3.25-$3.60/lb; and I can buy real scrap at a fraction of that.
But the trimmings are of known alloys and known hardness. 

--mike

---

From: [email-masked]
Date: 21 Feb 94 10:25:53 PST

>>from Allen Steel, it was $3.50/lb, which seemed like a lot to me.

Industrial Pipe & Steel Co. in South El Monte, California,
currently charges $1.90 for aluminum "remnants".   I just
bought a 6" x 9" x 1.25" aluminum plate at that price.   I
don't know what they charge for "new" stock since their
aluminum remnant stock is quite good.

Buying remnants is a much better deal if you are not fussy
about the exact alloy.   For example, I just bought some
cold-rolled steel "rounds" (3.5" - 4.25" diameter).   I could
only find one of the sizes I needed in the remnant bins, so
I had to pay full price for some.   The prices for 1018 CRS 
were $0.87 and $1.07 per pound.   The price for an unknown 
alloy (but probably 1018) remnant was $0.40 per pound.

In addition, IPS charges $3.00 for cutting off the length I
require.   For a slice of 4.25" CRS, I consider this quite
reasonable, since I don't have a a cut-off saw.

Back to aluminum.   The last time I looked, the local recyclers
were paying $.60 to $0.80 per pound of aluminum cans.
Personally, I prefer to take them over to the Los Angeles
Live Steamers in Griffith Park and run them through their
steam-powered can crusher.   It is lots of fun and they use 
the proceeds to fund site improvements.   If you live in the
Los Angeles area, start saving up those cans for the big
Spring Meet in May.   :-)

--  Alan E. Frisbie               [email-masked]
--  Flying Disk Systems, Inc.
--  4759 Round Top Drive          (213) 256-2575 (voice)
--  Los Angeles, CA 90065         (213) 258-3585 (FAX)

---

From: [email-masked] (Maldoror 2)
Date: 8 Apr 1994 11:53:03 -0400

I found various forms of ti at a mail order store called Reactive Metal
Studios.  They also carry Niobium and some others.  As far as I can remember,
they are located in Arizona?  Check Metalsmith Magazine for their ads.

---

From: [email-masked]
Date: Mon, 11 Apr 1994 04:08:57 GMT

> they are located in Arizona?  Check Metalsmith Magazine for their ads.

Years ago I used to visit a friend whose father had worked for some aircraft
firm. He had made a _curtain_ of titanium washer-lokking-thingies, each about
1" in diameter with a 1/2" hole in the center. The curtain separated the
disco-like entertainment area from the bar. It was in the late '70s...

Awwwwww Freak Out!    (oooo! Remember that one?!!)

-- 
** [email-masked] | (502) 491-1900 x401 | All opinions my own **
I've seen the needle and the damage done, A little part of it in everyone
But every junkie's like a setting sun. -- Neil Young