Subject: Re: oxyacetylene welding equip advice sought

From: [email-masked] (Eric Perozziello)
Date: Fri, 25 Mar 94 02:32:20 GMT

[email-masked] writes:
>
>I am about to make the plunge and purchase
>a complete outfit for oxyacetylene welding.
>I don't want to to get the cheapest equipment
>nor do I want the most expensive, but something
>of professional quality that will last a long
>time.  The problem is, I don't really know what
>the reputation of the different brands are and
>what features are important.  Were talking here
>basically about regulators and a torch.  Any
>advice anybody can offer will be greatly appreciated.
>(By the way, I intend to use this mainly for mild steel
>and a little for high temperature steel.)

IMO, Harris and Victor are the brands of choice.  I currently
own a Victor. And they're not that much more $ than the "junk"
that's out there.

I'd be interested in hearing others' opinions....

-Eric

-- 
Al Gore: "President Clinton is running this country in a way that it 
          hasn't been run in a long time."
Me:      "Yeah, since Nixon." 
                Whitewater can be dangerous. Ask Vince Foster.

---

From: [email-masked] (Andrew Vida-Szucs)
Date: Mon, 28 Mar 1994 15:13:52 GMT

Steve Schiller writes:

> time.  

	Want cake, want eat cake... hmmmm.
	
	Victor or Smith's torches are the best I know of.  If you want them
	for a lifetime, wait a bit longer, save the $$, and get the one's
	worth having.  Get regulators without diaphragms.  When the diaphragm
	goes, the regulator is useless, and potentially dangerous.  A farmer
	in the Freehold NJ area blew his barn and himself literally sky high
	back around 1970, when a faulty diaphragm leaked acetylene.  He lit
	the torch and took a one way trip to the morgue, after going round
	trip to the moon.  A very rare event, to be sure, but one which I `	
would gladly pay extra $$ to avoid.  Also, I have found replacement of
	diaphragms to be a pain in the ass. YMMV.

> The problem is, I don't really know what

	I would not go cheap-O.  Good tools are safe tools.

	-Andy V.