Subject: ENCO Lathe ?

From: [email-masked] (John Urbanski)
Date: Wed, 30 Mar 1994 22:20:49 GMT

Anyone have comments (good or bad) about an Enco 12x36 bench lathe?

Thanks John

---

From: [email-masked] (Paul Jones)
Date: 31 Mar 1994 03:20:37 GMT

>Thanks John

If it is any help to you, Nov/Dec 1993 HSM has an evaluation
of the Enco 12x26.

------
Paul Jones,  Motorola MCG                           [email-masked]
1101 E. University Ave.                             Voice: (217) 384-8529
Urbana, IL 61801, USA                               FAX:   (217) 384-8550