Subject: Cutoff Tool for Metal lathe

From: [email-masked] (Bradley Teets)
Date: 23 Dec 1994 05:26:40 GMT

Intrested in a cutoff tool for a production metal lathe.
Any brand reccomendations?

---

From: [email-masked] (Gary Helfrich)
Date: 25 Dec 1994 10:34:23 -0800

Bradley Teets ([email-masked]) wrote:
: Intrested in a cutoff tool for a production metal lathe.
: Any brand reccomendations?

Kennametal KGSP-U series. Far better than anything that Iscar makes.

Gary Helfrich 
Arctos Machine

---

From: [email-masked] (ed smith)
Date: 28 Dec 1994 17:37:22 GMT