Subject: 3-D surface types and Mastercam

From: [email-masked] (Alan Frisbie)
Date: 25 Sep 94 10:40:04 PST

I am using Mastercam (v4.11) to design a blade for a turbine,
and then generate the toolpath for a CNC mill.   At least 
I am attempting to do so.

The problem is that the Mastercam manuals assume that you 
already know all about the different types of 3-D surfaces
and when & how to use them.    As a novice in the world
of 3-D surfaces, I need some introductory help.   Can
anyone here point me at a good book that will explain the
following types of surfaces and when/how to use them,
particularly when applied to CNC machining?

    Loft        Ruled       Swept
    Nurbs       Blend       Parametric
    Coons       Revolution  Bicubic approximation

Also, *any* books that teach how to use Mastercam would
be appreciated, as the manuals are simply of the "do this,
then do this" form, rather then teaching you the concepts
and the "why" of the functions.

I will summarize and post the results.
Please note that I have crossposted this request to both
alt.cad and rec.crafts.metalworking.

Thanks,
Alan

--  Alan E. Frisbie               [email-masked]
--  Flying Disk Systems, Inc.
--  4759 Round Top Drive          (213) 256-2575 (voice)
--  Los Angeles, CA 90065         (213) 258-3585 (FAX)

---

From: [email-masked] (Steve Bongiovanni)
Date: Thu, 29 Sep 1994 12:37:55 GMT

>    Coons       Revolution  Bicubic approximation

Try:

Computational Geometry for Design and Manufacture
Copyright 1979, I.D.Faux, M.J. Pratt
Ellis Horwood Publishers, a division of John Wiley & Sons.
ISBN 0-85312-114-1

Very good overall text on surfaces and design.

There are lots of others, but this is a good start.

Bongi

Steve Bongiovanni
Product Development, Cadkey Inc.
[email-masked]