Subject: Myford dealer in US??

From: [email-masked] ([email-masked])
Date: 24 Jan 1995 21:50:21 GMT

--I'm trying to find out who sells Myford lathes and their 
accessories in the United States. It *used* to be D&M Model Engineering, 
but I think they've either dropped the line or gone belly-up. 
	--IMHO, this is the finest little lathe money can buy, but it's 
irksome not to have parts readily available....

--
"Steamboat Ed" Haas		:	Co-founder of the 
Voice: 805-968-7534		:	    SBSMEEBBQ
FAX:   805-JOB-TWAT		:	-Call about our Newsletter!
	--------Decks a-wash in a sea of words!!--------

---

From: [email-masked] (J. Kimberlin)
Date: 24 Jan 1995 17:27:17 -0800

>irksome not to have parts readily available....

I thought Blue Ridge took over when D&M gave up.  Don't know for sure.  
Get their address out of Live Steam, I think they have an 800 #.

JerryK

---

From: [email-masked] (Tim Kirby)
Date: 25 Jan 95 23:24:10 CST

J. Kimberlin ([email-masked]) wrote:
: In article <[email-masked]> [email-masked] ([email-masked]) writes:
: >	--I'm trying to find out who sells Myford lathes and their 
: >accessories in the United States. It *used* to be D&M Model Engineering, 
: >but I think they've either dropped the line or gone belly-up. 

: I thought Blue Ridge took over when D&M gave up.  Don't know for sure.  
: Get their address out of Live Steam, I think they have an 800 #.

Blue Ridge did Myford in the last catalog I had; I haven't seen one for a
while, though, and someone posted a while ago inferring that BR was not in
the Myford business (at least indirectly). Their details are in the
FAQ but I'll include them here for completeness...

Tim
--

   -  Blue Ridge Machinery and Tools, Inc.
      PO Box 536
      2806 Putnam Avenue
      Hurricane, WV  25516
      800-872-6500, 304-562-3538 in WV, 304-562-5311 (fax)
      Credit cards, COD's up to $200
      M,W,F 9-5 EST, Tu,Th 9-9 EST

      Lathes, milling machines, presses, brakes, from puny to industrial.
      Accessories and parts for popular machines from Myford, South Bend,
      Atlas, Sherline, Emco-Maier, etc.
      Hand tools and books of interest to hobbyists and professionals.
      Woodworking power tools
      Steel, brass, aluminum, tool steel in small quantities.

      110 page free catalog
--
Tim Kirby                    - [email-masked] -                +1-(612)-683-5390
Software Division System Support ________________ Cray Research, Eagan MN, USA
----------------- Ask not for whom I speak - I speak for me ------------------
If you are sure you understand everything that is going on,
you are hopelessly confused...                                - Walter Mondale