Subject: Milling machine clamps

From: [email-masked] (Dan Razzell)
Date: 12 Sep 1994 22:46:50 GMT

Anybody know where to get small hold-down clamps for milling machine
tables and the like?  We have a Präzi mill with a 17-inch x 6-inch
table.  It has 3/8-inch T-slots that fit 5/16-18 bolts.

The smallest clamps I can find seem really to be made for 3/8-inch
bolts, and are just too big and clumsy for use on this small table.  I
would machine some, but, um, don't have anything to hold the stock down.

-- 
     .^.^.      Dan Razzell <[email-masked]>
    . o o .     Laboratory for Computational Intelligence
    . >v< .     University of British Columbia
_____mm.mm_____ http://www.cs.ubc.ca/nest/lci

---

From: [email-masked] (Ken Toews)
Date: Wed, 14 Sep 1994 15:22:08 GMT

In a previous article, [email-masked] (Dan Razzell) says:

KBC Tools, Vancouver 1-604-540-4060, on page 417 of thier catalogue
they list 3 clamp styles in a total of 8 different lengths. Give
them a call. I never ceases to amaze me how I can order stuff
from these guys and if I get the order in by 3:00 pm they 
have it to my shop by 10 or 11:am the next day. It impresses
me every time.

--
Ken Toews    *       You can rent this space for as little as $25/day
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
.....Stay Hungry, Stay Foolish...Otherwise you'll end up fat and boring.....

---

From: [email-masked] (Dan Razzell)
Date: 16 Sep 1994 19:48:15 GMT

> table.  It has 3/8-inch T-slots that fit 5/16-18 bolts.

I'm following up several useful leads that I received from various people.
If nothing else, I'm going to have my shelves full of catalogues by the
time this is done!

It does look like most of the representative clamps in this range are
really quite oversized for the task.  One place I haven't checked yet is
Servo Products.  They make some beautiful CNC micro mills and lathes, so
they may know where to get suitable accessories.

Possible sources:

  Enco				(312) 745-1500
  MSC Industrial					(800) 645-7270
  All American The BUSHING	(818) 361-8776		(800) 423-2431	
  KBC Tools			(604) 540-4060
  Servo Products		(818) 796-2460
  Sherline			(619) 744-3674		(800) 541-0735

Thanks to:

  Ron Thompson <[email-masked]>
  Don Peterson <[email-masked]>
  Alden  Hackmann <[email-masked]>
  Vincent Jesus <[email-masked]>
  Ken Toews <[email-masked]>