Subject: Re: Copper Foils

From: [email-masked] (Mark Forbes)
Date: 22 Nov 1994 12:51:56 -0800

In *my* limited experience, copper foils are used for 
stained glass fabrication (employing a high-temperature
adhesive on one side), for shielding of electronics,
and in the form of beryllium copper, as precision
diaphragms: bellows and springs.

The Materials Handbook may list more things, as
will the Design News directory.
 
 Good Luck!
 [email-masked]
 Mark G. Forbes

---

From: [email-masked]
Date: 22 Nov 1994 02:03:00 GMT

Does anyone know where I can find information on thin copper foils (.001 - .003 thick)?  I'm looking for either 
compinies that produce the foils, properties of the foils, or even applications for them.

Thanks in advance.
Joel Moore