Subject: Re: used hydrolic press

From: [email-masked]
Date: Tue, 13 DEC 94 21:16:03 -0500

Charles Lewton-Brain gives Barbara McCartin P.O. Box 191, North
Sutton, New Hampshire 03260 USA.  as a source for a 20 ton
press , which is listed as "handmade welded steel".
 
I have the "expensive Bonny Doone and love it. Good luck.

---

From: [email-masked]
Date: Tue, 13 DEC 94 21:21:33 -0500

I am interested in putting together a bigger press.  How many
tons PSI does yours get?  I have one now that is a 20 ton
press, but  I need something bigger for deep draw presssing.
Can you give me a little detail as to how you made yours.
Would you do it differently if you were about to do it again?
What do you do on yours.  Yours seems similar to another I have
heard of the was made out of a logspliter.
Thanks.
Bill Hornaday

---

From: [email-masked] (Michael Horgan)
Date: Wed, 14 Dec 1994 08:36:36 GMT

In a previous article, [email-masked] (IT Front Office) says:

>does any one know where I can find either a used hydrolic press, or parts to
>put one together for die forming metal.  I am in the Boston area.  The
>presses sold for this purpose seem too expensive. please post any responses 
>rather than email. thanks.
>	Karin

It would help to know just how large are the pieces you want to form. We 
make a small 25 ton press for die forming medallions in bronze and 
silver. It's capacity for these metals, annealed dead soft, .100 thick, is 
about one square inch. Then again, this unit is an air over hydraulic press.
 In any case, larger capacity does not come cheap.

Michael Horgan		Representing Quick Silver Stamping, Tool and Die