Subject: Re: What is the phone # of SuperMax?

From: [email-masked] (J. Kimberlin)
Date: 1 Dec 1994 17:59:50 -0800

In article <[email-masked]> [email-masked] (Steve Lindsay) writes:
>
>Does anyone know the phone-address of the 
>manufacture for SuperMax mills?

It is somewhere in Taiwan.  YCI inc. in Compton, CA imports them.  
310-637-6380 or FAX 310-637-8925.

Had a friend that owned one - never again - always a parts availability 
problem.  It was innacurate and was down once for 6 months for parts.  It 
was a CNC type however, so that may be different than your wants.

You can lease a new Bridgeport for about $265/mo.  Better mill too.

---

From: [email-masked] (Steve Lindsay)
Date: 1 Dec 1994 09:14:42 -0700