Subject: Prepare Rusted Metal for Painting

From: [email-masked] (Bob Neidorff)
Date: Tue, 11 Oct 1994 16:51:57 GMT

Well, I have lightly rusted metal which I want to repaint.
I sanded and filed it down, but there are still some patches
which are very lightly rusted.  

I could:

	Use Naval Jelly to try to disolve the rust
	Use Rust Neutralizer to try to convert the rust
	Just prime and paint
	Sand until it is all gone, at the risk of weakening the metal
	Use a more specialized primer

What do you recommend?

Thanks for your advice.
-- 
Bob Neidorff; Unitrode I. C. Corp.  |  Internet: [email-masked]
7 Continental Blvd.                 |  Voice   : (US) 603-429-8541
Merrimack, NH  03054-0399 USA       |  FAX     : (US) 603-424-3460

---

From: PAUL <[email-masked]>
Date: Fri, 21 Oct 94 20:53:46 -0500

Greg Lewis <[email-masked]> writes:
 
>A related question... While I can see that sand is a sharper abrasive
>than glass beads, when and why would you choose one over the other?
>Heavy rust would obviously call for coarse sand, but what about new
>metal, to get a tooth for paint? 
 
Glass bead renders a much "finer" finish and is much kinder to the material
that you are blasting.I wouldn't imagine that you would want to choose it over
sand for prepping a painted surface, unless it was aluminum or some other soft
metal. It is great for cleaning up old carburetors though! (plug those holes!)