Subject: Re: What is the price per Kg. for casting bronze ?

From: [email-masked] (Steve Schiller)
Date: Thu, 26 Jan 1995 22:30:01 GMT

In article <[email-masked]>  
[email-masked] (Anton Bakker) writes:
> Thanks for any info!
> Anton

Two years ago it was about $2.75/lb for silicon bronze (Herculoy),
an easy-to-cast alloy.

The price fluctuates (like the price of gold) from month to
month. But that's the ball park.

I imagine that tin bronze (your classic bronze) would be slightly
more expensive.

---

From: [email-masked] (Anton Bakker)
Date: 26 Jan 1995 12:32:21 GMT

Thanks for any info!

Anton