Subject: Re: Digital calipers: Starrett vs. Mitutoyo

From: [email-masked] (Ken Toews)
Date: Tue, 24 Jan 1995 03:43:27 GMT

I used a Mitutoyo dial caliper on a daily basis, its about
12 years old and I am thinking of replacing it, mostly
because I want to. It still checks out with the gage blocks.

I also have a mitutoyo digital caliper that is probably
at least 8 years old which I use daily but only take
out for "special occasions" 

As a working toolmaker I would have no hesitations
to recommend mitutoyo. Personally when it comes
to dial calipers, dial indicators, I like
mitutoyo more than starret.

The Starret last word indicator and Starret dial calipers
have a different "feel" to them that just doesn't seem
right, hows that for hard as nails facts.

As for the starret digital calipers, never seen them, never
seen anyone use them so I cant comment on them.

Ken Toews

--
:>

---

From: [email-masked] (Erik Frank)
Date: 26 Jan 1995 21:47:35 GMT

>Ken Toews
I agree completely.  I think that the Starrett line of Indicators, while of an 
extremely high quality, just seem to lack the proper "feel".  Lately,
I've really liked the offerings by Brown & Sharpe.  Particularly their
"Jet Console" faced indicators.  I recently purchased a B&S 0-6" 0.1"/rev
Jet Black face dial calipers.  They're Swiss made, and have a great feel.

The Mitutoyo "Digimatic" digital calipers are really nice, (I personally prefer
dial calipers) and extremely reliable.  I have also used and liked Mitutoyo
indicators.

I try to buy quality tools whenver possible, as they will cause fewer headaches,
and last much better in the long run.

Erik Frank