Subject: (no subject)

From: mike faul <[email-masked]>
Date: 6 Jun 1995 21:02:36 GMT

Nayone have an address or tel# for Sid Sudameier? I guess he bought the 
Little Giant company.

Mike

---

From: [email-masked] (BrnzCaster)
Date: 6 Jun 1995 20:03:29 -0400

The current address is:

Sid Suedemeir
Little Giant Automotive
420 Fourth Corso
Nebraska City, NE 68410

Sorry ... don't have a phone number.

-------------------------------------
Winston W. Harness
Metal Casting Services
[email-masked] / [email-masked]