Subject: Re: May/June HSM sent?

From: [email-masked] (Mark Fraser)
Date: 3 Jun 1995 05:41:00 GMT

I got mine (in Vancouver BC!) weeks ago; the Mar/Apr issue was a trifle late,
I seem to recall.....

I'd call them, at this point.   800 number, and all....
/mark

Eric Beck(x3302) ([email-masked]) wrote:
: Has the May/June issue of HSM been sent out yet?

: I was thumbing through my magazines looking for something to read
: this evening and realized that my last copy was the March/April issue.

: Hope it wasn't lost (like some of my other mail!).

: 		Thanks,

: 			Eric

---

From: [email-masked] (Mark Fraser)
Date: 3 Jun 1995 05:41:00 GMT

: 		Thanks,

: 			Eric