Subject: Re: Brake Presses

From: John Tarrant <[email-masked]>
Date: 11 Apr 1995 02:05:58 GMT

Dear Merlin,

I just ordered a 320 ton Accurpress for my shop.  Prior to 
ordering it I looked a several different makes but felt 
Accurpress would do the best job for me.  Would be happy to relay 
any info to you.

John T.

---

From: John Tarrant <[email-masked]>
Date: 11 Apr 1995 02:05:58 GMT

Dear Merlin,

John T.