Subject: Re: Source for Bridgeport Parts?

From: Mike Rehmus <[email-masked]>
Date: 11 Aug 1995 17:52:54 GMT

Part 1

There is a company that makes Bridgeport replacement parts in Houston, Texas.

The company is J.R. Machine and their phone number is 800 332-5361.

Their parts seem to be about 25% less expensive than Bridgeports.
Longitudinal screw - $304, nut - $54 (one piece)
Cross screw - $189, nut $52.

They will send you a catalog if you wish.

Part 2

I have a few parts in my mill that were supplied by another company (I think) and 
seem to work OK.  According to my machine tool repairman, this other company (if 
they exist other than in my imagination) would charge, for a new set of leadscrews 
(X&Y) and nuts, about $260 for a standard (9" x 42") table.

I have a call into the repairman now.  I'll post the answer when he calls back.

Used parts, in good shape, seem to be real hard to find.

Best,

Mike Rehmus

---

From: [email-masked] (Alan Muller)
Date: 11 Aug 1995 12:58:16 GMT

I'm considering reviving a mill that has been stripped of some parts.
Can anyone suggest a source for used Bridgeport parts?  Thanks for any
info.

am

---

From: [email-masked] ()
Date: 13 Aug 1995 12:33:44 GMT

There is yet another Co. that sells replacement parts & accessories for 
vertical knee-type milling machines: High Quality Tools Inc., 1327 E. 
289th. St., Wickliffe, OH 44092. 216/944-0144, Fax: 216/585-2265.
 Ashoke Nijhowne.