Subject: Re: Armor for Arms&Elbow!!

From: [email-masked] (Mike Fifi)
Date: 5 Jun 1995 19:41:46 GMT

Oh ya, before I forget, the plastic elbow can be covered via
contact cement with any material of your choice for
hiding ugly plastic. If used black naga hide for this piece,
but have used  leather and suede/vinyl in the past 
which takes and holds a paint job of your choice quite well.
>
>If you have any other questions feel free to contact me at my email 
>address:
>
>Mike Fifi
>[email-masked]
>
>SCA and replica armourer.
>

---

From: [email-masked] (Mike Fifi)
Date: 5 Jun 1995 19:41:46 GMT