Subject: Ultrasonic cleaning

From: [email-masked] (Chris Youngson)
Date: 29 Mar 1995 11:26:14 -0800

Does anyone have any suggestions on building an ultrasonic cleaner, such 
as those used by gunsmiths, etc? How would you go about building the 
oscillator? Thanx 73 DE VE7CST

---

From: [email-masked] (Tony Smith)
Date: 12 Apr 1995 20:18:38 GMT

>oscillator? Thanx 73 DE VE7CST

Check out the March 1993 edition of ELECTRONICS NOW magazine (your
local library probably has back issues). The article 'Build this
Ultrasonic Cleaner' looks a bit complex, but if you strip away the
fancy timer/heater features, building just the basic cleaner should
be quite easy.

Good luck,
  Tony.