Subject: Re: Yet another MSC catalog

From: [email-masked] (Gregory Benjamin)
Date: Sat, 8 Apr 1995 05:07:47 GMT

Alan Frisbie ([email-masked]) wrote:
: I thought the MSC catalog selection (Not to mention their
: service) was "mind-boggling".

: Then MSC added their 250 page Welding catalog.

: Now, I have just received the MCS New Products catalog.
: It contains 500 pages of items (30,000 of them) that do
: not appear in the previous catalogs!

: 200 pages of threaded fasteners!
: 80 pages of tubing and fittings!
: More safety equipment, hand tools, power tools, material
: handling equipment, chemicals & lubricants, etc., etc., etc.

: The best keeps getting better!

I like the McMaster-Carr catalog better, though it has less
tooling, etc.

o-------------------------------------------------------------------o
| Gregory Benjamin       Laserlab, Inc.  precision laser photoplots |
|                        San Diego, CA   on film and glass made in  |
| [email-masked]     619-558-1246    a class 1000 cleanroom.    |
o-------------------------------------------------------------------o

---

From: [email-masked] (Alan Frisbie)
Date: 5 Apr 95 10:08:16 PST

I thought the MSC catalog selection (Not to mention their
service) was "mind-boggling".

Then MSC added their 250 page Welding catalog.

Now, I have just received the MCS New Products catalog.
It contains 500 pages of items (30,000 of them) that do
not appear in the previous catalogs!

200 pages of threaded fasteners!
80 pages of tubing and fittings!
More safety equipment, hand tools, power tools, material
handling equipment, chemicals & lubricants, etc., etc., etc.

The best keeps getting better!

--  Alan E. Frisbie               [email-masked]
--  Flying Disk Systems, Inc.
--  4759 Round Top Drive          (213) 256-2575 (voice)
--  Los Angeles, CA 90065         (213) 258-3585 (FAX)