Subject: Re: Conundrum: Indexing with Steppers

From: [email-masked] (Bob Neidorff)
Date: Wed, 10 May 1995 16:18:15 GMT

In article <[email-masked]>, [email-masked] (Ron Ginger) writes:
|> In article <[email-masked]> [email-masked] (Parker C.) writes:
|> >
|> >The answer is that you should not use a "stepper motor", since only the  
|> >most exotic units will ever give you the accuracy you are looking for.  
|> >So, forget that idea.  If you MUST control your indexing via computer, 
|> >then you need to build an interface unit to monitor the rotation of the 
|> >index wheel.  
|> 
|> ......deleted description....
|> 
|> I dont agree. A 200 step rep rev motor is quite accurate, and when geared to a 
|> 40 or 60 to 1 worm will provide far more resolution than most machining 
|> requires.
|> 
|> The index wheel described only provides feedback, that assures the step mottor 
|> has not lost a step. If the motor is properly sized and driven it will not 
|> loose steps. There are thousands of commercial CNC machine with step motor 
|> drive and no feedback.
|> 
|> There is also a kind of 'holy war' between believers of step motors and serveo 
|> motors. Truth is, correctly designed, both work fine. I believe in step motors.

I agree 100% with what Ron said, but...

If you get into LARGE motors and significant speeds, you
will find that a servo motor system will give more
performance for the same horse power.  By performance,
I mean speed of response and power efficiency.

Controlling either is a significant task.  Even pulsing a
stepper is non-trivial, as Ron hinted.  The stepper motor
rotor combined with the load represents a significant 
inertia which responds to applied torque in a predictable
but complex fashion.  It is common to get into resonance
problems where at one reasonable speed, the system steps
fine, but at a particular slower speed, the system won't
step worth beans without tricks (microstepping, etc.)

-- 
Bob Neidorff; Unitrode I. C. Corp.  |  Internet: [email-masked]
7 Continental Blvd.                 |  Voice   : (US) 603-429-8541
Merrimack, NH  03054-0399 USA       |  FAX     : (US) 603-429-8564

---

From: [email-masked] (Jonathan M. Elson)
Date: 9 May 1995 19:12:57 GMT

[email-masked] wrote:
: In article <[email-masked]>, [email-masked] (Jonathan M. Elson) writes:
: [...]
: >
: >Of course they do.  9/1000 of a degree = (approx) .3 ARC Second!  If you can
: >measure angles to that precision, you are doing about as good as the billion
: >dollar Hubble Space Telescope!  Actually, measurement of these small angles
: >on the tabletop are nearly impossible.
: >

: My calculator says 9/1000 of a degree is 32.4 arc seconds. This is still

Oops, I did that calculation in my head.  oh, well, only _one_ order of
magnitude off.

: Incidentally, I think you can measure angles to a precision of 0.3 arc seconds
: on a tabletop; just depends on the tabletop. It should be stable, temperature-
: controlled, and have a Moore Precision Index and a good autocollimator or
: laser interferometer sitting on it, or an A.G. Davis Rotary Calibrator.  

I did say (or at least I thought) "without exotic equipment."  What you
suggest is definitely exotic equipment!