Subject: Titanium sheets

From: IVAN WILLIS <[email-masked]>
Date: 9 May 1995 22:16:11 GMT

Im looking for titanium sheets about 1/8,1/4 thick 
 any one know of any good sources.

                         Ivan

---

From: [email-masked] (ErnieLeim)
Date: 10 May 1995 23:16:46 -0400

Titanium  source ?
If you know anyone in seattle they can bop on down to Boeing salvage in
Kent, WA.
They have a quite a variety of odd titanium.
Good luck

@---------------------------------------------------------@
                    Ernie Leimkuhler                                      

                  Stagesmith Productions                                  
                                          
                 Custom Metal Fabrication                                 
               
*    ABANA   SCA     AWS    USITT   IATSE local 15, 488   *
                        Renton, WA                                        
   
*"Rich gifts wax poor when givers prove unkind" the bard  *
@---------------------------------------------------------@