Subject: Re: Fowler Electric

From: myers <[email-masked]>
Date: Thu, 28 Nov 1996 09:15:04 -0500

James di Paulo wrote:
> 
> Does anyone have the address or the phone number of the Fowler Electic
> Company. I may not have the name spelled exactly right. They specialize in
> home power equipment.
> 
> Any help would be appreciated..
> 
> James

I had posted the following relative to another thread in this group. It 
seems Fowler Electric has changed it's name. I think this info. is 
applicable to your needs...try the 800# first....if not what you need, 
email me direct and I'll help you out...generally if its out there I can 
find it....<previously posted stuff follows>  Fowler Sno-Parts
2208 W. 94th St.
Bloomington, MN 55431
612/884-5401
Order line: 800/843-1424
FAX: 612/884-3628

Fowler Sno-Parts (formerly known as Fowler Electric Company) is a
distributor for Fast-Trac
traction products, Comet, Ride-on, SLP, Roetin, Black Magic, Sno-Stuff,
Wiseco, CMP,
Sno-Rider, PM Design, Formax, custom gasket and engine repair parts.

private reply to : [email-masked]

---

From: "J. Chace" <[email-masked]>
Date: Fri, 29 Nov 1996 23:30:43 -0800

James di Paulo wrote:
> JamesFowler Solar Electric
226 Huntington Road
PO box 435
Worthinton MA 01098
1-800-914-4131
They dont have a web site
JC

---

From: John Dunaj <[email-masked]>
Date: Sat, 30 Nov 1996 10:31:34 -0500

> > JamesFowler Solar Electric

They are changing their name to:

           New England Solar Electric, Inc.