Subject: Re: Medieval Herb Gardens

From: [email-masked] (Flyinggoat)
Date: 27 Mar 1995 12:47:53 -0500

>A Modern Herbal" by Mrs. M. Grieve contains a great deal of historical 
>info on the ancient use of herbs, including older names.  It was 
>reprinted in 1980 by Pengiun Books 

In the US, this would be Dover Publications.
Another very good title (US info) is:
THE ENCYCLOPEDIA OF HERBS AND HERBALISM
                 by  Stuart
            CRESCENT BOOKS
                   1979

Betty Cunningham([email-masked])
illustrator, animator, and likes to collect dead things

---

From: [email-masked] (Flyinggoat)
Date: 27 Mar 1995 12:47:53 -0500