Subject: Herbalist Multimedia

From: [email-masked] (DaveB1045)
Date: 9 Mar 1995 21:23:38 -0500

Does anyone know a source for "The Herbalist Multimedia"?  I saw it
mentioned in PC Computing last Fall, but have been unable to locate a
vendor.  It is supposed to be a very good resource.

thanks, 
Dave
Dave
NRA Life Member, and proud of it!

---

From: [email-masked] (Michael J Pfafflin)
Date: 10 Mar 1995 13:18:05 GMT

I got mine at CDROM Warehouse. I have a Macintosh version, but do carry
most products in both Mac and windows. 800-237-6623

[email-masked]

"Just give me the truth.
 All I wan't is the truth" 
John Lennon