Subject: Re: Looking for good medicinal herb book

From: [email-masked] (Jet Silverman)
Date: 10 Mar 1995 23:39:26 -0800

Medicinal Plants of the Mountain West
Michael Moore
Museum of New Mexico Press

This book has everything. Pictures, doses, chemicals, cultivation, 
gatering and preperation tips.

---

From: [email-masked] (Jet Silverman)
Date: 10 Mar 1995 23:39:26 -0800