Subject: Re: news:alt.folklore.herbs

From: [email-masked] (ChenueC)
Date: 1 Aug 1995 10:32:35 -0400

The herb supreme is milk thistle. For lots of information about this herb
read Christopher Hobbs book on The Liver. I knew a man who was told he
needed a liver transplant and after three months of this herb his liver
functions were all back within normal or acceptable range. Did the Doctor
want to know what he had done - NOOOOOOPE.
ChenueC

---

From: [email-masked] (Todd Caldecott)
Date: Tue, 01 Aug 1995 18:06:23 -0800

In article <[email-masked]>, "claude s. hayden"
<[email-masked]> wrote:

> Does anyone know of any herbs that can help restore liver 
> functions.
> 
> My liver enzymes test are high each time i get a blood test.
> 
> thanks for your help!
> 
> e-mail to [email-masked]

Carduus marianum, Curcuma longa, Taraxacum off. radix, Berberis vulgaris,
Bupleurum falcatum   a.k.a.   milk thistle, turmeric, dandelion root,
oregon grape root, bupleurum

-- 
Regards... [email-masked]