Subject: eleutherococcus senticosis

From: Jim Brennan <[email-masked]>
Date: Tue, 27 Dec 1994 15:37:14 -0400

Does anyone have information on this? It is in some hy-po capsules I am 
taking.

---

From: [email-masked]
Date: Tue, 27 Dec 1994 22:50:22 GMT

Eleutherococcus senticosus is Siberian ginseng.
It promotes stamina and is often used during convãlescence.