Subject: Prostate Cancer

From: [email-masked] (KARLA4ADT)
Date: 11 Jan 1995 23:40:06 -0500

I know some sugggestions were covered in previous posts on this subject,
but I haven't been able to locate anything in my net-notes on the subject.

Please, anyone, send suggestions re: herbals for the treatment of Prostate
Cancer.

Thanks in advance,

Karla
[email-masked]

---

From: [email-masked]
Date: Thu, 12 Jan 95 18:34:54 -0500

>Please, anyone, send suggestions re: herbals for the treatment of Prostate
 
There is a new newsgroup covering this subject.
alt.support.cancer.prostate