Subject: Yarrow

From: [email-masked] (Duane Champion)
Date: Fri, 23 Dec 1994 18:43:25 GMT

Will someone talk on the history and uses of Yarrow? Thanks.

---

From: [email-masked] (David Ehrensperger)
Date: 27 Dec 1994 18:33:37 GMT

Duane Champion ([email-masked]) wrote:
: Will someone talk on the history and uses of Yarrow? Thanks.

The history of the herb I do not know, but I have used it.
It is good for purifying the blood and helps w/fevers and 
colds.  It is also supposed to help blood clot though I
haven't used it for that.  Bombarding an embryonic cold
(ie, when the symptoms first appear) with plenty of
yarrow tea is supposed to help make the cold go away 
quickly.

Warning:  the taste leaves something to be desired--honey
can be your friend.

--
Dave Ehrensperger
[email-masked]
[email-masked]

As soon as he woke Piglet said to himself, "Oh!"
Then he said bravely, "Yes," and then, still more
bravely, "Quite so."