Subject: Chick Pea

From: Dhanaraj <[email-masked]>
Date: 1 Jan 1995 14:15:51 GMT

Would like to know if anyone has any ideas or views on chick pea 
and its nutritional value and uses.

Dhanaraj
[email-masked]

---

From: [email-masked] (Steve Russell)
Date: 1 Jan 1995 18:56:23 GMT

>and its nutritional value and uses.

They take hours to cook even with a pressure cooker.  They taste decent.
They have a high fat content for beans, to my knowledge the only bean
aside from soy that has a significant fat content.  If you are dieting,
object to can beans, or don't like cooking for hours it isn't the legume
for you.

Steve
[email-masked]..edu