Subject: Ma'ajoon

From: [email-masked] (Jerry Hamilton)
Date: Sun, 15 Jan 1995 11:10:06 GMT

I saw a reference on another newsgroup to an (East) Indian herb by the
name of Ma'ajoon.

Anyone heard of this or know anything about it.

---

From: [email-masked] (Conrad Richter)
Date: Mon, 16 Jan 95 07:24:23 EST

> Anyone heard of this or know anything about it.

There is a willow that goes by the Hindi name of Majnoon (Salix daphnoides)
but that is the closest I could find to Ma'ajoon.  Do you know what 
language this name is in?

Conrad Richter

RICHTERS HERBS                     | Info:                 [email-masked]
Goodwood, ON  L0C 1A0, Canada      | Catalog Requests:  [email-masked]
Tel +1-905-640-6677  Fax 640-6641  | What's New for '95:    [email-masked]