Subject: Herbs for Animals??

From: [email-masked]
Date: Tue, 10 Jan 95 04:22:58 EST

IR>Does anyone have any resources that describe herbal usage as it
IR>pertains to animals? Specifically cats and birds. Books, lists, etc.

IR>What hurts and what helps??

        Juliet De Bairacli Levy has written several books on herbs for
        animals.  I'd be interested in learning of other sources for
        similar info myself.  Good luck!

        [email-masked]
---
 þ SLMR 2.0 þ Moderation in all things should be practiced sparingly.

---

From: [email-masked] (mgang)
Date: 10 Jan 1995 17:42:43 -0500

Ks> (Rick Popham) wrote:
 
 > Does anyone have any resources that describe herbal usage as it 
 > pertains to animals? Specifically cats and birds. Books, lists, etc.
 > 
 > What hurts and what helps??
 > 
 > Any feedback is welcome..

Check out this book:  "THE NEW NATURAL CAT" by Anitra Frazier.
1990, US: $15, Canada $19

It was recommended to me by a friend who finds home for abused
and homeless cats.  It is indeed excellent.

I have a fixed 11 year old male who is apartment bound and
started to get sluggish and overweight.

By using the Vita-Mineral mix recommended in her book, my cat is
friskier and weighs less.
I also give him flax oil occasionally and either Kamut powder
or Super Blue Green Algae.  He _finally_ stopped shedding and
his coat, etc. is healthier.  Litter box smells less.
I enjoy preparing his food for him as I feel I am finally doing
something to contribute to his health instead of just scooping
out some indistinguishable gunk into his bowl.

There is a lot in here on herbs as well and many other subjects.
(to answer your original query).

- Marilyn -
[email-masked]

___ Blue Wave/QWK v2.12