Subject: hypoglycemia

From: [email-masked]
Date: Mon, 2 Jan 1995 16:46:01 GMT

For my occasional bouts of hypoglycemia, I take a 1/2-teaspoon of
turmeric (2 parts)
kudzu (2 parts)
licorice (1 part)
All powdered.
This REALLY works well. (Although licorice is contraindicated in
high-blood pressure or water-retention situations.)

Rick

---

From: [email-masked] (Rosebrit)
Date: 2 Jan 1995 23:54:00 -0800

>high-blood pressure or water-retention situations.)

Where can you get kudzu? and does it go by any other names?  
Why would you say this works for you?

thank you
Rosebrit

---

From: [email-masked] (George Law)
Date: 3 Jan 1995 15:58:34 GMT

[email-masked] wrote:
: For my occasional bouts of hypoglycemia, I take a 1/2-teaspoon of
: turmeric (2 parts)
: kudzu (2 parts)
: licorice (1 part)
: All powdered.
: This REALLY works well. (Although licorice is contraindicated in
: high-blood pressure or water-retention situations.)

: Rick

Hi Rick,

Ever take chromium supplement ? If not, test take it. It is very
important to pancreas which produce insulin. It was found that
hypoglycemics lack chromium in their pancreas. I had hypoglycemia,
now very little of it occassionally.

George Law

---

From: [email-masked] (Paul David Menair)
Date: 3 Jan 1995 18:52:16 GMT

Rosebrit ([email-masked]) wrote:
: In article <[email-masked]>,
:  <[email-masked]> wrote:
: >For my occasional bouts of hypoglycemia, I take a 1/2-teaspoon of
: >turmeric (2 parts)
: >kudzu (2 parts)
: >licorice (1 part)
: >All powdered.
: >This REALLY works well. (Although licorice is contraindicated in
: >high-blood pressure or water-retention situations.)
: >
: >Rick

: Where can you get kudzu? and does it go by any other names?  
: Why would you say this works for you?

: thank you
: Rosebrit

Rosebrit,

Kudzu, as you probably know, is a plant that was imported to this country 
for erosion control and planted by the WPA throughout the southeast.  If 
you've ever been to the south, you've seen it everywhere - entire states 
have literally been covered by the stuff, a sort of tropical ivy with big 
leaves.  It grows ridiculously fast...

Folks around here claim that it's a useless weed, and I've heard people 
jokingly offer rewards to anyone who finds a use for it.  But it _does_ 
have a use, in traditional Japanese cuisine and medicine.  In cooking, the 
root starch is used as a thickener.  I don't have the details on 
medicinal use with me (ie. in my head), but I can get back to you if 
you'd like.  I think that only the root is used in medicine.

Now if only we could come up with a use for the above ground portion...

As to where you can get it - I've seen it in the (ridiculously expensive) 
macrobiotic foods section of health food stores.  I've never seen it sold 
as a bulk herb, but that doesn't mean that it's never sold that way.

Paul