Subject: Re: Magnolia bark/flower very effective

From: [email-masked] (Jet Silverman)
Date: 9 Jan 1995 22:53:21 -0800

Could you tell us the Chinese name for Magnolia? Thanks.

---

From: [email-masked] (PlantMed)
Date: 11 Jan 1995 04:32:12 -0500

>Could you tell us the Chinese name for Magnolia? Thanks.<

The flower, which is used for nasal problems, is called Xin Yi Hua.
The bark, which is used for digestive and respiratory problems, is called
Hou Po.