Subject: wholesale botanical catalog

From: [email-masked] (liberty)
Date: 4 Jan 1995 11:05:39 GMT

Liberty Natural Products is a established distributor
of botanical ingredients, with a focus on essential
oils (over 300) and aromatherapy materials. We 
specialize in hard to find oils, such as yarrow, 
yuzo reco, helichyrsum,etc. We also have a wide selection
of glassware, caps, droppers etc. We distribute to 
health care practitioners and natural products
manufacturers. E-mail your name, address, phone &
customer type and we will send you our complete
catalog of botanical [email-masked].

We are new on the Internet, and are hopeful this article
is acceptable Internetiquette.

---

From: [email-masked] (Helen Bucknall)
Date: 15 Jan 1995 06:08:17 GMT

liberty ([email-masked]) wrote:
: Liberty Natural Products is a established distributor
: of botanical ingredients, with a focus on essential
: oils (over 300) and aromatherapy materials. We 
: specialize in hard to find oils, such as yarrow, 
: yuzo reco, helichyrsum,etc. We also have a wide selection
: of glassware, caps, droppers etc. We distribute to 
: health care practitioners and natural products
: manufacturers. E-mail your name, address, phone &

That's great, but what country are you in??