Subject: Osha root - need information

From: [email-masked] (StephenS49)
Date: 30 Aug 1995 02:30:50 -0400

Can anyone share some information on osha root.

A co-worker's son brought some back from his trip out west.  He told his
mother that it was used in Indian sweat lodge ceremonies and was good for
the immune system. I held the root briefly, and found it to be very
energetic--my fingers tingled for several minutes afterword.

Any information is appreciated.

---

From: Maggie Houston <[email-masked]>
Date: 5 Sep 1995 17:41:35 GMT

For the real facts on this plant contact this  address:  
http://www.crl.com/~robbee/herbal.html.   This site has the best discussion 
on Osha I have ever seen.  I brought a local Botanist in to see this  and she is 
going to hook up to WWW just to visit it.