Subject: Re: IMMUNE SYSTEM HERBS

From: [email-masked] (MannRo)
Date: 5 Sep 1995 17:19:49 -0400

Message-ID: <[email-masked]>

>I'm looking for recomendations for keeping my immune system
>in good shape.  Also any advice on a daily regiment for good
>overall health would be appreciated.

Astragulus is considered among the best for immune boosting

---

From: Frog <[email-masked]>
Date: Mon, 11 Sep 1995 21:59:44 -0400

any comments re echinacea?

On 9 Sep 1995, James Boone wrote:

> [email-masked] (MannRo) wrote:
> Last year we had a man who has survived AIDS for over 8 years I believe 
> it was.  Anyways, I recall him saying that along with his perscribed 
> medications he also drank an infusion of St. John's Wort to help boost 
> his immune system.    
> 
> 
>