Subject: Lemon Balm/Thyme/verbena

From: [email-masked] (Donna Beach)
Date: 20 Jul 95 22:40:01 CST

My garden is still overrun with lemon balm. In fact, it's now blooming.

I also have lemon thyme blooming (tiny pruple flowers) and a healthy lemon
verbena plant.

Here's my question--can these herbs be combined either for medicinal or
culinary purposes?

Donna

---

From: [email-masked] (VON BRUNDZ)
Date: 23 Jul 1995 05:39:55 -0400

yes, dry them -mix-great for colds ect. I use this combo quite frequetly
myself.