Subject: Re: Herbal remedy for yeast infection ?

From: "melissa.abraham" <[email-masked]>
Date: 9 Nov 1995 17:52:38 GMT

Wow.  Garlic seems to be good for just about everything.

Kamala, where did you find this info??

Melissa

---

From: [email-masked] (Dana M. Gass)
Date: 9 Nov 1995 17:04:51 GMT

One of the best remedies for yeast infections is to sterilize
a needle, thread it with dental floss, and thread a peeled
clove of garlic onto the floss.  Take the needle off and
insert the garlic into your vagina before bed. Pull it
out carefully by the floss the next morning and voila!
no yeast infection!
bright blessings,
Kamala
-- 
Kamala Perfumes: quality aromatherapy  and herbal supplies
E-mail us for more info. or check our web page at
htpp://kamala.com/~kamala/kamala.html