Subject: aphrodisiacs?

From: [email-masked] (Scott)
Date: Sat, 22 Jul 95 04:35:00 GMT

Could someone please provide a list and the effectiveness of some aphrodisiacs 
 that can be purchased at a health food store? I have heard rumors that there 
are no actual aphrodisiacs? Is this true? Any insights are appreciated!

---

From: [email-masked] (New York Theosophical Society)
Date: Mon, 24 Jul 1995 13:12:24 GMT

Scott ([email-masked]) wrote:
: Could someone please provide a list and the effectiveness of some aphrodisiacs 
:  that can be purchased at a health food store? I have heard rumors that there 
: are no actual aphrodisiacs? Is this true? Any insights are appreciated!

	Bottom line? Any substance that can make someone who does not 
wish to have sex have sex, in our society (where repression of sexual 
urges is trained into most people at a very early age) would have to be 
so strong as to make any sexual act with them an act of rape.

	Bart Lidofsky

---

From: Graham Sorenson <[email-masked]>
Date: Mon, 24 Jul 1995 21:11:10 GMT

In article: <[email-masked]>  [email-masked] (Scott Dorsey) writes:
> I have always found roses to be effective.  Barring that, try a box of 
> chocolates.

Good choices Scott,  the Essential oil of Rose is believed to be an aphrodisiac
and there are chemicals in chocolate which give a nice feeling, so together they should work :-)

Graham

> --scott
> -- 
> "C'est un Nagra.  C'est suisse, et tres, tres precis."
> 
> 
-- 
Graham Sorenson                 Guide to Aromatherapy URL
http://www.dircon.co.uk/home/philrees/fragrant/index.html