Subject: avina sativa - natural sex herb homeopathically administered?

From: [email-masked] (Jeanne Colin)
Date: Tue, 7 Nov 1995 07:35:48 GMT

hard copy (sorry) had a piece on avina (sic) sativa, or green oats, done up 
homeopathically. i didn't get the name of the manufacuters, but it's being 
mail order marketted by the name of natural sex for women.

any clues?

---

From: Leslie Taylor <[email-masked]>
Date: 8 Nov 1995 22:45:01 GMT

>mail order marketted by the name of natural sex for women.

Sorry, I didn't catch the Hard Copy piece either.  
However, I just got a copy of the Life Extension Catalog 
and they feature on the cover, both "Natural Sex for Women" 
and "Natural Sex for Men" which is Avena Sativa. Life 
Extension has a web page on the net, and also have an 800 # 
to order, but I think you have to be a member (I haven't 
joined nor have I ordered product from them - so I'm not 
sure how it works) It looks awful pricey for green oats 
too, at $35(Men) and $42 (women) for 60 capsules! Email me 
if you want the 800# out of the catalog though.

Take care,
Leslie Taylor

---

From: [email-masked]
Date: 9 Nov 1995 22:45:49 GMT

>   [email-masked] (Jeanne Colin) writes:

I would also be interested. I have a small health care business and had a phone
request for this product, which I had not heard of. Any information would be 
welcome including testimonial-type info.

Kris