Subject: Psoriatic Arthritis

From: [email-masked] (LIZ)
Date: Wed, 08 Nov 95 04:18:18 GMT

My brother is afflicted with this disease and is now seeking
natural medications after finding out that traditional ones
won't give him any relief.
When I first found Newsgroups I discovered a group where
people were discussing P.A. cures and meant to get back
to it, but then never found them again. Can anyone help?

---

From: [email-masked] (Don Wiss)
Date: Thu, 09 Nov 1995 03:20:18 GMT

>to it, but then never found them again. Can anyone help?

Could be:

alt.support.arthritis
alt.support.skin-diseases.psoriasis
misc.health.arthritis