Subject: Re: Euphoria Tape...Try it with a Lover!

From: [email-masked] (NofA)
Date: 4 Oct 1995 10:37:03 -0400

Hmm.  Do you think the Euphoria Tape could be considered alternative
halth?

---

From: [email-masked] (Psyberdude)
Date: 5 Oct 1995 13:28:27 GMT

Well I tried the tape and I felt relaxed but no way did I get super buzzed out.
Save your $$$ and go meditate or smoke a joint.