Subject: Re: Belladonna

From: [email-masked] (Callie)
Date: Fri, 06 Oct 95 08:42:33 GMT

In article <[email-masked]>, [email-masked] wrote:

>I have just been prescribed a belladonna and gold preparation for
>high blood pressure I not sure how it works.
>z
THEN ASK THE PERSON WHO PRESCRIBED IT!  

Callie

[email-masked]      | The Write Page for genre fiction:
http://www.writepage.com  | All the books that are fun to read.

---

From: [email-masked]
Date: Thu, 5 Oct 95 21:19:03 -0500