Subject: Correspondence courses for herbalist

From: [email-masked] (E.F.Schelby)
Date: Wed, 30 Aug 1995 17:11:03 GMT

My daughter wants to know if anyone knows what are the best
correspondence courses for herbalist, master herbalist or
foundation knowledge in herbs. Thanks for any information.
Fred

---

From: [email-masked] (Tcumminsrn)
Date: 6 Sep 1995 12:30:43 -0400

Please let me know how you like the classes/courses from Clayton School. 
I have their catalog but am unsure if it is what I am looking for.  Want
to become a Natropathic Physician.  Thanks for any info.

Teresa, RN, in Florida