Subject: Re: *BEST Book on Herbs

From: [email-masked] (Meow Mew)
Date: 8 Aug 1995 22:08:53 -0400

also *the herb book* by john lust

---

From: [email-masked] (Sisterjoe)
Date: 9 Aug 1995 16:04:30 -0400

Greetings --

I personally have found the Encyclopedia of Natural Healing to be
extremely helpful.  It pleases both  the human and scientist in me at the
same time.

Peace,

SCJ