Subject: Devils Claw/Blood Poisoning

From: [email-masked] (Jarvell Jardey)
Date: 13 Aug 1995 07:21:05 GMT

I have heard that "Devils Claw" can cause blood poisoning if
taken daily past a three week period. 

Can someone advise me if this is true?

Thanks 
Jardy

---

From: [email-masked] (Callie)
Date: Fri, 11 Aug 95 22:31:41 GMT

>Can someone advise me if this is true?

Jardy - 
  There are several plants known as "Devil's Claw".  Please identify the 
species and genus .... you know, the scientific name.

Callie