Subject: Kambuka ??? anybody ???

From: [email-masked] (c.f.)
Date: 6 Sep 1995 01:10:23 GMT

Please my wife wants to know the cost and 
properties of a Russian mushroom. How to get it, where and how mauch it cost!
please e-mail me : [email-masked]

THANKS !

---

From: Jerry Haugen <[email-masked]>
Date: 6 Sep 1995 04:43:19 GMT

> please e-mail me : [email-masked]

It's not a mushroom. For all the info try the following web page:

http://www.webcom.com/~sease/kombucha/info.html

-Jerry, Editor
The Mushroom Growers' Newsletter
[email-masked]