Subject: Re: KUDZU and alcoholism

From: [email-masked] (HRBS4HLTH)
Date: 8 Oct 1995 22:40:37 -0400

Hi Tommy!  Nature's Sunshine has a new product called Kudzu/St. John's
Wort.  It's a really effective combination, and NSP products are strictly
organic.  If you can't find a local supplier let me know and I can mail
order to you.

Sheila Weissman
Herbs For Health, 994 East Sahara, Las Vegas, NV 89104  (702) 732-9270

---

From: [email-masked] (Tommy g)
Date: 8 Oct 1995 10:52:20 GMT

Are there any national 
sources for KUDZU root 
that has reported success 
in minimizing urge to 
consume alcohol?