Subject: lemon verbena

From: [email-masked] (just della)
Date: Wed, 30 Aug 1995 04:26:38 GMT

i grow lemon verbena and nothing smells better.  it's
	such a happy and healthy plant (almost a tree) that it
	produces a lot of leaves.  i dry them and make tea, use
	the stems for flavoring on the bbq grill and even use it
	for *fragrant* cut flowers.  is this okay to do?  i wonder
	why i've never seen it in any herb or health shop?  am i
	killing myself slowly?   help.

                     _______________________________________
                     The world can be divided into two kinds
                     of people;  those who divide the world
                     into two kinds of people, and those who
                     don't.
                    [email-masked]

---

From: [email-masked] (RAVENDNCR)
Date: 30 Aug 1995 09:19:29 -0400

no.  Lemon verbena is a great herb, but as a medicinal ("mildly sedative"
tea) there are better herbs to use.  I grow it for its beauty and for the
fragrant leaves that I use for dream pillows, bath water, and cold
compresses.   It can also be used in oils and vinegars.  Standard warning
applies:  large doses over long period not good.
My $ .25 worth. : )

---

From: Graham Sorenson <[email-masked]>
Date: Wed, 30 Aug 1995 08:31:05 GMT

In article: <[email-masked]>  [email-masked] (just 
> 	killing myself slowly?   help.

No, not killing yourself slowly or quickly. <grin>

In the health shops look for an oil called verbena, careful of the make though, as some "verbena" oils are diluted with the cheaper lemongrass.

Lemon Verbena is well known in the essential oil/aromatherapy business.
It should grow to about 5 metres high. Used for the physical problems of 
cramps, indigestion and clearing the liver and is a digestive stimulant. 
Emotion problems it helps are anxiety, insomnia, nervous tension and stress 
related conditions. It is a mild sedative and the leaves used as a "Tea" is 
refreshing.

Graham

-- 
"New Pages" "New URL" "New Pages" "New URL"
Graham Sorenson         Guide to Aromatherapy URL

http://www.pikeperry.co.uk/ppp/fragrant/index.htm

We are not Physical beings having a spiritual experience
But Spiritual beings having a physical experience.