Subject: Re: Ginger Root

From: [email-masked] (Vijayendra Rao)
Date: Thu, 9 Mar 1995 16:01:15 GMT

[email-masked] () wrote:
>
> Anybody out there know how to store fresh ginger root?  I heard recently
> that it can be stored minced in a jar (in water, maybe?) similar to
> store-bought minced garlic.
> 
> Thanks,
> Sara

I find that keeping it in the freezer works very well.  When I need
some I do not thaw it, but use a sharp knife to slice it in
its frozen state.  It thaws very quickly when sliced and gets a 
little soggy, but tastes the same as fresh ginger. 
The same is true for other rizhomes like galangal (kah).

---

From: [email-masked] (Debbie Lang)
Date: Thu, 9 Mar 1995 18:43:07 GMT

In article <[email-masked]>, [email-masked] ()

> store-bought minced garlic.

I learned from my teacher of Chinese herbs to put it in a paper bag and
then put that inside a plastic bag.  In the paper bag alone it will dry
out; in the plastic bag alone it mold quickly.  It keeps quite awhile this
way!

Debbie

Debbie Lang
-----------
"...practice isn't a search.  Practice is to be with that which motivates the search, which is unease, distress.  And this is the turning around."                            --Charlotte Joko Beck

---

From: [email-masked] (Debbie Lang)
Date: Thu, 9 Mar 1995 18:43:07 GMT

Debbie

Debbie Lang
-----------

---

From: [email-masked] (Mitchell Olson)
Date: Thu, 9 Mar 1995 22:37:24 GMT

In article <[email-masked]>, [email-masked] 
says...

>store-bought minced garlic.

The best way to store it is to throw it in your freezer - just as it is, 
skin on and everything. It doesn't even need to be wrapped in plastic.

Then just peel some when you want some to chop or grate. It is also much 
easier to use "frozen" as the juice doesn't run everywhere and the 
freezing intensifies the taste (as with garlic).
 
Kristin.