Subject: Re: software cursor with 3.1.2Ec

From: Geert Uytterhoeven <[email-masked]>
Date: Tue, 23 Jul 1996 10:27:56 +0200 (MET DST)

Thomas Mueller wrote:
> > I'm integrating the Linux/m68k frame buffer device support in 3.1.2Ec.
> > Everything works fine, except that I have 3 problems:

	[...]

> I had the same problems on a SPARC. The problem was introduced in the
> patch from 3.1.2De to 3.1.2Df. The attached patch (against 3.1.2Ec)
> should fix the problem (it did at least on the SPARC).

	[...]

> +  * CAUTION: (type)*p is not the same as *((type*)p) esp. not on Big endians!

Thanks a lot! This fixed all my problems with the X server, and I don't think I
could have ever found this myself...

Greetings,

						Geert

--
Geert Uytterhoeven                     [email-masked]
Wavelets, Linux/m68k on Amiga          http://www.cs.kuleuven.ac.be/~geert/
Department of Computer Science -- Katholieke Universiteit Leuven -- Belgium

---

From: Geert Uytterhoeven <[email-masked]>
Date: Tue, 23 Jul 1996 10:33:13 +0200 (MET DST)

Geert Uytterhoeven wrote:

	[ stuff about X software cursors ]

Please forgive me... wrong list :-(

Greetings,

						Geert