Subject: Re: routing problem solved

From: Rick Hawkins <[email-masked]>
Date: Wed, 12 Jun 1996 15:59:10 CDT

> : NETWORK=129.186.31.38
> 
> IPADDR as the same as the NETWORK address?? Strange, isn't it?

err, forgot about this in the message i just sent.

On these machines, i found that i had to use their own address as teh
network address, rather than the .0 address; otherwise they wouldn't
talk to anything.

rick

---

From: [email-masked] (Bruce Perens)
Date: Wed, 12 Jun 96 14:40 PDT

The installation menu provides a prototype network number made from the
logical AND of your IP address and your netmask. If the user types in the
wrong netmask or overrides the prototype network number (which I think is
what happened here), they can get an incorrect value. I'll have to look at
this when I get home, I'm not in front of my Debian system.

Netmasks, by the way, can legitimately have zeroes in less than all 8
bits of the last octet. They should, however, have zeroes in one or
more low-order bits, and we could check for that.

	Thanks

	Bruce

On Wed, 12 Jun 1996, Rick Hawkins wrote:
> Under the beta releases with 1.3.9x, the following file is created:
> 
> #!      /bin/sh
> ifconfig lo 127.0.0.1
> route add 127.0.0.1
> IPADDR=129.186.31.38
> NETMASK=255.255.255.0
> NETWORK=129.186.31.38
> BROADCAST=129.186.31.255
> GATEWAY=129.186.31.254
> ifconfig eth0 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
> route add -net ${NETWORK}
> route add default gw ${GATEWAY} metric 1
> 
> these last two lines simply aren't working with the variable names.  I
> added 

Gerry:
> The reason the last "route add -net ${NETWORK}" is not working is that it
> is expecting a network address (ending in .0) and it is getting a host
> address instead.