Subject: xbiff: cannot convert to type Pixmap

From: Gerry Jensen <[email-masked]>
Date: Sun, 16 Jun 1996 16:50:11 -0600 (MDT)

I recently upgraded our system to 1.1.  Now, when I run xbiff, I get:

Warning: Cannot convert string "flagup" to type Pixmap
Warning: Cannot convert string "flagdown" to type Pixmap

And a silly pixmap of shelves or something is shown instead of the
mailbox pixmap.  I had this same problem on my home system when I upgraded
some time ago, but the problem was solved by adding some other packages.
I *thought* the packages I needed to add were aout-xpm and xcompat so I
installed these packages but it hasn't solved the problem this time.  Does
anyone know what other package I need to add to make xbiff display the
pixmaps properly?

Thanks,

Gerry
[email-masked]

---

From: [email-masked] (joost witteveen)
Date: Tue, 18 Jun 1996 11:04:27 +0200 (MET DST)

> mailbox pixmap.

Strange.....

Could you mail me (privately) the output of
   dpkg -l
on your system? Especially your version of xaw3d interests me:
an old version _used_ to cause this problem, but not the current
version.

Release xaw3d-1.2a-4 (and -3) should be OK.

If you do have xaw3d installed, could you also send me the output
of
  ldd /usr/X11R6/bin/xterm

(this should list Xaw being loaded at the start, and _not_
(also) at the end, or both start and end).

If you do have xaw3d installed, could you try removing it,
and checking what the effect is?

Thanks, 
 your xaw3d maintainer who thought he fixed the problem,

-- 
joost witteveen
            [email-masked]
          [email-masked]
--
Use Debian Linux!

---

From: Gerry Jensen <[email-masked]>
Date: Tue, 18 Jun 1996 10:58:13 -0600 (MDT)

> > And a silly pixmap of shelves or something is shown instead of the

The problem was really trivial.  Xbiff just couldn't find the flagup and
flagdown bitmaps.  The package that contains xbiff (xcontrib) does not
have these bitmaps (I think it should though). xdevel does contain these
bitmaps. After installing xdevel, all works again. 

Perhaps this should be reported as a bug.

Gerry
[email-masked]