Subject: Re: `Packages' not synced with *.deb files --> Solution

From: Christian Hudon <[email-masked]>
Date: Wed, 19 Jun 1996 09:34:19 -0400 (EDT)

On Wed, 19 Jun 1996, Heiko Schlittermann wrote:

> Hi,
> 
> since I've experienced some problems when I used `Packages'
> (.../binary/Packages) files which weren't in sync with the corresponding
> *.deb files and since I asked twice for a tool to create these Packages
> files from scratch and since I got no answer ... I made a first
> attempt to write this tool (and I'm sure, that I reinvented the wheel).

You might want to look into dpkg-scanpackages...   

  Christian

---

From: Guy Maor <[email-masked]>
Date: Wed, 19 Jun 1996 09:42:27 -0500 (CDT)

> attempt to write this tool (and I'm sure, that I reinvented the wheel).

/usr/sbin/dpkg-scanpackages

---

From: [email-masked] (Heiko Schlittermann)
Date: Wed, 19 Jun 1996 16:51:48 +0200 (MET DST)

Christian Hudon wrote:
: 
: > files from scratch and since I got no answer ... I made a first
: > attempt to write this tool (and I'm sure, that I reinvented the wheel).
: 
: You might want to look into dpkg-scanpackages...   

Uhhm ... it's true, I reinvented the wheel :-/

Ok, Thanks.
[ so it was at least a good exercise programming perl ]

Heiko
public pgp : finger [email-masked]
fingerprint: A1 7D F6 7B 69 73 48 35  E1 DE 21 A7 A8 9A 77 92

---

From: [email-masked] (Heiko Schlittermann)
Date: Wed, 19 Jun 1996 14:08:56 +0200 (MET DST)

Hi,

Now I can take my local collected *.deb files (same file system layout
as on the ftp server), `cd /usr/DEBIAN/1.1; mk_packages -v' and all
the `Packages' files are rebuilt.

[ Of course, there are some bugs, but at least for me it worked and I
didn't get annoying updates of already updated packages when I used
dselect ... ]

If there is some interest in this short perl script I could post it to
this mailing list or whereever you want ;-)

Heiko