Subject: Re: 1.1 problems

From: [email-masked] (Heiko Schlittermann)
Date: Mon, 17 Jun 1996 17:40:44 +0200 (MET DST)

Mark Phillips wrote:
: 
: 
: Next problem: when I boot I now get the following error messages:
: Configuring serial ports..../dev/cua0: No such device
: done.
: /dev/cua0: No such device
: /dev/cua1: No such device
: /dev/cua2: No such device
: /dev/cua3: No such device

Perhaps you serial driver is modularized not not yet loaded.

: Next problem: when trying to configure my ethernet interface:
: ifconfig eth0 192.1.1.1 netmask 255.255.255.0 broadcast 192.1.1.255
: SIOCSIFADDR: No such device
: SIOCSIFNETMASK: No such device
: SIOCSIFBRDADDR: No such device

Same as above for the ethernet device driver.

: NE*000 ethercard prob at 0x340: 00 40 01 41 4a 37
: eth0: NE2000 found at 0x340, using IRQ5
: I don't see any such message for the debian bootup - does debian
: detect my ethernet card?

Have a look at /etc/modules and /etc/conf.modules.

Heiko
public pgp : finger [email-masked]
fingerprint: A1 7D F6 7B 69 73 48 35  E1 DE 21 A7 A8 9A 77 92

---

From: Rick Hawkins <[email-masked]>
Date: Mon, 17 Jun 1996 10:59:51 CDT

> dependency problem prevents configuration of libc5-dev
> 	libc5-dev depends on libc5 (=5.2.18-8) however:
> 	version of libc5 on system is 5.2.18-9

i'm shooting from the hip, but how about reinstalling both to the
current version?

> Next problem: when trying to configure my ethernet interface:
> 
> ifconfig eth0 192.1.1.1 netmask 255.255.255.0 broadcast 192.1.1.255
> SIOCSIFADDR: No such device
etc. . .

> What is wrong?
> 
> I noticed with my slackware bootup (where things work okay), that
> it prints:
> 
> NE*000 ethercard prob at 0x340: 00 40 01 41 4a 37
> eth0: NE2000 found at 0x340, using IRQ5
> 
> I don't see any such message for the debian bootup - does debian
> detect my ethernet card?

not automatically, although .93 did.

What you need to do is add

  ne io=0x340

to the end of /etc/modules.  It willthen load the ne.o module you need
for that card on boot.

ONce booted, you can use 

  insmod ne io=0x340

to do the same thing.

rick

---

From: Kai Grossjohann <[email-masked]>
Date: 17 Jun 1996 18:37:55 +0200

>>>>> On Mon, 17 Jun 1996 06:58:53 +1000, Mark Phillips
>>>>> <[email-masked]> said:

  Mark> dependency problem prevents configuration of libc5-dev
  Mark> 	libc5-dev depends on libc5 (=5.2.18-8) however:
  Mark> 	version of libc5 on system is 5.2.18-9

Get a newer libc5-dev (5.2.18-9 rather than -8) and install that.

kai
-- 
Life is hard and then you die.