Subject: .xinitrc

From: Rick Hawkins <[email-masked]>
Date: Wed, 12 Jun 1996 12:33:09 CDT

one more, probably minor thing:  with it set up for xdm, it ignores the
.xinitrc file in my home directory.  am i missing something obvious?

rick

---

From: Rick Hawkins <[email-masked]>
Date: Wed, 12 Jun 1996 13:02:12 CDT

> Here's an example of how I sometimes launch xdm:
> 
> xdm -config /home/syrus/.fvwmrc -session /home/syrus/.xinitrc\
>   -resources /home/syrus/.Xdefaults       
> 
> That way, the files in my directory are used for the configuration.
> I run this command from a script as root when I want to use xdm.

for the moment, at least, i've been leaving xdm running automatically at
boot.  is there a way to do this this way?  come to think of it, it
would have to be able to use whoever logged in's file . . .

---

From: Rob Browning <[email-masked]>
Date: 12 Jun 1996 13:04:47 -0500

> .xinitrc file in my home directory.  am i missing something obvious?

Is it's executable bit set?  /etc/X11/Xsession checks this to decide
whether or not to run the user's script.

--
Rob

---

From: Syrus Nemat-Nasser <[email-masked]>
Date: Wed, 12 Jun 1996 10:41:00 -0700 (PDT)

Syrus.

----------------------------------------------------------
Syrus Nemat-Nasser <[email-masked]>    UCSD Physics Dept.

---

From: "David M. Cooke" <[email-masked]>
Date: Wed, 12 Jun 1996 14:25:33 -0400

> .xinitrc file in my home directory.  am i missing something obvious?

I ran into this.  Reading /etc/X11/Xsession told me enough to
fix it.

Edit /etc/X11/config and add the following lines:
allow-user-resources
allow-user-modmap
allow-user-xsession

I think this should be concidered a bug.  These lines should
already be present and the sysadmin can remove one or more of
them in very unusual cases where that might be desired.

-- 
________________________________________________________________________
David M. Cooke                                   [email-masked]

---

From: Rick Hawkins <[email-masked]>
Date: Wed, 12 Jun 1996 15:11:48 CDT

> whether or not to run the user's script.

the combination of that, and changing to .xsession, did it.

and now emacs is telling me that it doesn't recognize a -geom option.
huh?  so how do i get it to place itself automatically?

---

From: Rob Browning <[email-masked]>
Date: 12 Jun 1996 18:39:08 -0500

> huh?  so how do i get it to place itself automatically?

Are you using -geom or -geometry?  I use the latter and it works.

--
Rob

---

From: Stephen Early <[email-masked]>
Date: Thu, 13 Jun 1996 01:39:13 +0100 (BST)

> them in very unusual cases where that might be desired.

Yes, I consider it to be a bug. I haven't worked out exactly which 
interaction between the package configuration scripts makes 
/etc/X11/config be created without these lines, but I'm going to skip the 
problem by writing a little utility to make the scripts properly idempotent.
Expect new X packages in a few days.

Steve Early
[email-masked]

---

From: Yves Arrouye <[email-masked]>
Date: Fri, 14 Jun 1996 07:34:23 +0200

> .xinitrc file in my home directory.  am i missing something obvious?

When one uses xdm, the .xsession file is used instead. You can just have
one that looks like:

	#! /bin/sh

	sh $HOME/.xinitrc

(the 'sh' should not been necessary, but does no harm...).

Yves.

---

From: Rob Browning <[email-masked]>
Date: 14 Jun 1996 12:23:45 -0500

> When one uses xdm, the .xsession file is used instead. You can just have

Or just

ln -s .xinitrc .xsession

which has worked fine for me.

I do the same for .Xdefaults -> .Xresources, although someone
recently told me that that they weren't so sure about that, but it
seems to work...

--
Rob

---

From: [email-masked] (Heiko Schlittermann)
Date: Fri, 14 Jun 1996 21:41:02 +0200 (MET DST)

Yves Arrouye wrote:
: 
: Rick Hawkins writes:
:  > one more, probably minor thing:  with it set up for xdm, it ignores the
:  > .xinitrc file in my home directory.  am i missing something obvious?
: 
: When one uses xdm, the .xsession file is used instead. You can just have
: one that looks like:
: 
: 	#! /bin/sh
: 
: 	sh $HOME/.xinitrc
: (the 'sh' should not been necessary, but does no harm...).

On my system there is a link:

/home/bmt/heiko/.xinitrc -> .xsession

And .xsession is:
#############################################
#!/bin/bash -login
# xmodmap /usr/lib/X11/etc/de-hacker.xmod
export TERM=xterm
xclock -chime -geometry 100x100-0+0 &
xclipboard -geometry 310x52--4+259 &
xload -geometry 100x63-0+116 &
xterm -geometry 80x24+10+50 -sb -ls -font 7x14 -bg gray -name $(hostname)&
exec fvwm &
xbiff -geometry 100x45-0+195

Heiko
public pgp : finger [email-masked]
fingerprint: A1 7D F6 7B 69 73 48 35  E1 DE 21 A7 A8 9A 77 92