Subject: PPP initial connection

From: stevem <[email-masked]>
Date: Wed, 12 Jun 1996 20:17:43 -0500 (EST)

I have had for the longest time the problem of never being able to
get PPP to connect with a server the first time (off af a boot). I used
to think it was the provider, but now believe it is me, since I can 
connect and reconnect flawlessly as long as I don't reboot. Has anyone else
out there had this problem? 

Also, while I'm on the subject, has anyone crafted a perl script that 
replaces chat, or know where there is one? I tried it and gave up and now
have a hybrid perl/chat script. Pure perl would be preferred.

	Thanks, Steve Millard

---

From: Rick Macdonald <[email-masked]>
Date: Wed, 12 Jun 1996 22:11:05 -0600 (MDT)

> have a hybrid perl/chat script. Pure perl would be preferred.

I use the runscript program that comes with minicom. It has these
fairly obvious commands:

            expect   send     goto     gosub    return   !
            exit     print    set      inc      dec      if
            timeout  verbose  sleep    break    call

call calls another script and ! runs a shell/command.

...RickM...

---

From: "Darren/Torin/Who Ever..." <[email-masked]>
Date: 13 Jun 1996 10:41:10 -0700

-----BEGIN PGP SIGNED MESSAGE-----

>have a hybrid perl/chat script. Pure perl would be preferred.

Check out Comm.pl at -CPAN-/authors/id/ERICA/Comm.pl-1.5beta.tar.gz
(-CPAN- is any CPAN site.  I got this from ftp://ftp.delphi.com/pub/mirrors/packages/perl/CPAN/)

(BTW, this is both perl4 and perl5 compliant...)

- From the Announcement:
What:

  "Comm.pl", a successor to "chat2.pl", providing a high level interface to:

    - STREAM/UDP sockets
    - pseudo-tty control
    - Revamped "expect"-like functionality (plus "interact").
    - ioctl/stty terminal mode control

  other things:

    - Support for BSD & SVR4 flavors (so far, tested with SunOS4.x, olaris2.x)
    - sample client/server and expect scripts

Why:

  - "chat2.pl" doesn't have SVR4 support.  People have been posted a
    lot with questions about getting SOCK_STREAM right, or how to get
    a pty.

  - The Expect pattern/action pair only confuses people the way that chat2
    emulated it.  A Perl "expect" should be simple; it should not be
    trying to execute code given as parameters; that's what the Perl
    interpreter is for.  Also, the TCL Expect program has a whole lot
    of stuff that we don't really need because it's available via other
    methods in Perl (i.e. "send_tty").

Darren
- -- 
<[email-masked]> <http://www.daft.com/~torin/>    <[email-masked]> <[email-masked]>
Darren Stalder/2608 Second Ave, @282/Seattle, WA 98121-1212/USA/+1-800-921-4996
@ Do you have your clothes on? I probably don't. Take yours off. Feel better. @
@ Sysadmin, webweaver, postmaster for hire.  C/Perl/CGI programmer and tutor. @