Subject: squid

From: [email-masked] (Tim O'Brien)
Date: Thu, 15 Aug 1996 10:02:29 -0500

Could someone please explain a little more about the linux software 
called squid? I read the homepage, but I still don't completely get
the picture.... What is it? 

I know it does some caching, but from what I read I really can't see 
what it's good for.. I know there's a use, I just don't understand
what it is. 

Thanks!

Tim 

-----------------------------------------------------------------------
  I am Pentium of Borg. Division is futile. You will be APPROXIMATED! 

  [email-masked]      <-- (Primary email)
  
-----------------------------------------------------------------------

---

From: Jim Pick <[email-masked]>
Date: Thu, 15 Aug 1996 11:10:05 -0700

I haven't used it myself, but I believe it is a cache for
surfing the WWW.  You give it a certain amount of disk
space (say 300MB), and you set Netscape to use it as a
proxy server.  So whenever you access a web page using
Netscape, it will pass the request to squid, and squid
will either serve up the page out of it's disk cache
(very fast), or if it doesn't have the latest version
of the document, fetch it from the internet.

For a single user, this probably doesn't do anything for
you that just increasing the cache size inside of Netscape
doesn't do.  But if you set up several users to use the
squid, then this can speed things up considerably, and
cut down on the amount of network traffic.  A proxy cache
also gives you more control over what is cached than
what Netscape provides.

Of course, there are drawbacks to using proxy caches --
the cache might cache something that it really shouldn't
(like the output from a CGI script), and you will not
be able to see the latest output.  Normally though,
this shouldn't happen.

How's that sound?

 - Jim