Subject: Help: sendmail/filter locking errors

From: [email-masked] (Eamon Daly)
Date: Wed, 21 Aug 1996 09:48:19 -0500 (CDT)

I just made the   switch the debian  distribution,
and I'm fairly  impressed with it so far. However,
with   the  installation   of  the  elm  2.4pl25-2
package, filter appears to be broken. It panics
when it tries to lock, reporting:

filter (Wed Aug 21 09:30:32 1996 eamon): Mailing message to eamon
filter (Wed Aug 21 09:31:02 1996 eamon): Couldn't create lock file
filter (Wed Aug 21 09:31:02 1996 eamon): Can't open mailbox /var/spool/mail/eamon!
filter (Wed Aug 21 09:31:02 1996 eamon): Using /home/eamon/EMERGENCY_MBOX as emergency mailbox

Permissions  on the inboxes in /var/spool/mail are
660, owned by  owner and grouped by 'mail'. Normal
mail (smail) delivery seems  to be  going smoothly
with no locking errors. Any ideas?

   - Eamon Daly
     Manager, Electronic Marketing
     (847) 785 8000 x205

---

From: Casper BodenCummins <[email-masked]>
Date: Thu, 22 Aug 1996 10:08:12 +0100

I'm unfamiliar with filter and elm, so this may be on the wrong track.

Anyhow, I had a similar problem trying to use two mail user agents
simultaneously (on a Sun, as it happens). The first program had placed a
lock on the mailbox while the second program, using the same protocol,
saw the lock refused to open my mailbox. Quitting both and restarting
the second program cured this.

If this is so, the `couldn't create lock file' problem is probably
causing the `couldn't open mailbox ...' problem.

HTH,
Casper Boden-Cummins.

>----------
>From: 	[email-masked][SMTP:[email-masked]]
>Sent: 	21 August 1996 15:48
>To: 	[email-masked]
>Cc: 	The recipient's address is unknown.
>Subject: 	Help: sendmail/filter locking errors
>
>filter (Wed Aug 21 09:31:02 1996 eamon): Using
>/home/eamon/EMERGENCY_MBOX as emergency mailbox
>