Subject: a4.sty and a4wide.sty

From: Hakan Ardo <[email-masked]>
Date: Sun, 25 Aug 1996 16:09:11 +0200

Hi,
I have latex 2e-7 installed, but I can't find  a4.sty a4wide.sty, in which 
package are they?

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Sun, 25 Aug 1996 14:56:37 -0400

Hi Hakan --

> I have latex 2e-7 installed, but I can't find  a4.sty a4wide.sty, in which 

I think the Latex-2e approach is not to use .sty files, but to use .cls
(class) files.  Support for a4 letter paper is built into the article.cls
file, for example, but the option a4paper.
So, to get output formatted for a4 paper, you would invoke the article style
this way:

\documentclass[titlepage, oneside, a4paper, 11pt]{article}
\usepackage{html}
\usepackage[dvips]{graphicx}

where the options "titlepage", "oneside", "11pt", etc., are all 
optional (!); I just put them there to illustrate that you can have more
than 1 option in the [].  I also added the statements regarding
"usepackage" as a further example of package-loading in latex-2e.

If you'd like to read more about this, you might want to get a copy
of the boot "The LaTeX Companion", by Goosens, Mittelbach, and Samarin.

HTH,
Susan Kleinmann

---

From: Hakan Ardo <[email-masked]>
Date: Sun, 25 Aug 1996 22:28:41 +0200

> "usepackage" as a further example of package-loading in latex-2e.

OK, this works all fine, but the there is the trouble with my old latex files,
latex still supports the us of sty files, right? I have several documents
that uese that apportch, and I felt it easyer to install the stys, than 
convert all my files. 

Then there is the trouble with lyx. I have just started to try it out, and it 
seems like it uses the sty approch, but it might be a misconfiguration of it
to...

---

From: Michael Meskes <[email-masked]>
Date: Mon, 26 Aug 1996 13:02:05 +0200 (MET DST)

> seems like it uses the sty approch, but it might be a misconfiguration of it

I use a4paper with LyX all the time without a problem. However, a4wide
doesn't work.

Michael

-- 
Michael Meskes                   |    _____ ________ __  ____
[email-masked] |   / ___// ____/ // / / __ \___  __________
[email-masked]                  |   \__ \/ /_  / // /_/ /_/ / _ \/ ___/ ___/
[email-masked]                |  ___/ / __/ /__  __/\__, /  __/ /  (__  )
Use Debian Linux!                | /____/_/      /_/  /____/\___/_/  /____/

---

From: Hakan Ardo <[email-masked]>
Date: Mon, 26 Aug 1996 13:52:49 +0200

> I use a4paper with LyX all the time without a problem. However, a4wide

Sure it does, the only trouble with that one is that it only uses half of 
the paper :) The rest is margins...

---

From: [email-masked]
Date: Tue, 27 Aug 1996 11:51:06 +0200

>of the boot "The LaTeX Companion", by Goosens, Mittelbach, and Samarin.
As the normal a4paper is not very wide, my office mate wrote a package
to get bigger text-width.
It can be invoked vai  \usepackage{realA4}.
Options are nohead, if no headers are used, and symetric, to place the 
text in the middle of the page

greetings,
jan

% realA4.sty
% 
% REALLY use A4 paper (based on longlines.sty)
%
% (c) 1995, 1996, Christian Cachin ([email-masked])
%
%
% USAGE:  (in LaTeX2e only)
%
% \documentclass{anyclass}
%
% \usepackage[nohead,symmetric]{realA4}
%
% The optional `nohead' specifies that no headings will be used in the document
% and  therefore, the space reserved for it by LaTeX can be used for text.
%
% The optional `symmetric' specifies that even with the `twosided' option
% the main text is centered on the page.
%
%
% IMPLEMENTATION:
%
% The following is just the code to calculate \textwidth and several widths
% that depend on it, copied 1-to-1 from classes.dtx.
%

\def\fileversion{1.1}
\def\filedate{1996/07/23}
\NeedsTeXFormat{LaTeX2e}
\ProvidesPackage{realA4}[\filedate\space\fileversion\ the real A4 page layout]

\DeclareOption{nohead}{%
\advance\textheight by \headheight%
\advance\textheight by \headsep%
\headheight 0pt%
\headsep 0pt}

\DeclareOption{symmetric}{%
\def\@symmetrya{0.5}%
\def\@symmetryb{0.5}}

\setlength\paperheight {297mm}
\setlength\paperwidth  {210mm}

\voffset 0pt
\topmargin 0pt                                                                 
 
\ifcase \@ptsize                                                               
 
    \textheight 54\baselineskip                                                
 
\or                                                                            
 
    \textheight 47\baselineskip                                                
 
\or                                                                            
 
    \textheight 43\baselineskip                                                
 
\fi                                                                            
 
\advance\textheight by \topskip                                                

\def\@symmetrya{0.4}
\def\@symmetryb{0.6}

\ProcessOptions

\setlength\@tempdima{\paperwidth}
\addtolength\@tempdima{-2in}
\setlength\textwidth{\@tempdima}
\@settopoint\textwidth

\if@twoside
  \setlength\@tempdima        {\paperwidth}
  \addtolength\@tempdima      {-\textwidth}
  \setlength\oddsidemargin    {\@symmetrya\@tempdima}
  \addtolength\oddsidemargin  {-1in}
  \setlength\marginparwidth   {\@symmetryb\@tempdima}
  \addtolength\marginparwidth {-0.4in}
\else
  \setlength\@tempdima        {\paperwidth}
  \addtolength\@tempdima      {-\textwidth}
  \setlength\oddsidemargin    {.5\@tempdima}
  \addtolength\oddsidemargin  {-1in}
  \setlength\marginparwidth   {.5\@tempdima}
  \addtolength\marginparwidth {-.4in}
\fi
\ifdim \marginparwidth >2in
   \setlength\marginparwidth{2in}
\fi
\@settopoint\oddsidemargin
\@settopoint\marginparwidth
\setlength\evensidemargin  {\paperwidth}
\addtolength\evensidemargin{-2in}
\addtolength\evensidemargin{-\textwidth}
\addtolength\evensidemargin{-\oddsidemargin}
\@settopoint\evensidemargin

------------------------------------------------------------------------
  Jan Camenisch                                                    
  Institut fuer theor. Informatik                  Tel. +41 1 632 7412
  ETH Zentrum, IFW                                 Fax. +41 1 632 1172
  CH-8092 Zurich, Switzerland            e-mail: [email-masked] -       
                                                               -
  URL of my hompage           http://www.inf.ethz.ch/personal/camenisc
------------------------------------------------------------------------