Subject: UncorrectableError from two disk sectors

From: Douglas Bates <[email-masked]>
Date: Mon, 12 Aug 96 17:37 CDT

`dmesg' shows a lot of messages about two sectors on my disk.  For
example
 hda: read_intr: error=0x01 { AddrMarkNotFound }, LBAsect=1097170, sector=48787
 hda: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
 hda: read_intr: error=0x40 { UncorrectableError }, LBAsect=1097170, sector=48787
 end_request: I/O error, dev 03:05, sector 48787
 hda: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
 hda: read_intr: error=0x40 { UncorrectableError }, LBAsect=1097170, sector=48787
 end_request: I/O error, dev 03:05, sector 48787
 hda: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
 hda: read_intr: error=0x40 { UncorrectableError }, LBAsect=1044268, sector=814444
 end_request: I/O error, dev 03:03, sector 814444

Should this be a concern?  What action would be recommended?

---

From: Michael Harnois <[email-masked]>
Date: 12 Aug 1996 21:20:59 -0500

Douglas Bates <[email-masked]> writes:

> 
> `dmesg' shows a lot of messages about two sectors on my disk.

Oh, thank God! I'm not the only one! I thought my disk was dying!

---

From: [email-masked] (Bruce Perens)
Date: Tue, 13 Aug 96 08:59 PDT

> `dmesg' shows a lot of messages about two sectors on my disk.
From: Michael Harnois <[email-masked]>
> Oh, thank God! I'm not the only one! I thought my disk was dying!

Maybe it is. Read the man page for "e2fsck", and look for the "-c"
flag. Read the man page on "badblocks", too. That will help you retire
those bad blocks, given that they are on our usual EXT2 filesystems.
I see that "mkswap" (used to make swap partitions) has a "-c" option
as well, but I'm not clear that it actually retires the block.

If more bad blocks with different numbers pop up after that, think about
a new disk.

	Thanks

	Bruce

---

From: Gerry Jensen <[email-masked]>
Date: Tue, 13 Aug 1996 10:04:09 -0600 (MDT)

>  hda: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
...
> Should this be a concern?  What action would be recommended?

I also get this.  It's lead to several system crashes.  I would recommend
you back up.  If possible, post that you are getting these messages along
with the output from dmesg to the linux-kernel mailing list
([email-masked]) so as to give the developers as much
information as possible to figure out where the problem is. 

I have a 1.5g Maxtor hard drive.  My motherboard has the Intel Triton
chipset.  Do we have anything in common here?  I'm currently running
2.0.11 but have had this with other 2.0.x kernels as well. 

Regards,

Gerry

---

From: Michael Harnois <[email-masked]>
Date: 13 Aug 1996 17:20:17 -0500

> 2.0.11 but have had this with other 2.0.x kernels as well. 

Aha. I've been having this problem and I have a 1.6 Maxtor HD ...

---

From: Kevin M Bealer <[email-masked]>
Date: Tue, 13 Aug 1996 20:51:09 -0400 (EDT)

> Should this be a concern?  What action would be recommended?

Aug 13 01:16:15 brando kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Aug 13 01:16:15 brando kernel: hda: write_intr: error=0x04 { DriveStatusError }
Aug  6 18:50:42 brando kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Aug  6 18:50:43 brando kernel: hda: write_intr: error=0x04 { DriveStatusError }
Aug  6 23:20:24 brando kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Aug  6 23:20:24 brando kernel: hda: write_intr: error=0x04 { DriveStatusError }

This are skimmed from my /var/log/messages ...

My system is a Maxtor 540 (Bios calls it a 528) MB drive, IDE
and a 486-33.

BTW:  I posted about these messages on the linux-kernel list a
few days ago, it is being discussed there.  This is almost
certainly not Debian specific.

[email-masked]/GNU__1.1___Linux__2.0.11___
    THE LESSER-KNOWN PROGRAMMING LANGUAGES #12: LITHP
This otherwise unremarkable language is distinguished by the
absence of an "S" in its character set; users must substitute
"TH".  LITHP is said to be useful in protheththing lithtth.