Subject: Adding nfs and ip modules to base

From: Jeppe Sigbrandt <[email-masked]>
Date: Tue, 6 Aug 1996 21:56:44 +0100

Hi,

During installation I was prompted to select some modules to
install.

I wanted nfs but it replied

	nfs_mknod undefined
	nfs_sillyrename_create undefined
	nfs_create undefined undefined
	nfs_mkdir undefined undefined
	nfs_lookup_cache undefined undefined
	nfs_rename undefined undefined
	nfs_lookup undefined undefined
	nfs_nfs_rmdir undefined undefined
	nfs_link undefined
	nfs_refresh_inode undefined
	nfs_symlink undefined
	nfs_unlink undefined
	Loading failed ! The module symbols 
	(from linux-2.0.6) don't match your linux-2.0.6
	Installation failed

For the internet protocol drivers it said:
	Can't locate module console

And for my ne2000 card:
	ne.c : Module autoprobing not allowed
	append "io=0xNNN" values

	(Howabout pointer to Ethernet Howto in Installation doc
	where values to try above can be found)

I also tried (with identical results):
	modprobe -t fs nfs.o

Fortunatly, can still use computer since didn't overwrite
previous system.  However, can't install Debian since cannot
mount the nfs drive where distribution will be kept.

Have read the Module-Howto and related Docs but can't find 
a solution to these problems.  I fed the first line of nfs 
error message to dejanews using 200,000 linux messages and it 
found nothing !  It looks simple, since the
messges don't seem cryptic, but what do I know ...

Thanks in advance for any enlightenment,
Jay

---

From: Mike <[email-masked]>
Date: Wed, 7 Aug 1996 12:37:25 -1000

I'm trying to install Debian 1.1 and can't seem to get the loopback
device configured. At boot up the error:

    SCIOADDRT: Invalid argument

appears when the /etc/init.d/network script runs. The offending line
in this script is:

    route add -net 127.0.0.0

ifconfig reports (output below) that the loopback interface does not
have the inet addr that I expect it to have (nor the one that it had
under Debian 0.93R6, BTW).

Any help or pointers appreciated. Mike.

Here's the output from ifconfig:

lo       Link encap:Local Loopback  
         inet addr:255.255.255.255  Bcast:127.255.255.255  Mask:255.0.0.0
[which used to read:
         inet addr:127.0.0.1 Bcast:127.255.255.255  Mask:255.0.0.0
]
         UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
         RX packets:0 errors:0 dropped:0 overruns:0
         TX packets:0 errors:0 dropped:0 overruns:0

eth0     Link encap:10Mbps Ethernet  HWaddr 00:A0:24:0D:08:7E
         inet addr:xxx.yyy.zzz.164  Bcast:xxx.yyy.zzz.191  Mask:255.255.255.192
         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         RX packets:1074 errors:0 dropped:0 overruns:0
         TX packets:135 errors:0 dropped:0 overruns:0
         Interrupt:5 Base address:0x300 

Here's the current /etc/init.d/network script:
#!	/bin/sh
ifconfig lo 127.0.0.1
route add -net 127.0.0.0
IPADDR=xxx.yyy.zzz.164
NETMASK=255.255.255.192
NETWORK=xxx.yyy.zzz.128
BROADCAST=xxx.yyy.zzz.191
GATEWAY=xxx.yyy.zzz.129
ifconfig eth0 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
route add -net ${NETWORK}
route add default gw ${GATEWAY} metric 1

And, FWIW, here's the 0.93R6 /etc/init.d/network:
#! /bin/sh
# network: establish the network connection.
# $Id: network,v 1.1 1995/02/19 20:29:29 imurdock Exp $

# Configure the loopback device.
ifconfig lo 127.0.0.1
route add 127.0.0.1

# Configure the ethernet device or start SLIP/PPP below.
IPADDR="xxx.yyy.zzz.164"	# Your IP address.
NETMASK="255.255.255.192"	# Your netmask.
NETWORK="xxx.yyy.zzz.128"	# Your network address.
BROADCAST="xxx.yyy.zzz.191"	# Your broadcast address (blank if none).
GATEWAY="xxx.yyy.zzz.129"	# Your gateway address.

/sbin/ifconfig eth0 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}

/sbin/route add -net ${NETWORK}
/sbin/route add default gw ${GATEWAY} metric 1

---

From: Mr A Birdi <[email-masked]>
Date: Wed, 7 Aug 1996 14:41:21 +0100

> mount the nfs drive where distribution will be kept.

I get exactly the same set of problems and also have a half-formed 1.1
system. Any help is certainly appreciated.

-- 
    -------------------------------------------------------------
   | Alvin Birdi                    Email: [email-masked] |
   | School of Economic Studies     Tel: 0161 275-4791           |
   | University of Manchester       Fax: 0161 275-4812           |
   | Manchester M13 9PL  UK                                      |
    -------------------------------------------------------------