Subject: FW: #1, make it boot! Engage.

From: [email-masked] (Ninoles, Fabien: DGSE)
Date: Wed, 21 Aug 1996 12:13:29 -0400

<SNAP ON>
 ----------
From:  Bruce Perens[SMTP:[email-masked]]
Sent:  Tuesday, August 20, 1996 9:34 PM
To:  bruce; salwen; Happy Linux Users; Charles A. Schuman
Subject:  Re:  #1, make it boot!  Engage.

From: "Charles A. Schuman" <[email-masked]>
> # fdisk  (then "p")
>  Device Boot Begin Start  End  Blocks   Id  System
> /dev/sda1  *    1      1    251   513891   6  DOS 16-bit >=32M
> /dev/sda2     252    252    976 1484437+  83  Linux native
> /dev/sda3     977    977   1003   55282+  82  Linux swap

Note the "*" is next to the DOS partition.
This will cause the DOS partition to boot, because it's marked as
the "Boot" partition. I'm not sure what MBR (master
boot record) you have. If you have the Debian one, holding the shift key
down while the system boots will cause a "123FA: " prompt (or something
similar). Press 2 and see if Linux comes up.

If you have the DOS MBR, you won't get that prompt. Use FDISK (on DOS or
Linux) or "activate" on Linux to set /dev/sda2 to be the "Boot"   
partition.
That will also set the _default_ partition booted by the Debian MBR.

> The drive is a SLED (Single Large Expensive Disk).

Are you sure it's not an IPTMCTWTSFN? That means "I Paid Too Much   
Compared
to What They Sell For Now". I have a whole room full of those. :-)

> Here's the messed up lilo.conf on what now is /target/etc/lilo.conf:
>
> boot=/dev/sda2
> root=/dev/sda2
> install=/target/boot/boot.b
> vga=normal
> delay=20
> image=/target/boot/vmlinuz
> label=Linux

That looks like an OK lilo.conf but it's living on the sda2 partition
(as it should), and you need to set that "Boot" designation or you'll
never run it.

> I can't even begin to speculate on what this is all doing.

At boot time, the boot ROM loads the first block of the disk. The first
446 bytes of that block contain the MBR. The next 66 bytes are the
partition table. If the MBR starts with the right byte pattern, the ROM
jumps into its code. The MBR looks for first partition in the table
with the "Boot" flag set. The first block (maybe more - I don't know)
of that partition is loaded, and the MBR jumps to that code. In your case
that should be what LILO wrote, but the flag is on the wrong partition so
you boot (or try to boot) the DOS partition instead.

 Bruce

<SNAP OFF>

For myself (I have a look-alike partitions table), I prefer
to boot with a floppy and rerun LILO on my MBR. You will
set it by replacing your boot line by boot=/dev/sda who
will write on your sda MBR, in place of /dev/sda2 who
would write on your partition. After that, just run lilo
when you're root. the Boot flag are only use in OS/2 or
MS-OSs at my knowledge. It's better to only have one set
because MS-DOS doesn't support multiple boot parts.

 ---------------------------------------------------------------
The contradiction is not that free software are among the best,
   it's that commercial software aren't the best of them.
===============================================================
Fabien Ninoles aka the Baggus Mage aka Baffouille
[email-masked]             +-----------------------------
finger me for my PGP Public Key  | Not knowing where you go
                                 | always lead you to
[space must be fill to register] | a Baggus End...
 ---------------------------------------------------------------
Can be reach too on [email-masked] until 30/08/96
 ---------------------------------------------------------------

---

From: "Charles A. Schuman" <[email-masked]>
Date: Wed, 21 Aug 1996 23:52:27 -0500 (CDT)

> because MS-DOS doesn't support multiple boot parts.

I replaced line "boot=/dev/sda2" with "boot=/dev/sda"
and now I've an endless loop that goes:

LILO Loading Linux.......

LILO Loading Linux.......

LILO Loading Linux.......

LILO Loading Linux.......

LILO Loading Linux.......

LILO Loading Linux.......

with the seven dots.  Pressing shift gives me the 

LILO boot:

What should I try next to get the hard drive to boot
the kernel on the second partition?  I may have ruined
it by writing a boot record onto the second partition.
I really don't know what I've done.  I made sure to 
check the second partition - it is set active/bootable.
I'd made a typo earlier and ommited the star (*).

Missing Linux,

Charles