Subject: Re: help getting X and openwin to work?

From: Sven Rudolph <[email-masked]>
Date: Thu, 1 Aug 1996 19:02:18 +0200

In article <[email-masked]> [email-masked] (Ken Gaugler) writes:

> I really prefer running openwin, so I created the directory
> /usr/openwin and copied all the stuff from my Slackware system over
> to there (bin, lib, etc.)  

FYI: I will upload a xview package including the openwin-like programs
next week.

	Sven
-- 
Sven Rudolph <[email-masked]> ; WWW : http://www.sax.de/~sr1/

---

From: [email-masked] (Erick Branderhorst)
Date: Thu, 1 Aug 1996 11:31:05 +0100

> So I went back and fixed that, and everything configured fine
> except the X server setup.  After fixing a problem with the
> mouse in XF86Config, I got X up and running fairly well.  I think it
> is giving me fvwm as the default window manager, and the middle mouse
> button doesn't work right ( the menu flashes a lot and I cannot select
> anything on that menu).

In /etc/X11 there are a few files and dirs which you might want to
modify a bit.

> to there (bin, lib, etc.)  I can get openwin to start, display the
> Linux openwin logo, but before the screen turns blue, the X-server
> exits with the message
> lwm: can't find library 'libolg.so.3'
> 
> That library exists in the openwin/lib hierarchy, so I think there must
> be a link missing somewhere, possibly between /usr/X11/lib and somewhere.
> Do you know anything about this, or can I give you any more information
> to help me solve this?

This is a shared library and for libraries to be found you have to run
ldconfig as root after moving or installing libraries.

Erick

---

From: [email-masked] (Wichert Akkerman)
Date: Thu, 1 Aug 1996 16:13:48 +0200 (MDT)

> > lwm: can't find library 'libolg.so.3'

[.. snap ..]

> ldconfig as root after moving or installing libraries.

Also make sure /usr/openwin/lib is mentioned in /etc/ldconfig.

Another option is to add /usr/openwin/lib to LD_LIBRARY_PATH using
	export LD_LIBRARY_PATH=/usr/openwin/lib
if you use bash, or
	setenv LD_LIBRARY_PATH /usr/openwin/lib
if you use tcsh or csh.

Wichert.

---

From: [email-masked] (Ken Gaugler)
Date: Thu, 01 Aug 1996 00:31:08 -0700

I had no luck getting X to run on my first installation of Debian
1.1 from the Gold cd from I-connect.

So I completely re-loaded the distribution, taking extra care to
resolve the dependency conflicts.

When I got to the configure packages section, I noticed in the
error message
  "dpkg - Configure returned error exit status 1"
that there were still a couple of things not installed right.

Thanks!!

---
Ken Gaugler  URL:http://users.aimnet.com/~keng
"The life of a Repo Man is ALWAYS INTENSE..."