Subject: Two Questions

From: Dan Bergman <[email-masked]>
Date: Tue, 06 Aug 1996 14:35:50 +0200

1. How do I set up a boot so I can boot Debian or Win95? 
 Now I have to use a boot disk to get debian to boot...

2. How do I change the diplay mode in XF86 from 8bit to 16bit
color? I have a Diamond Stealth 64 Video VRAM w/ 2MB and use 
16bit color in win95 so there shouldn't be any probs to get
it in X too..

---

From: Dale Scheetz <[email-masked]>
Date: Tue, 6 Aug 1996 16:04:43 -0400 (EDT)

>  Now I have to use a boot disk to get debian to boot...

Check out loadlin in the tools path. You will need to set up config.sys
with a menu, so you can choose between Linux and Win95. Then set up
autoexec.bat to run loadlin, or win95 depending on your selection from the
menu. Check with me if you need more details.

> 16bit color in win95 so there shouldn't be any probs to get
I hesitate to say anything here, as my knowledge may be dated or just
plain incorrect. It is my understanding that the Diamond Stealth cards are
not supported due to NDAs being required by Diamond. If this has changed,
someone please correct me ;-)

Luck,

Dwarf

------------                                          --------------

aka   Dale Scheetz                   Phone:   1 (904) 877-0257
      Flexible Software              Fax:     NONE 
      Black Creek Critters           e-mail:  [email-masked]

------------ If you don't see what you want, just ask --------------

---

From: Syrus Nemat-Nasser <[email-masked]>
Date: Tue, 6 Aug 1996 19:42:00 -0700 (PDT)

> someone please correct me ;-)

Diamond did cooperate, and most of the Stealth cards are supported.  I use
Stealth 64's on all my linux PC's and they work under the accelerated S3
server.

To choose 16 bit color, you can invoke: startx -- -bpp 16.  The '--' prevents
the startx front end from evaluating the -bpp option so it gets passed to
X.

Syrus.

----------------------------------------------------------
Syrus Nemat-Nasser <[email-masked]>    UCSD Physics Dept.

---

From: Kevin M Bealer <[email-masked]>
Date: Wed, 7 Aug 1996 05:26:29 -0400 (EDT)

> 16bit color in win95 so there shouldn't be any probs to get

generally, you type:

startx -- -bpp 16

You need XF86Config set up correctly (is it possibly already
correct?)

You can also edit the Xservers file (type "locate Xservers" it
should be in /etc/X11 somewhere) to use 16 bit.  Mine has:

:0 local /usr/X11R6/bin/X -gamma 1.5 -bpp 16

as the active ingredient.

[email-masked]/GNU__1.1___Linux__2.0.11___
We believe that man is essentially good.  It's only his behavior
that lets him down.  This is the fault of society.  Society is
the fault of conditions.  Conditions are the fault of society.
				-- Steve Turner, "Creed"

---

From: Michael Meskes <[email-masked]>
Date: Wed, 7 Aug 1996 12:09:42 +0200 (MET DST)

>  Now I have to use a boot disk to get debian to boot...

Try this lilo.config:

# Start LILO global section
boot = /dev/hda
compact        # faster, but won't work on all systems.
delay = 50
vga=extended
ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /vmlinuz
  root = /dev/hda2
  label = linux
# Linux bootable partition config ends
# WIN95 bootable partition config begins
other = /dev/hda1
  label = win95
  loader = /boot/chain.b
# WIN95 bootable partition config ends

I haven't tried it yet (since my WIN95 is on hdb not hda it has to be
different). It should work, though. In any case you get the idea. Once you
started lilo from Linux you should be able to boot both via the LILO prompt.

Michael

-- 
Michael Meskes                   |    _____ ________ __  ____
[email-masked] |   / ___// ____/ // / / __ \___  __________
[email-masked]                  |   \__ \/ /_  / // /_/ /_/ / _ \/ ___/ ___/
[email-masked]                |  ___/ / __/ /__  __/\__, /  __/ /  (__  )
Use Debian Linux!                | /____/_/      /_/  /____/\___/_/  /____/