Subject: shutdown: non-existing PID

From: Michael Gaertner <[email-masked]>
Date: Tue, 6 Aug 1996 15:42:37 +0200 (MET DST)

shutdown -h now

console-message:
"start-stop-daemon:warning: failed to kill 218: No such process"

Indeed there is no PID 218. BTW the pid-number changes with every
shutdown.
I think it has something to do with X Windows because I have another
debian-system without X Windows installed - and I don't get this message.

Which script invokes this message? (I use sysklogd 1.3-8) for
message-logging and start debian with loadlin.

Please include my personal email-adress in your r.

Cheerio, Michael.

Michael Gaertner <[email-masked]>
Tel/Fax +49-761-32684

---

From: Philippe Troin <[email-masked]>
Date: Tue, 06 Aug 1996 11:51:39 -0700

> debian-system without X Windows installed - and I don't get this message.

I have the same minor problem, and it's '/etc/init.d/xdm stop' which causes the trouble. From what I've found, start-stop-daemon will kill the process tree of the daemon to stop. In case of xdm, it will try to kill xdm first, then X.
But, xdm kills X too when it's about to shutdown. The message appears when xdm kills X before start-stop-daemon. Sometimes, no message appears, and I assume that happens when start-stop-daemon kills X before xdm.

I have no fix yet. (It's only a minor annoyance)

Phil.

---

From: Michael Gaertner <[email-masked]>
Date: Wed, 7 Aug 1996 14:08:08 +0200 (MET DST)

> > Indeed there is no PID 218. BTW the pid-number changes with every

That's not true. examin with ps -ef

> But, xdm kills X too when it's about to shutdown. The message appears when xdm kills X before start-stop-daemon. Sometimes, no message appears, and I assume that happens when start-stop-daemon kill…

Ok, what happens is: 

PID (ex.)	COMMAND
151		/usr/bin/X11/xdm
159		\_ /usr/X11R6/bin/X
160		\_ -:0 ;(local display-server)		

shutdown invokes k01xdm:
star-stop-daemon --stop --verbose --exec /usr/bin/X11/xdm

invoked "by hand" prints same message:
"[...] failed to kill 160: No such process
stopped /usr/bin/X11/xdm (pid 160)"

which gets printed by start-stop-daemon script (r1.2.13):
[...]
for $pid (@found) {
    if ($testmode) {
       [...];
    } else {
        if (kill($signal,$pid)) {
           push(@killed,$pid); is this wrong ?
        } else {
            print "start-stop-daemon: warning: failed to kill $pid:$!\n";#
	}
    }

Maybe Jan can help?

> I have no fix yet. (It's only a minor annoyance)
you can always use ssd --quite ;)