Subject: Problem with 3C509 ifconfig

From: Ken Gaugler <[email-masked]>
Date: Fri, 16 Aug 1996 07:26:34 -0700

Last night I tried to manually ifconfig my eth0 interface
(3Com 509 combo card), then tried to ping it, and got this:

>ping: sendto: Network is unreachable
>ping: wrote 166.117.11.123 64 chars, ret=-1
>
>--- 166.117.11.123 ping statistics ---
>10 packets transmitted, 0 packets received, 100% packet loss
># netstat -rn
>Kernel IP routing table
>Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
>166.117.11.125  0.0.0.0         255.255.255.255 UH     1500 0          0 eth0
>127.0.0.0       0.0.0.0         255.0.0.0       U      3584 0          0 lo
># ifconfig -a
>lo        Link encap:Local Loopback  
>          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
>          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0
>          TX packets:0 errors:0 dropped:0 overruns:0
>
>eth0      Link encap:10Mbps Ethernet  HWaddr 00:A0:24:0F:15:63
>          inet addr:166.117.11.123  Bcast:166.117.11.255  Mask:255.255.255.0
>          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>          RX packets:0 errors:0 dropped:0 overruns:0
>          TX packets:0 errors:0 dropped:0 overruns:0
>          Interrupt:10 Base address:0x250 
>
>
>

Did I forget something?  I am pretty sure the card is good, and during
bootup I see that the MAC address is seen by the kernel, with the card
at 0x250 and IRQ 10.  Are these settings OK?

Thanks for your help!
---
Key fingerprint =  D6 A7 D7 8C 92 CB 42 FD  60 D5 62 1C D7 B9 EA 8E 
Ken Gaugler  N6OSK         Hybrid Networks, Inc.  Cupertino, Calif.
URL: www.hybrid.com (home: [email-masked]  URL: users.aimnet.com/~keng)
"The life of a Repo Man is ALWAYS INTENSE..."

---

From: [email-masked] (Bernd Eckenfels)
Date: Mon, 19 Aug 1996 13:01:10 +0200 (MET DST)

> >127.0.0.0       0.0.0.0         255.0.0.0       U      3584 0          0 lo
There is no default an no net route, therefore the kernel doesnt know how to
reach 166.117.11.123.

Greetings
Bernd