Subject: Re: Fix for your serial/PPP problems

From: [email-masked] (renald loignon)
Date: Wed, 21 Aug 1996 00:23:16 -0400 (EDT)

Could someone knowledgeable in low-level kernel matters take a look at the
following?  I looked at the Web page, and though it sounds interesting
overall (and it WOULD solve a serial problem I experienced with Debian 1.1.1
and kernel 2.0.6), there appear to be some technical inaccuracies which give
me second thoughts. Any comments appreciated.

"Craig A. Estey" <[email-masked]> wrote
To: [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked],
        gbutler@I_should_put_my_domain_in_etc_NNTP_INEWS_DOMAIN,
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked],
        [email-masked], [email-masked], [email-masked]

>Hi, Folks
>
>All of you have posted problems with serial/PPP to comp.os.linux.* newsgroups
>(under various heading listed at the end of this message).
>
>I had exactly the same problems.  I did some microsecond resolution performance
>profiling of the kernel.  I found a kernel bug and devised a fix.
>I have been scanning the groups and have not found a similar fix anywhere.
>
>Online documentation (FAQ format) that explains all (the *real* problem is
>IRQ priority):
>	http://www.best.com/~cae/irqtune
>
>The entire package:
>	ftp://www.best.com/pub/cae/irqtune.tgz
>
>I've been running the patch for over a month and I tripled the throughput
>of my 33.6 modem from 700 chars/sec to over 2500 chars/sec.  It also fixes
>data dropouts.
>
>I'm going to post this to the newsgroups but I need some testing in various
>configurations.
>
>Please give it a try. I'd greatly appreciate your feedback via email.
>Send your configuration data, what performance you got, what you think.
>
>Thanks,
>Craig Estey
>[email-masked]
>
>---------------------------------------------------------------------------
>Subjects:
>> Erratic IP forwarding via PPP
>> Hanging file transfers (ppp,linux 1.2.13)
>> Has SLIP gotten slower in 2.0.x?
>> Help with pppd error messages in syslog
>> How to measure speed of my pppp link
>> Linux:/PPP dead end! Do I need NT?
>> Modem quits after 20 seconds
>> Modem trouble (Need Help)
>> NFS over PPP usable?
>> Only getting half my bandwidth through modem (ftp)
>> PPP 2.2.0f connect to Xylogics Annex 4000 hangs
>> PPP Slowness
>> PPP hangs while sending large files
>> PPP problem even after looking at many references/posts to no avail
>> PPP routing problem
>> PPP unreliable
>> PPPD Problem w/ Pentium & Kernel 2.0.7
>> Q: SLIP comm waits on IDE disk
>> RTS/CTS flow control problems with Motorola BSP
>> Re: *very* slow SLIP
>> Re: Has SLIP gotten slower in 2.0.x?
>> Re: How to get precise interrupt timing? (reading RC PPM signal)
>> Re: PPP slow (450bytes/sec)
>> Re: PPP throughput, tuning, & network info
>> Re: Serial port problem with Linux-2.0.x (x > 3)
>> Re: Slow -> halt modem
>> Serial port problem with Linux-2.0.x (x > 3)
>> Speeding up telnet?
>> TCP connections and degrading performance
>> Unexplained PPPD hangups.
>> Weird PPP Latency Effect
>> help I have a very slow ppp connection
>> modem trouble(help)
>> ppp setup problem
>> ppp2.0.d problems. It a BUG or a configuration mistake ????
>> ppp: frame with bad fcs
>> serial handing bug in 2.0.12?

---

From: Philippe Troin <[email-masked]>
Date: Wed, 21 Aug 1996 00:14:10 -0700

> me second thoughts. Any comments appreciated.
[mail copy snipped]

I've browsed through the web page, and this just looks sensible to me.
The question is: why isn't this part of standard kernel ?

Phil.

---

From: [email-masked] (Christoph Lameter)
Date: 21 Aug 1996 11:44:44 -0700

renald loignon ([email-masked]) wrote:
: Could someone knowledgeable in low-level kernel matters take a look at the
: following?  I looked at the Web page, and though it sounds interesting
: overall (and it WOULD solve a serial problem I experienced with Debian 1.1.1
: and kernel 2.0.6), there appear to be some technical inaccuracies which give
: me second thoughts. Any comments appreciated.
What are the inaccuracies you are referring to? Seems to be ok as far as I can tell except I dont
know enough about PIC programming to tell if he is right on that.