Subject: X and mouse

From: Adrenolin <[email-masked]>
Date: Thu, 1 Aug 1996 16:09:36 -0400 (EDT)

hiya all
	i'm haveing trouble configureing my mouse for use in the
xf86config. i have a logitech 2 button mouse. in the boot process it saz
foud PS/2 mouse but nothing more. i have in the xf86config file:

Section "Pointer"
	Protocal "PS/2"
	Device   "/dev/mouse"

	how can i set this correctly and/or check where/what the Device
should be. i use startx and use the fvwm window manager. it comes up but
no control over the mouse.

-Rob

	/---------------------------------------------------------\
	|   	        Robert "Adrenolin" MacQuarrie             |
	|		     [email-masked]                  | 
	|=========================================================|
	|     ProvisioNet Distributions at New Jersey Branch      |
	|	   Email: [email-masked]           |
	\---------------------------------------------------------/

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Fri, 02 Aug 1996 06:12:00 -0400

Hi Robert --
> foud PS/2 mouse but nothing more. i have in the xf86config file:

What do you get when you execute
	ls -l /dev/mouse
Does the link point to the I/O port which is connected to your mouse?

Susan Kleinmann

---

From: Dale Scheetz <[email-masked]>
Date: Fri, 2 Aug 1996 08:50:42 -0400 (EDT)

> no control over the mouse.

Are you sure this is a PS/2 mouse? Does it have the cylindrical connector
or the trapazoidal 9 pin DIN? I'm not sure why the kernel says it found a
PS mouse, but it sounds like you want the serial protocal.

Luck,

Dwarf

------------                                          --------------

aka   Dale Scheetz                   Phone:   1 (904) 877-0257
      Flexible Software              Fax:     NONE 
      Black Creek Critters           e-mail:  [email-masked]

------------ If you don't see what you want, just ask --------------

---

From: Adrenolin <[email-masked]>
Date: Fri, 2 Aug 1996 20:52:50 -0400 (EDT)

> PS mouse, but it sounds like you want the serial protocal.
yes it is a logitech mouse thu in dos configured as PS/2. it is a 6 pin
cylindrical connector.

---

From: [email-masked]
Date: Fri, 2 Aug 96 23:33 EDT

--text follows this line--
I too am having trouble with X and my mouse.  No matter what I try for the
mouse device, the X servr fails with the message "Cannot open mouse (no such
device)".  How to I tell what device my mouse is?  During boot the BIOS just
says "Mouse recognized", and the kernel says nothing.

I have a Microsoft PS/2 mouse.  I used to run Slackware, and it worked fine.
Now I'm using Debian-1.1.  I found some links in /dev:  msmouse->inportbm,
psmouse->psaux, and I tried them, as well as making /dev/mouse point to them.
Nothing helped.

--

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Sat, 03 Aug 1996 06:31:38 -0400

Hi --

> psmouse->psaux, and I tried them, as well as making /dev/mouse point to them.

If you have a Microsoft PS/2 mouse (6-pin connector) then 
-- /dev/mouse should point to /dev/psmouse.
-- you should have these lines in /etc/X11/XF86Config (in Section "Pointer"):
	Protocol	"PS/2"
	Device		"/dev/psmouse"
-- you should be using one of the special kernels in
	buzz-fixed/disks-i386/special-kernels
   They all support bus mice as modules.

Good luck,
Susan Kleinmann

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Sat, 03 Aug 1996 06:41:45 -0400

Hi Robert --

Given all the reports regarding bus mice recently, I was motivated to
read the section on mice in the kernel-sources Documentation/devices.txt.
(Should have done that a while ago.)

That indicates that if you have a Logitech bus mouse, you should either

use 
	Device "/dev/logibm"
in your /etc/X11/XF86Config, 

OR 

use
	Device "/dev/mouse" 
if you've already executed: 
	ln -s /dev/logibm /dev/mouse

Good luck.
Susan Kleinmann