Subject: Re: More info on PPP problem

From: Berntsen <[email-masked]>
Date: Fri, 02 Aug 1996 06:03:15 +0200

At 23:07 01.08.96 -0500, you wrote:
>Regarding your PPP problem:
>
>I just finished fighting something similar. I think what's happening is that
>the 'chat' section is not getting started. To test it, use the following 
>command (but insert your info in the right places)
>
>pppd -connect 'chat -v "" ATDT5551212 CONNECT "" ogin: yerlogin word:
>yerpassword' /dev/cua1 38400 debug modem noipdefault netmask 255.0.0.0

I'll try it. But I think the problem has something to do with modules,
since I get an error message saying that modprobe can't find ppp0.

---

From: Berntsen <[email-masked]>
Date: Fri, 02 Aug 1996 05:40:27 +0200

At 13:35 02.08.96 +1000, you wrote:
>Berntsen wrote:
>> 
>> When I boot I get the following on my screen:
>> 
>> PPP: version 2.2.0 (dynamic channel allocation)
>> TCP compression code copyright 1989 Regents of the University of California
>> PPP Dynamic channel allocation code copyright 1995 Caldera, Inc
>> PPP line discipline registered
>> ...
>> ...
>> Starting base network deamons: rpc.portmap  inetd
>> 
>> When I start 'ppp-on', it starts pppd, but pppd doesn't do anything.
>> The lights on my modem flashes, but it doesn't dial.
>> 
>> It seems as if the ppp is loaded, and I have set up the files
>> /etc/ppp/options
>> /etc/ppp/chatscript
>> It's just that it doesn't dial.
>> What's wrong?
>
>It seems that you didn't set the ATDT<phone no> in your chatscript file.
>
Yes, I did.
I found out even more.
modprobe probes for ppp0, which is set as:
alias ppp0 ppp
alias ppp1 ppp
in the etc/conf.modules
So it seems as if kerneld think that ppp is a module or something (?)
Well, I think the ppp is loaded, but not as a module,
so how should I fix it?

---

From: [email-masked] (Tim O'Brien)
Date: Thu, 1 Aug 1996 23:05:32 -0500

Use /dev/cua0 for COM1, /dev/cua1 for COM2.
Replace 5551212 with your ISP's phone#, and change it to ATm0DT if you want 
the modem not to raise cain when it connects (mine's loud as heck!)

When it's done, and looks connected, issue 

route add default gw 123.123.123.123

Replace 123.123.123.123 with your ISP's gateway address. If you don't know it,
they can give it to you.

This should work for diagnostic purposes, but sure is a pain to do each time.
I set up some scripts to do it all for me, works ok. Let me know if this helps,
if something needs clarification, let me know.

Good luck!
Tim

BTW, let me know if it works on your system..

-------------------------------------------------------------------------
 < I am Pentium of Borg. Division is futile. You will be APPROXIMATED! > 
-------------------------------------------------------------------------
Email: [email-masked]