Subject: sendmail queuing incoming mail

From: Scott Barker <[email-masked]>
Date: Fri, 16 Aug 1996 13:53:54 -0600 (MDT)

I'm trying to figure out why my incoming mail (coming in via uucp) is being
queued up instead of being delivered straight to my mailbox.

I'm using debian sendmail, Version: 8.7.5-4

I've got the following in my .mc file:

VERSIONID(`@(#)sendmail.mc	8.7 (Linux) 3/5/96')
OSTYPE(debian)dnl
FEATURE(nocanonify)dnl
FEATURE(nouucp)dnl
FEATURE(nodns)dnl
FEATURE(local_procmail, /usr/bin/procmail)
MAILER(local)dnl
MAILER(smtp)dnl
FEATURE(mailertable, hash /etc/mailertable)
define(`UUCP_MAX_SIZE', 0)
define(`SMART_HOST', uucp-dom:cuugnet)
MAILER(uucp)

Which results in the following in my sendmail.cf file (among much else):

O DeliveryMode=background

Mlocal,		P=/usr/bin/procmail, F=lsDFMAw5:/|@SPfhn, S=10/30, R=20/40,
		T=DNS/RFC822/X-Unix,
		A=procmail -Y -a $h -d $u

As you can see, the expensive flag is not present, and queue mode is not set,
so I can't figure out why the mail is being queued. Outgoing mail is sent to
uucp right away.

Can anyone shed some light on this for me? I've never run across this problem
with sendmail before (and I've used sendmail a *lot*, right down to re-writing
rule-sets). This is the newest version of sendmail I've ever used though, so
perhaps I'm missing something somewhere?

-- 
Scott Barker
Linux Consultant
[email-masked]
http://www.cuug.ab.ca:8001/~barkers/   (under construction)

[ I try to reply to all e-mail within 3 days. If you don't   ]
[ get a response by then, I probably didn't get your e-mail. ]
[ Unsolicited commercial and junk e-mail will be proof-read for US$100 ]

"The shortest distance between two points is under construction."
   - Noelie Altito

---

From: Nikita Schmidt <[email-masked]>
Date: Mon, 19 Aug 1996 16:02:58 +0400

>queued up instead of being delivered straight to my mailbox.

Maybe this happens because of rmail that invokes sendmail with -odq
to explicitly specify queue delivery mode?
Try rmail -T to check the arguments it passes to sendmail.

	Kit.