Subject: Problems with aha1542.o ...

From: "Richard G. Roberto" <[email-masked]>
Date: Tue, 13 Aug 1996 08:09:30 -0400 (EDT)

I posted earlier about this, but I have more info and it
seems to be specific to this module and not lilo.  I had to
change my base_io from 330 to 234 to accomodate my MPU-401
interface on the Audiotrix Pro card.  This works fine under
DOS/WIN with a "/P234" switch at load time for the driver.
The analogous entry for the aha1542.o module is a lilo
parameter "aha1542=0x234".  I've added this to the top of my
lilo.conf file with 'append = "aha1542=0x234"' but I still
get errors.  I tried doing depmod -a (which showed some
unresolveable symbols in sound.o :-() and modprobe but no
luck.  I did an strace -f on it and it seems that its
unable to find its irq.  I can't find any way to pass a
parameter to the module to tell it what irq I'm on (10)!

I took the advice from someone on the list and checked out
/proc/... but there are no conflicts there (I suspected
not).  I plan on upgrading to kernel 2.0.12 in the next few
days, but this module hasn't changed at all (I think the
sound.o will be fixed though!).  If this magically fixes
anything, I'll let you guys know.  In the mean time, anyone
got any ideas?  The load time error I get is this:

Initialization of aha1542 failed
scsi_mod: Device or resource busy

which is pretty general.  I can send the strace file to
anyone willing to have a look.

Thanks in advance!

Richard G. Roberto
[email-masked]
201-739-2886 - whippany, nj

--
*******************************************************************************
Bear Stearns is not responsible for any recommendation, solicitation, offer or
agreement or any information about any transaction, customer account or account
activity contained in this communication.
*******************************************************************************

---

From: "Christopher R. Hertel" <[email-masked]>
Date: Tue, 13 Aug 1996 14:13:11 -0500

On Aug 13,  8:09am, Richard G. Roberto wrote:
> Subject: Problems with aha1542.o ...
[snip]
: I did an strace -f on it and it seems that its
: unable to find its irq.  I can't find any way to pass a
: parameter to the module to tell it what irq I'm on (10)!

You can include the IRQ using a comma, as in:

  append = "aha1542=0x234,10"

It took me a while to search this down, but the documentation (thanks
to LDP) is available at:

  http://sunsite.unc.edu/mdw/HOWTO/BootPrompt-HOWTO-4.html#ss4.2

The syntax for the 'aha1542=' line is:

  aha152x=iobase[,irq[,scsi-id[,reconnect[,parity]]]]

This should, at minimum, allow you to include the IRQ.

I hope that helps!

Chris -)-----

-- 
Christopher R. Hertel -)-----                   University of Minnesota
[email-masked]              Networking and Telecommunications Services

---

From: [email-masked]
Date: Tue, 13 Aug 96 22:16 EDT

Christopher> It took me a while to search this down, but the documentation
  Christopher> (thanks to LDP) is available at:
  Christopher> 
  Christopher> http://sunsite.unc.edu/mdw/HOWTO/BootPrompt-HOWTO-4.html#ss4.2

If you install the doc-linux package, it is also at

	/usr/doc/HOWTO/*

As the doc-linux package is updated monthly with the upstream HOWTOs, you
should always look for the newest one in unstable/binary-all/doc. Safe to
install on any system as it's only text. Hard to put a bug into that :-)

--
Dirk Eddelb"uttel                             http://qed.econ.queensu.ca/~edd

---

From: "Richard G. Roberto" <[email-masked]>
Date: Wed, 14 Aug 1996 09:16:41 -0400 (EDT)

> install on any system as it's only text. Hard to put a bug into that :-)

Yes I read the BootPrompt-HOWTO, that's where I got the
append = "aha1542=0x234" syntax.  However, the driver source
code is where to get the module parameters (as per this same
HOWTO).  In the aha1542.c file, there is a section that
explains why you cannot pass IRQ or DMA parameters.  The
driver was apparently "upgraded" to issue "request_{irq,dma}
calls that query the board for that info.  I suspect that
the reason the module can't find the IRQ for the board is
because it can't find the board.  This was working fine
before I changed the base_io, and it still works fine under
DOS/WIN.  I'm sure I just need to properly inform the driver
module of the new base_io address (0x234).  

Does anybody know how I can tell what this value is set to?
I mean I set aha1542=0x234 in lilo, but how can I tell if
its been set in the kernel?  Can anybody tell me if I even
set it correctly?  It looks good to me, using the aha1542.c
file as a guide, but I'm rather new at this.  By the way,
I upgraded to kernel 2.0.12 last night, but no magic.

Thanks in advance

Richard G. Roberto
[email-masked]