Subject: Re: Isn't it a security hole...

From: Joshua Stockwell <[email-masked]>
Date: Thu, 15 Aug 1996 10:57:10 -0400

>>> On Aug 14,  2:35pm, Bruce Perens wrote:
>>> : Ahem. Let's not use the word "hacker" to mean "computer criminal" on
>>> : this list. "cracker" is more appropriate.
>>> >-- End of excerpt from Bruce Perens

Christopher R. Hertel wrote:
>>> Seconded.  The term "hacker" originally referred to one who would
>>> "hack" at [working] code to make it better, faster, cleaner, more fun,
>>> etc.  The term has been badly misused in recent years, and for some has
>>> taken on a new meaning.  Given the true meaning of the term, most of
>>> the people on this list could be called "hacker".

To be quite honest, I think it has two meanings now. And it is nothing
very recent, "hacker" has been used to label computer criminals at
least for the last 12 years. Like many other english words, you just
have to keep in mind under what context it is being used and apply the
most appropriate definition. I personally would never want to be
called a hacker, because it has a third definition for me -- someone
who spends way too much time on their computer :)

	-Josh Stockwell

---

From: "David L. Craig" <[email-masked]>
Date: Thu, 15 Aug 1996 17:11:36 -0400 (EDT)

As Joshua Stockwell wrote:

> >>> : Ahem. Let's not use the word "hacker" to mean
> >>> : "computer criminal" on this list. "cracker" is more
> >>> : appropriate.
> >>> Seconded.  The term "hacker" originally referred to one
> >>> who would "hack" at [working] code to make it better,
> >>> faster, cleaner, more fun, etc.  The term has been badly
> >>> misused in recent years, and for some has taken on a
> >>> new meaning.  Given the true meaning of the term, most
> >>> of the people on this list could be called "hacker".

> To be quite honest, I think it has two meanings now. And it
> is nothing very recent, "hacker" has been used to label
> computer criminals at least for the last 12 years. Like many
> other english words, you just have to keep in mind under
> what context it is being used and apply the most appropriate
> definition. I personally would never want to be called a
> hacker, because it has a third definition for me -- someone

Actually, all the above meanings are Johnny-come-latelies.
The original meanings (there are several nuances) derive from
hack (n.), a contraction of hackney, which means a horse used
in common work.  Leading into meaning a carriage for hire,
operated by a hacker, this is also applied to motorized
taxicab operators (I know, I was one before I discovered
computers).  Thus, through personal experience, I can attest
that the other nuances -- hired out, trite or commonplace,
make common by overuse, someone hired to do monotonous
mindless drugery, a lackey -- all these meanings come from
that taken-for-granted nag.

So it was with great surprise that, over twenty years ago, I
encountered the new meaning of hacker, which is truely at
variance with the established conotation of the word.  I say
this new meaning should be given completely to the crackers,
especially since, thanks to the media, society has already
done so, as Joshua has pointed out.

Thus, I propose a new word be adopted to describe the clever
and benign inventor of quick technical fixes.  Rasher, from
"Shockwave Rider" usage, is a possible candidate, except
Brunner's rashers seemed to operate too much outside the
boundaries of ethics, delving into industrial espionage and
even sabotage, as I recall.  Ideas, anyone?