Subject: RE: cron

From: Al Youngwerth <[email-masked]>
Date: Tue, 27 Aug 1996 08:41:49 -0600

That's funny, I haven't figured out how to get it to stop mailing me it results! The manpage (or some other documentation I found) says to add the line MAILTO=<user_to_mail_to> or if you prefer, leave it blank and it should never mail. I've found the MAILTO line doesn't seem to make any difference. If the cron job produces output to STDOUT (or maybe its STDERR), I get a friendly reminder from cron. If the cron job produces no output, I don't get a message from cron.

If anyone really knows how to get cron to stop pestering me, let me know. 

Al Youngwerth
[email-masked]

----------
From: 	Miro Torrielli[SMTP:[email-masked]]
Sent: 	Tuesday, August 27, 1996 5:53 AM
To: 	[email-masked]
Subject: 	cron

I would be grateful if anyone can tell me how to get cron to
mail me its results daily. Thanx... :-)

---

From: Rob Browning <[email-masked]>
Date: 27 Aug 1996 11:37:28 -0500

Al Youngwerth <[email-masked]> writes:

> If anyone really knows how to get cron to stop pestering me, let me =
> know.=20

If the command has output, you will get the results mailed to you.  I
don't know of any way to stop that, but it's easy to arrange for the
command to avoid sending results.

Just make your command

cmd > /dev/null

or the more thorough

cmd > /dev/null 2>&1

which redirects stderr and stdout.

See "man bash" for more details.

--
Rob

---

From: [email-masked] (Bernd Eckenfels)
Date: Tue, 27 Aug 1996 20:09:46 +0200 (MET DST)

Hi,

> If anyone really knows how to get cron to stop pestering me, let me =

simply avoid that cron jobs produce output if the operate normally. Then you
will only get mails if something went wrong. Thats how it is suppoed to
work.

Greetings
Bernd