Subject: A few problems

From: Miro Torrielli <[email-masked]>
Date: Sat, 24 Aug 1996 23:21:57 +0200

I've been having a few problems lately:

1. After I recompiled the kernel, NAS loads fine at boot,
but auplay et all tell me that they can't connect to audio server.
Can anybody help??

2. I can't get diald to work. Pppd works fine, but diald disconnects
from my ISP as soon as I get connected. I have a feeling that
this has to do with the diald options file, and possibly the pppd
options file. Any tips?

3. Lacking knowledge of the XPM format, I need to know how to
make transparent pixmap backgrounds (for icons). I can't get xpaint
or pixmap to do this. Anyone know how??

Thanx for your time...:-)

---

From: Philippe Troin <[email-masked]>
Date: Sat, 24 Aug 1996 17:06:11 -0700

> this has to do with the diald options file, and possibly the pppd

Have you got the standard configuration ?
What does the logs (/var/log/messages & /var/log/daemon.log) say ?

> or pixmap to do this. Anyone know how??

Edit the file by hand, and change the background color specification from
its color code (#07070808AAAA for example) or name to `none'.
I don't know about a graphics program which can do it automatically yet...

Phil.

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Sat, 24 Aug 1996 20:35:27 -0400

Hi Miro --

(I'm not sure of these answers, but see if any of them help.)

> but auplay et all tell me that they can't connect to audio server.

I think that the error here may be that the kernel provided with 2.0.6 uses
a non-standard IRQ (namely, 7) for sound boards.  If you recompile a kernel,
and use IRQ=5 for your sound board (which is what most of them really use),
then you might get NAS to work.  Alternatively, some people have reported
that they get sound to work if they use kernel 2.0.0, but I don't know
exactly what that works for them.

> this has to do with the diald options file, and possibly the pppd

Mark Warburton solved his problems by "turning off all the 
modem-related options in the ppp config file".

^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Joonwoo Nam reported that adding 'connect-timeout' as an option 
solved his problem.  He gave this /usr/sbin/ppp-up script:
  /usr/sbin/ppp-up
  ----------------
  #!/bin/sh

  /bin/setserial /dev/cua1 spd_hi
  /usr/sbin/diald /dev/cua1 -m ppp local 127.0.0.3 \
  remote 127.0.0.2 \
  defaultroute modem crtscts dynamic connect-timeout 180 \
  connect '/usr/sbin/chat -f /etc/ppp/chat-ppp' \
  fifo /var/adm/diald.ctl

  Adding the following entry at the end of /etc/diald.conf
  also helped me out making the line keep up contiguously:

  restrict * * * * *
  up

^^^^^^^^^^^^^^^^^^^^^^^^^^^^

> or pixmap to do this. Anyone know how??

(Perhaps klutsy, but practical answer:)
Convert the xpm file to a .gif (perhaps using xv from the non-free 
  distribution).
Then use giftrans to make the gif file transparent.

HTH,
Susan Kleinmann