Subject: Re: mailing list

From: Lars Wirzenius <[email-masked]>
Date: Thu, 29 Aug 1996 10:22:41 +0300

I hope this to be my last contribution to this thread, so I'll
try to make it thorough. Sorry about the length.

I will use "must" to indicate that unless we do it that
way, there is going to be problems and the Debian project
will suffer. (No film at 11.) I'm willing to stake whatever
reputation I have on the Internet on this. These opinions aren't
mere whims. I base them on a few thousand hours spent using a
news reader in the past seven years.

* [email-masked] must not be replaced with a news group

	News articles move much slower than e-mail messages. This
	is because news is not a critical resource to most people,
	so admins don't want to spend lots of money to make it 
	move fast. Part of the problem is that the volume of news
	is huge (our university news server sometimes got more than
	two gigabytes per day, until they cut binaries groups).
	
	Therefore debian-user must stay.
	
* [email-masked] must not be linked with comp.os.linux.debian
  (or other comp.* group)

	It is easy to post (or cross-post) messages to newsgroups
	you don't read. It happens all the time. Some people do it
	to start flame wars (trolling).
	
	It is also easy to start reading a newsgroup. Many more
	people read a newsgroup than an average mailing list. If
	there is a flame war, there will be many participants
	and it will go on and on and on. It is almost impossible
	to kill a flame war on a newsgroup. Because news moves
	slowly, if people in one part of the world cease fire,
	a couple of days later some other people somewhere else 
	will get the first articles and be angry and start it all
	over again. Cross-posts make flame wars worse.
	
	Flame wars on mailing lists are easy to control.
	Subscribing to a list takes much more effort, which
	reduces the number of participants. People who won't
	stop can be thrown out of the list.
	
	If debian-user and col.debian are linked (with messages in
	one appearing in the other), the usefulness of the list will
	vanish. We will see flame war after flame war (not to mention
	spam after spam -- the spam can't be cancelled from the
	mailing list).
	
	The existing linux.debian.user group is OK (see below), but
	a mainstream group is not.
	
* linux.* must not be moved to comp.os.linux.*

	Same reasons apply as to mailing lists. linux.* aren't on
	everyone's news server, so fewer people can easily access
	them, but anyway who wants to can.
	
* comp.os.linux.debian (and col.red-hat and col.slackware) can be 
  created if they are independent of the respective mailing lists
  
	Personally, I don't think distribution-specific news
	groups will do much good, but I don't mind if they
	are created. If it comes to voting, I will vote against
	them, but I expect to be out-voted.
	
	If you want the mainstream groups, read and follow the
	instructions in news.announce.newgroups. Don't expect
	anyone else to do it. (This is the standard answer
	to almost all proposals for new groups. It tends to
	silence almost all people. :)
	
* If you think reading news is easier than reading mail, get 
  better software.
  
  	There's no inherent reason why news readers should be
	better at grouping related messages together than mail
	readers. If your mail reader isn't capable of doing it,
	get a better one. Or start reading thew linux.* groups.
	
	If your ISP (or company, or whatever) doesn't have any
	better programs installed, well, that's unfortunate.
	I know one person who still reads all his mail with
	/bin/mail and who refuses to learn procmail. He
	doesn't have a right to demand list-specific keywords
	in subjects so that he can tell different lists apart
	from the subject alone. Mail filters exist because they
	are necessary. If you can't use them, you lose.

-- 
Please read <http://www.iki.fi/liw/mail-to-lasu.html> before mailing me.
Please don't Cc: me when replying to my message on a mailing list.

---

From: David Gaudine <[email-masked]>
Date: Thu, 29 Aug 1996 12:54:34 -0400 (EDT)

On Thu, 29 Aug 1996, Lars Wirzenius wrote:

> 	people read a newsgroup than an average mailing list.
[snip]
> 	reduces the number of participants.
[snip]
> 	linux.* aren't on

There seems to be a pattern here.  What about people that hear about Linux
for the first time?  They're likely to head directly to comp.* and read
the "Slackware vs. Red Hat" threads.  I installed Slackware long before I
knew there was a Debian mailing list or newsgroup, and I assume that
a lot of Debian users are "converts" for the same reason.  This might cut
down on the number of silly questions, but it probably also cuts down on
the number of Debian users.  I would think that a prominent debian
newsgroup would get a lot more attention.  I guess it depends on whether
you want debian to eventually become the major system, or used mainly by
people with prior Linux experience.  (Am I correct in assuming that most
people start with Slackware or Red Hat because they're prominent?)

A few months ago, someone asked me to investigate debian.  I looked in
comp.os.linux.*, and came up empty because the word "debian" did not appear
once in the 7 days of articles that my server still had.  I searched for
any newsgroup with the word "debian" in it and there were none.
Eventually I found something, probably by doing a web search.  Keeping
Linux discussion on a mailing list and a "hidden" newsgroup certainly
doesn't make it easy for newcomers looking for Debian info.  And they have
no reason to try very hard, with people screaming "Slackware!" at them.

> * If you think reading news is easier than reading mail, get 

Some people don't have much control over their software, and some
people don't have sufficient disk quotas to use mailing lists.  If I were
a student here I certainly wouldn't be on any mailing lists.  (It's bad
enough having to fit a web page into 500K!)