Subject: Re: Can't remove sendmail with dselect/dpkg

From: Miro Torrielli <[email-masked]>
Date: Wed, 21 Aug 1996 13:06:22 +0200

John Houwen wrote:
> 
> Miro,
> 
> I appreciate your comments, but that is part of the problem ... smail
> *won't* install unless sendmail is removed!  At the same time, dpkg
> refuses to remove sendmail unless smail is installed ... like Catch-22 :)
> 
> Sorry about the mis-understanding ...
> 
> Thanks
> 
> On Sun, 18 Aug 1996, Miro Torrielli wrote:
> 
> > John Houwen wrote:
> > >
> < ascii deleted>
> > > Can anyone help with this?
> > >
> > >
> >
> > Sounds strange. Anyway, the simplest way would probably be to
> > install smail, and then remove sendmail :-)
> >
> >

Allright, I get it now. What you gotta do to remove sendmail is
edit the "status" file in /var/lib/dpkg. This is the file that
dpkg relies upon to perform its main functions. What you have to do
is search the file for the sendmail section, and remove smail from
the "depends upon" line (or possibly some other line).

Good luck...:-)

---

From: Dale Scheetz <[email-masked]>
Date: Wed, 21 Aug 1996 15:16:45 -0400 (EDT)

> the "depends upon" line (or possibly some other line).

Don't do this. First, it is dangerous to edit the dpkg database. Second,
it is not necessary. Check out 'dpkg --force-help' for the full list of
force options. What you need to do is either:

dpkg -r --force-depends sendmail
dpkg -i /path-to-package/smail*.deb

or

dpkg -i --force-conflicts /path-to-package/smail*.deb
dpkg -r sendmail

Either of the above examples should allow you to replace
dependant/conflicting packages with some other package.

Luck,

Dwarf

------------                                          --------------

aka   Dale Scheetz                   Phone:   1 (904) 877-0257
      Flexible Software              Fax:     NONE 
      Black Creek Critters           e-mail:  [email-masked]

------------ If you don't see what you want, just ask --------------