Subject: Duplicating Debian Installations?

From: [email-masked] (Tres Hofmeister)
Date: Mon, 19 Aug 1996 19:10:41 -0600 (MDT)

Can someone point me towards info. on how one can duplicate the
packages installed on one Debian system on another?  Going through
dselect by hand seems just a bit too tedious for multiple
installations...  Thanks.

-- 
Tres Hofmeister                       Research Applications Program
[email-masked]         National Center for Atmospheric Research

---

From: Ioannis Tambouras <[email-masked]>
Date: Tue, 20 Aug 1996 00:43:38 -0400 (EDT)

$ umask 000              # not sure if it is nessesary
 $ (cd /; tar -clpf - .) | ( cd /<destination> ; tar -xpkf - )
 $ umask 022

 This is from the Tips-HOWTO, there is one other method in that doc but
 never used it. 
 With the method shown above you might get some complains about not being
 able to copy some /dev  devices (or was it just some named pipes). 
 I always ignore those errors, and everything works just fine.

 Of course...
 Once you transfer, remember about: rdev, /etc/fstab, etc.. 

Ioannis Tambouras
[email-masked]
PGP 512/D042DD45, West Palm Beach, Florida

---

From: [email-masked] (Heiko Schlittermann)
Date: Tue, 20 Aug 1996 08:18:39 +0200 (MET DST)

Tres Hofmeister wrote:
: 
: 	Can someone point me towards info. on how one can duplicate the
: packages installed on one Debian system on another?  Going through
: dselect by hand seems just a bit too tedious for multiple
: installations...  Thanks.
: 

Just install the base system from the first 3 floppies and
copy the /var/lib/dpkg/status file from the `master' system, mount
the distribution somewhere on the `slave', cd to the distribution
toplevel and run `dpkg -iGROEB'.  Never tried this, so
someone else?

    Heiko
--
email : [email-masked] [email-masked] [email-masked]
pgp   : A1 7D F6 7B 69 73 48 35  E1 DE 21 A7 A8 9A 77 92 
finger: [email-masked]         [email-masked]

---

From: Dale Scheetz <[email-masked]>
Date: Tue, 20 Aug 1996 09:37:24 -0400 (EDT)

> dselect by hand seems just a bit too tedious for multiple
Check out the UpGrades script in the upgrades/ directory. The base_list is
a good example of how to build the list file. Check with me if you need
more pointers.

Luck,
 
Dwarf

------------                                          --------------

aka   Dale Scheetz                   Phone:   1 (904) 877-0257
      Flexible Software              Fax:     NONE 
      Black Creek Critters           e-mail:  [email-masked]

------------ If you don't see what you want, just ask --------------