Subject: output of shutdown -h now

From: Justin Ennis <[email-masked]>
Date: Tue, 20 Aug 1996 09:35:50 -0700 (PDT)

I am reluctant to bring this up again, since I saw it just a few
months ago on this list, and didn't pay attention at the time.  So,
at the risk of rehashing this problem (if that is what it is), I am
submitting it again since I am now having the same difficulty myself.

I am using the original Debian 1.1 release (kernel 2.0.0), and when
I issue a "shutdown -h now" command, I get the following:

System halted
general protection: 0000
CPU: 0
EIP: 0010: [<00173257>]
EFLAGS: 00010046
eax: 00005307  ebx: 00000001  ecx: bfff0003  edx: 00000000
esi: bfffff0c  edi: 08000e4a  ebp: bfff0003  esp: 005a5f80
ds: 0000  es: 0000  fs: 0000  gs: 0000  ss: 0018
Process halt (pid: 220, process nr: 6, stackpage=005a5000)
Stack:  00000246 0000002b 0011002b 00000018 00710018 00714810 bfffff0c 08000e4a
        bffffdc0 0011231e 00000003 ffffffff 00000009 001cc40a 0010a482 fee1dead
        28121969 cdef0123 bfffff0c 08000e4a bffffdc0 ffffffda 0803002b 0010002b
Call Trace:  [<0011002b>] [<0011231e>] [<0010a482>]
Code: 2e ff 1d 2c b8 20 00 0f 92 c0 9d 0f a9 0f 91 07 1f 89 c5 84

I'd like to know if this is normal, or a symptom of a needed kernel upgrade,
or something else entirely.  I hate to post this again, seeing that you have
all probably solved this and moved on.  But I would greatly appreciate any
help that you may possibly be able to give.

Justin Ennis

---

From: [email-masked] (Jeppe Sigbrandt)
Date: Wed, 21 Aug 1996 03:00:04 +0100 (BST)

> months ago on this list, and didn't pay attention at the time.  So,

In that case you might want to try the archives.
You will get a much speedier response from there, I'm sure :).
Sorry can't answer your question.

Regards,
jay>

---

From: "Richard G. Roberto" <[email-masked]>
Date: Wed, 21 Aug 1996 08:12:32 -0400 (EDT)

> help that you may possibly be able to give.

I get this periodically for no reason.  I've been a little
busy, and haven't had time to pay attention to it, but It is
distressing.  I'm using the upstream 2.0.12 kernel sources
with the kernel-package package.  I really just assumed that
the 2.0.x kernels need some work in the area of exception
handling.  They seem to hickup a little too easily.

Richard G. Roberto
[email-masked]
201-739-2886 - whippany, nj

--
*******************************************************************************
Bear Stearns is not responsible for any recommendation, solicitation, offer or
agreement or any information about any transaction, customer account or account
activity contained in this communication.
*******************************************************************************

---

From: "Brian C. White" <[email-masked]>
Date: Wed, 21 Aug 1996 15:59:27 -0400

> Code: 2e ff 1d 2c b8 20 00 0f 92 c0 9d 0f a9 0f 91 07 1f 89 c5 84

I'm running 2.02 and got this problem during bootup today when I tried
to install another 16MB of Ram in my system.  Dos/Windows runs fine
with it, but Linux dies immediately.

In other words, it could very well be a hardware problem/idosyncracy(sp?).

(Guess I'm stuck with only 32MB ram.  Oh well.  <sigh>

                                        Brian
                               ( [email-masked] )

-------------------------------------------------------------------------------
    In theory, theory and practice are the same.  In practice, they're not.