Subject: CHAP authentication

From: [email-masked] (Steven Tonnesen)
Date: Tue, 13 Aug 96 06:53 PDT

My ISP just changed from login authentication to CHAP authentication.  Can someone
send me an example of what a chap-secrets file should look like?

This is an excerpt from the pppd logs:

Aug 12 06:09:22 haze pppd[393]: pppd 2.2.0 started by root, uid 0
Aug 12 06:09:22 haze pppd[393]: Using interface ppp0
Aug 12 06:09:22 haze pppd[393]: Connect: ppp0 <--> /dev/ttyS2
Aug 12 06:09:22 haze pppd[393]: sent [LCP ConfReq id=0x1 <mru 1500> <magic 0x39f
354e7> <pcomp> <accomp>]
Aug 12 06:09:25 haze pppd[393]: sent [LCP ConfReq id=0x1 <mru 1500> <magic 0x39f
354e7> <pcomp> <accomp>]
Aug 12 06:09:26 haze pppd[393]: rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth ch
ap msoft> <magic 0x7b83> <pcomp> <accomp>]
Aug 12 06:09:26 haze pppd[393]: sent [LCP ConfRej id=0x0 <auth chap msoft>]
Aug 12 06:09:26 haze pppd[393]: rcvd [LCP ConfAck id=0x1 <mru 1500> <magic 0x39f
354e7> <pcomp> <accomp>]
Aug 12 06:09:26 haze pppd[393]: rcvd [LCP TermReq id=0x1 00 00 02 dc]
Aug 12 06:09:26 haze pppd[393]: sent [LCP TermAck id=0x1]
Aug 12 06:09:28 haze pppd[393]: sent [LCP ConfReq id=0x1 <mru 1500> <magic 0x39f
354e7> <pcomp> <accomp>]
Aug 12 06:09:29 haze pppd[393]: Hangup (SIGHUP)
Aug 12 06:09:29 haze pppd[393]: Modem hangup
Aug 12 06:09:29 haze pppd[393]: Connection terminated.
Aug 12 06:09:29 haze pppd[393]: Exit.

Thanks for any help.

Steve.

---

From: Rick Macdonald <[email-masked]>
Date: Wed, 14 Aug 1996 10:49:25 -0600

((((I tried to send this to Steve directly but it bounced))))

> send me an example of what a chap-secrets file should look like?

I just set up PAP for my wife's ISP. It may be very similar. I figured
it out from the pppd man page.

Given:

login id = mylogin
login password = mypsw
isp name = myisp

I put on the pppd command line:

user mylogin remotename myisp

and in pap-secrets, one line:

mylogin myisp mypsw

NOTE: this is all from memory, so please check the man page. I may have
the secrets values out of order. Hopefully, the chap setup is very
similar to the PAP setup.

-- 
...RickM...