Subject: RE: cdplay & sound.o autoloading

From: Casper BodenCummins <[email-masked]>
Date: Fri, 16 Aug 1996 13:06:21 +0100

Someone (I know you will) correct me if I'm wrong, but doesn't the CD
simply send audio directly to the sound card, rather than via a device
file?

This would not require a sound module, or kernel support for sound, to
be present. It would also suggest your problem lies in the card's
initialisation.

Casper Boden-Cummins.

>----------
>From: 	Derek Lee[SMTP:[email-masked]]
>Sent: 	16 August 1996 01:36
>To: 	[email-masked]
>Cc: 	The recipient's address is unknown.
>Subject: 	cdplay & sound.o autoloading
>
>I have been seeing something strange on my system. The autoloading of
>the sound module works most of the time. The problem is with the CD
>playing programs (cdplay from cdtool 1.0 or workman). They do not send
>a request the sound module to kerneld. But they work if the module has
>been loaded at some point in the past. In fact, they would continue to
>work even if the sound module has been removed from the kernel!
>
>--Derek Lee
>
>
>
>

---

From: [email-masked] (Gilbert Ramirez Jr.)
Date: Fri, 16 Aug 1996 09:16:36 -0500 (CDT)

>  be present. It would also suggest your problem lies in the card's

You are correct. That's what the little cable (with 4 wires, I believe) is
for. The audio data doesn't go through the CPU.

--gilbert
______________________________________________________________________
Gilbert Ramirez Jr.                     [email-masked]
University of Texas                     http://merece.uthscsa.edu/gram
Health Science Center at San Antonio    University Health System

---

From: [email-masked]
Date: Fri, 16 Aug 1996 11:09:13 -0400

> From [email-masked] Fri Aug 16 08:03:29 1996
> Resent-Date: 16 Aug 1996 12:03:29 -0000
> Resent-Cc: recipient.list.not.shown:;@lists.debian.org
> Old-Return-Path: <[email-masked]>
> From: Casper BodenCummins <[email-masked]>
> To: "[email-masked]'" <[email-masked]>
> Subject: RE: cdplay & sound.o autoloading
> Date: Fri, 16 Aug 1996 13:06:21 +0100
> X-Mailer:  Microsoft Exchange Server Internet Mail Connector Version 4.0.837.3
> Mime-Version: 1.0
> Content-Type: text/plain; charset="us-ascii"
> Content-Transfer-Encoding: 7bit
> Resent-From: [email-masked]
> X-Mailing-List: <[email-masked]> archive/latest/5006
> X-Loop: [email-masked]
> Resent-Sender: [email-masked]
>

Hi

I am coming to the same conclusion myself
So where is this initialisation done?

--Derek