Subject: Problems booting with new kernel...

From: [email-masked] (Rob Nielsen)
Date: Mon, 5 Aug 1996 14:58:10 -0500

I've built a kernel with the sources from 2.0.6, but I'm having problems
when I try to run it.  I get the error:

    VFS: Cannot open root device 03:02
    Kernel panic: VFS: Unable to mount root fs on 03:02

This is what I have in my .config file:

    #
    # Filesystems
    #
    # CONFIG_QUOTA is not set
    # CONFIG_LOCK_MANDATORY is not set
    CONFIG_MINIX_FS=y
    # CONFIG_EXT_FS is not set
    CONFIG_EXT2_FS=y
    # CONFIG_XIA_FS is not set
    CONFIG_FAT_FS=y
    CONFIG_MSDOS_FS=y
    CONFIG_VFAT_FS=m
    CONFIG_UMSDOS_FS=m
    CONFIG_PROC_FS=y
    CONFIG_NFS_FS=y
    # CONFIG_ROOT_NFS is not set
    # CONFIG_SMB_FS is not set
    # CONFIG_ISO9660_FS is not set
    # CONFIG_HPFS_FS is not set
    # CONFIG_SYSV_FS is not set
    # CONFIG_UFS_FS is not set
    
Any Ideas?

Thanks,

Rob
---
Rob Nielsen                   [email-masked]
ADC Telecommunications, Inc.  http://www.cs.ndsu.nodak.edu/alumni/rob_nielsen 
4900 West 78th Street, MS34   (612) 896-2706
Minneapolis, MN  55345        (612) 896-2959 - fax

---

From: [email-masked] (Bernd Eckenfels)
Date: Tue, 6 Aug 1996 01:56:49 +0200 (MET DST)

Hi,

>     VFS: Cannot open root device 03:02

your IDE driver is missing or can't find the disk. Is there any lines about
IDE disks on the screen?

Greetings
Bernd

---

From: Michael Karafotis <[email-masked]>
Date: Tue, 6 Aug 1996 08:25:21 -0500 (CDT)

Actually it looks like your root device isn't set up properly .. are you
using a boot disk .. if you are check out the rdev command it enables you
to set your root partition.  If it is not set correctly then you will get
the following error.

Michael