Subject: Re: printing and .profile problems

From: Kevin M Bealer <[email-masked]>
Date: Wed, 7 Aug 1996 23:08:53 -0400 (EDT)

On Wed, 7 Aug 1996, chris beamis wrote:

> 
> Leszek,
>   Sorry, I should have mentioned that it is the same .profile which I've
> always used successfully with Slackware releases. I was going from memory
> which is the only reason I got the quotes wrong. There is something else
> going on causing bash or something to ignore my .profile.
> 
> Thanks anyway.
> 
> Chris Beamis

Is it named .profile?  I have a .profile in /etc/ but in my home
directory I use ".bash_profile" and ".bash_rc".

[email-masked]/GNU__1.1___Linux__2.0.11___
"Love is a snowmobile racing across the tundra and then suddenly
it flips over, pinning you underneath.  At night, the ice
weasels come."
                -- Matt Groening

---

From: Mike Miller <[email-masked]>
Date: Wed, 7 Aug 1996 16:24:45 -0700 (MST)

Chris,
		I had the same problem with my profile.  My work around
was editing (creating?) the .bash_profile   file.  At least I think that's
it, I'm at school now.  It's just like .profile , but renamed to confuse
us !  Good luck.
		Mike.

On Wed, 7 Aug 1996, chris beamis wrote:

> >> 2. another problem, which I didn't have under Slackware, is using a .profile
> >> in the user's home area. I have just one line in it, "alias 'lo'=exit" which
> >> has always worked before but the lo commanded doesn't get recognized. I also
> >> tried renaming the file to .login but still no luck. Any ideas?
> 
> Leszek,

---

From: Ed Donovan <[email-masked]>
Date: 07 Aug 1996 20:42:19 -0400

Hi Chris - 

Is there an existing .bash_profile in that directory?  I believe Debian
by default gives you one.  If so, .profile will not be read:  

          Login shells:
            On login (subject to the -noprofile option):
                  if /etc/profile exists, source it.

                  if ~/.bash_profile exists, source it,
                    else if ~/.bash_login exists, source it,
                      else if ~/.profile exists, source it.

                                                    (from the man page)
So you could rework it one way or another to get your command sourced.
(You can also instead just put it in .bashrc, which practically always
gets read by interactive shells.  But why leave this .profile ambiguity
hanging anyway? :-)

The other possibility is less likely: that you are somehow running a
sub-shell, not a login shell.  If you were using an xterm this might be
the case.  But any login from a console prompt should be a login shell,
and read the startup files as specified above.  Specifying login
behavior, or the .bashrc solution, would work if it was a sub.  

Hth,

-- 

Ed Donovan			[email-masked]

---

From: [email-masked] (chris beamis)
Date: Wed, 07 Aug 1996 08:09:05 -0700

At 03:13 PM 8/7/96 +0200, [email-masked] wrote:
>On Tue, 6 Aug 1996, chris beamis wrote:
>
>> 
>This line should look like:
>
>alias lo='exit'
>
>but NOT like:
>
>alias 'lo'=exit
>
>Did it work?!?!?!?!?
>
>
>Leszek Gerwatowski
>TG S.A
>Warsaw, Poland
>
>

Leszek,

Thanks anyway.

Chris Beamis

---

From: Michael Karafotis <[email-masked]>
Date: Wed, 7 Aug 1996 18:56:17 -0500 (CDT)

Just a note .. if you have a ~/.bash_profile file than bash will ignore your
.profile file.

Don't forget everyone here is making an assumption you are using the bash
shell .. if you are using a csh derivative than the .profile will be
ignored and those same commands will not work.

The csh version of an alias is 
	alias lo 'logout'

Good luck,
Michael