Subject: Nearly perfect!

From: Erik van der Meulen <[email-masked]>
Date: Thu, 08 Aug 1996 17:19:42 +0200

It seems that I have nearly conquered my uucp and sendmail installation.
Thanks to the contribution of this list, no doubt.
Receiving mail works like a charm. Outbound mail gets queued as one might
expect. Uucico does its jobs. Log files show my mail has left my machine. It
just does not arrive at its destination! As I said, nearly perfect.
The only difference I notice between my new setup and my old
Slackware/HDB/sendmail configuration is that uustat -a gives:

        Executing rmail ncm.nl!eme      with the new box

        Executing rmail [email-masked]      with the old configuration

As far as I know both should be valid. I really have no clue as to what goes
on, I do not even get some sort of bounce (after eight hours that is).
I was hoping anyone out here might have an idea as to what might still be
wrong. My sendmail.mc file is listed below, just in case.

Thanks all for any comment!

Erik van der Meulen
[email-masked]
[email-masked]

--------------------------------------------------
#
# This file is used to configure sendmail for use with Debian systems.
#

divert(0)
VERSIONID(`@(#)sendmail.mc      8.7 (Linux) 3/5/96')
OSTYPE(debian)dnl
FEATURE(masquerade_envelope)dnl
FEATURE(use_cw_file)dnl
FEATURE(use_ct_file)dnl
FEATURE(redirect)dnl
FEATURE(nodns)dnl
define(`confTO_QUEUEWARN', `1d')dnl
MAILER(local)dnl
MAILER(smtp)dnl
Cwavondel.xs4all.nl
MASQUERADE_AS(avondel.xs4all.nl)dnl

## Custom configurations below (will be preserved)

MAILER(uucp)dnl
define(`SMART_HOST', uucp:xs4all)
--------------------------------------------------

My setup:

        ISP is called:      xs4all.nl
        UUCP node:          avondel

---

From: "Randall Shutt" <[email-masked]>
Date: Thu, 8 Aug 1996 19:16:19 -0400

About that uucp SMART_HOST line again, try using the uucp-dom mailer
rather than the std. uucp mailer.  It uses the smtp mailer rules for rewriting
envelope addresses.  Aside from that, youd have to show uucico logs for both
sides to make sure the mail was still addressed correctly on the server side.

-- 
=======================================================================
= Randall Shutt                                                       =
= RaveNet Systems, Inc                                                =
=======================================================================