Subject: xconsole error

From: Ken Gaugler <[email-masked]>
Date: Sat, 24 Aug 1996 09:55:33 -0700

I am having difficulty getting the xconsole to work running in
fvwm 9or any window manager).  I use a .xsession file in my home
directory.  Here is that file:

----------------- begin .xsession file -------------
#!/bin/bash

#Add to path
PATH=$PATH:/usr/local/lib/X11:/usr/contrib/mh/bin:/usr/contrib/bin:/usr/X11R6/bin
export PATH

DISPLAY=:0.0
export DISPLAY

#Merge in user resources:
#xrdb -merge $HOME/.Xresources

#start Applications
xterm -g 95x40-40+200 -sb &
xterm -g 95x40-700+10 -sb &
xconsole -exitOnFail -g 490x200-20-50 &
xclock &
xcal &
#xmh   -g 750x545+5+400 &
#exmh &

#start fishtank
#xfishtank &

#start window manager
exec fvwm2 &

#start controlling proc
/usr/X11R6/bin/xterm -iconify -rv -title root -name "root" -g +5+1 
-------------------------- end .xsession file -------------

At first I did not have the "exitOnFail" in the xconsole line,
and I would get an xconsole window that said
  "Couldn't open console".
With the "exitOnFail", I just get no window at all.

I created a test user account, and didn't put a .xsession file
in its home directory.  The xconsole opens and works fine.

What is it about this xsession file that is trashing my xconsole?

Any ideas greatly appreciated!

-- 
Ken Gaugler  
email: [email-masked]  URL: users.aimnet.com/~keng
"The life of a Repo Man is always INTENSE..."

---

From: "Susan G. Kleinmann" <[email-masked]>
Date: Sun, 25 Aug 1996 06:40:56 -0400

Hi Ken --

You wrote:
> fvwm (or any window manager).  I use a .xsession file in my home
[snip]
> -------------------------- end .xsession file -------------
[snip]
> With the "exitOnFail", I just get no window at all.
Your /dev/xconsole should look like this:
prw-r--r--   1 root     root            0 Aug 25 06:37 /dev/xconsole|

If not, execute:
mknod -m 644 /dev/xconsole p

Be sure that the xconsole line is uncommented in /etc/syslog.conf:
auth.*;daemon.*;mail.*;news.crit;news.err;news.notice;*.=debug;*.=info;\
*.=notice;*.=warn;cron.none      |/dev/xconsole

I start xconsole with this:
xconsole -file /dev/xconsole

If you try bringing up xconsole and see nothing, then it's possible that
you've already been logging messages for a while and the pipe filled up, so
syslog quit sending messages to it.  To start over again, issue this 
command:
kill -SIGHUP `cat /var/run/syslog.pid`

HTH,
Susan Kleinmann