Subject: Netscape and XKeysymDB

From: Ken Gaugler <[email-masked]>
Date: Tue, 13 Aug 1996 07:49:18 -0700

I am getting lots of messages about the key symbols
not being right.  I remember from BSDI that you had
to have the nls directory set up in a special place.
Tried to hack this but still not getting the desired
result (i.e. no more messages about missing keysyms).

The docs say that a suitable XKeysymDB is included
in the package, though I have my doubts.  Is there
some manual intervention needed here?

Thanks!

---

From: [email-masked]
Date: Tue, 13 Aug 96 16:39 EDT

Ken Gaugler writes:
  Ken>  I am getting lots of messages about the key symbols not being right.
  Ken> I remember from BSDI that you had to have the nls directory set up in
  Ken> a special place.  Tried to hack this but still not getting the desired
  Ken> result (i.e. no more messages about missing keysyms).

There are several ways out:
 
 - read the README that comes with netscape :-)

 - install Debian's motifnls package, it creates the required nls directory

 - use Debian's "netscape" installer package

and there are still more possibilities. I simply put netscape's binary into
/usr/local/lib/netscape, along with the moz3_0.zip and the XKeysymDB file,
and then use this script which is saved as /usr/local/bin/netscape

#!/bin/sh
XNLSPATH=/usr/lib/X11/nls/ \
XKEYSYMDB=/usr/local/lib/netscape/XKeysymDB \
exec /usr/local/lib/netscape/netscape "$@"     

--
Dirk Eddelb"uttel                             http://qed.econ.queensu.ca/~edd

---

From: "Richard G. Roberto" <[email-masked]>
Date: Wed, 14 Aug 1996 08:39:57 -0400 (EDT)

> some manual intervention needed here?

The following environment variables are useable:

XKEYSYMDB
XNLSPATH

Where XKEYSYMDB points to the XKeysymDB file inthe Netscape
distribution and XNLSPATH is a colon separated list of
possible locations for the nls directory.  I'm not sure if
it wants the path to the parent directory (i.e.
/usr/local/Netscape) or the actual nls directory (i.e.
/usr/local/Netscape/nls) so you could just include both.  I
have a script to start netscape that (re)sets these
variables and then exec's netscape.  I'm using Netscape2.0.2
precompiled ELF binaries. 

I hope that helps.  By the way, has anybody run into a
problem in 16 bit mode where netscape hangs the X session?
It's happening to me, and I think I remember somebody else
having that problem too.  Any fixes?  Probably not ...

Richard G. Roberto
[email-masked]
201-739-2886 - whippany, nj

--
*******************************************************************************
Bear Stearns is not responsible for any recommendation, solicitation, offer or
agreement or any information about any transaction, customer account or account
activity contained in this communication.
*******************************************************************************

---

From: "Brian C. White" <[email-masked]>
Date: Wed, 14 Aug 1996 12:12:24 -0400

> some manual intervention needed here?

Use the "netscape" package from the distribution.  It takes
care of all this.

                                        Brian
                               ( [email-masked] )

-------------------------------------------------------------------------------
    In theory, theory and practice are the same.  In practice, they're not.