Subject: "man" crashes

From: Hamish Moffatt <[email-masked]>
Date: Sat, 24 Aug 1996 14:47:21 +1000 (EST)

When I try to view a manual page that's located in /usr/local/man,
man says it's updating a local index, then gives a segmentation fault.
Any ideas on how to fix this?

thanks
hamish

---

From: [email-masked] (Christoph Lameter)
Date: 23 Aug 1996 22:37:43 -0700

Same problem here.
Hamish Moffatt ([email-masked]) wrote:
: 
: When I try to view a manual page that's located in /usr/local/man,
: man says it's updating a local index, then gives a segmentation fault.
: Any ideas on how to fix this?
: 
: 
: thanks
: hamish
:

---

From: Dale Scheetz <[email-masked]>
Date: Sat, 24 Aug 1996 12:44:55 -0400 (EDT)

> Any ideas on how to fix this?
Need more information to be of any help.
What version of man are you using? What shell and it's version? 
Such problems in the past have been caused by a corupted index file. Try:
mandb /usr/local/man and see if that helps.

Luck,

Dwarf

------------                                          --------------

aka   Dale Scheetz                   Phone:   1 (904) 877-0257
      Flexible Software              Fax:     NONE 
      Black Creek Critters           e-mail:  [email-masked]

------------ If you don't see what you want, just ask --------------

---

From: [email-masked] (Christoph Lameter)
Date: 24 Aug 1996 11:19:28 -0700

Dale Scheetz ([email-masked]) wrote:
: On Sat, 24 Aug 1996, Hamish Moffatt wrote:
: 
: > 
: > When I try to view a manual page that's located in /usr/local/man,
: > man says it's updating a local index, then gives a segmentation fault.
: > Any ideas on how to fix this?
: > 
: Need more information to be of any help.
: What version of man are you using? What shell and it's version? 
: Such problems in the past have been caused by a corupted index file. Try:
: mandb /usr/local/man and see if that helps.
waterf:/usr/local# mandb /usr/local/man
Processing manual pages under /usr/local/man...
Checking for stray cats under /usr/local/man...
Checking for stray cats under /var/catman/local...
0 man subdirectories contained newer manual pages.
0 manual pages and 0 stray cats were added.
waterf:/usr/local# man -kr xx
Segmentation fault (core dumped)
waterf:/usr/local# dpkg -s man
Package: man
Status: install ok installed
Priority: important
Section: doc
Maintainer: Alvar Bray <[email-masked]>
Version: 2.3.10-11
Depends: groff, libc5, libgdbm1
Description: Display the on-line manual.
 This packages provides the man command, this utility is the primary
 way of examining the on-line help files (manual pages). Other utilities
 provided include the whatis and apropos commands for searching the
 manual page database; the manpath utility for determining the manual
 page search path and the maintenance utilities mandb, catman and
 zsoelim. This packages uses the groff suit of programs to format and
 display the manual pages.

waterf:/usr/local# 

Hope that is enough....

---

From: Christoph Lameter <[email-masked]>
Date: Sat, 24 Aug 1996 19:34:31 -0700 (PDT)

On Sat, 24 Aug 1996, Dale Scheetz wrote:

dwarf>I've got the same version. I get:
dwarf>
dwarf>$ man -kr xx
dwarf>xxgdb (1x)           - X window system interface to the gdb debugger.
dwarf>
dwarf>However, most of my man pages are in /usr/man not /usr/local/man. Try
dwarf>running mandb on /usr/man and see if that helps. 
dwarf>You might also try checking the MD5SUM on the package file you installed
dwarf>from. If it does not check out, then you got a corrupt package file. Try
dwarf>getting a new copy and re-install, if this is the case.
dwarf>Just an asside...is your shell bash?
Yes.

Here is the output from what you suggested:
mandb: warning: /usr/man/man1/dpkg-source.1 is a dangling symlink
mandb: can't open /usr/man/man1/dpkg-parsechangelog.1: No such file or
directory
mandb: warning: /usr/man/man1/dpkg-parsechangelog.1: bad symlink or ROFF
`.so' request
mandb: warning: /usr/man/man1/dpkg-source.1 is a dangling symlink
mandb: can't open /usr/man/man1/dpkg-genchanges.1: No such file or
directory
mandb: warning: /usr/man/man1/dpkg-genchanges.1: bad symlink or ROFF `.so'
request
mandb: warning: /usr/man/man1/dpkg-source.1 is a dangling symlink
mandb: can't open /usr/man/man1/dpkg-buildpackage.1: No such file or
directory
mandb: warning: /usr/man/man1/dpkg-buildpackage.1: bad symlink or ROFF
`.so' request
mandb: warning: /usr/man/man1/dpkg-source.1 is a dangling symlink
mandb: can't open /usr/man/man1/dpkg-distaddfile.1: No such file or
directory
mandb: warning: /usr/man/man1/dpkg-distaddfile.1: bad symlink or ROFF
`.so' request
Checking for stray cats under /usr/man...
Checking for stray cats under /var/catman...
3 man subdirectories contained newer manual pages.
80 manual pages and 0 stray cats were added.
waterf:/home/clameter# man -kr xx
Segmentation fault (core dumped)
waterf:/home/clameter# 

Seems that the man package cannot cope with some screwups of the dpkg
updates.

{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}
{}    Snail Mail:   FTS Box 466, 135 N.Oakland Ave, Pasadena, CA 91182        {}
{}    FISH Internet System Administrator at Fuller Theological Seminary       {}
{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}{}
PGP Public Key  =  FB 9B 31 21 04 1E 3A 33  C7 62 2F C0 CD 81 CA B5

---

From: Dale Scheetz <[email-masked]>
Date: Sat, 24 Aug 1996 22:32:16 -0400 (EDT)

> Maintainer: Alvar Bray <[email-masked]>

I've got the same version. I get:

$ man -kr xx
xxgdb (1x)           - X window system interface to the gdb debugger.

However, most of my man pages are in /usr/man not /usr/local/man. Try
running mandb on /usr/man and see if that helps. 
You might also try checking the MD5SUM on the package file you installed
from. If it does not check out, then you got a corrupt package file. Try
getting a new copy and re-install, if this is the case.
Just an asside...is your shell bash?

Luck,

Dwarf

------------ If you don't see what you want, just ask --------------

---

From: Dale Scheetz <[email-masked]>
Date: Sat, 24 Aug 1996 23:03:53 -0400 (EDT)

> Seems that the man package cannot cope with some screwups of the dpkg
Sounds like you upgraded to an experimental version of dpkg. Which version
do you have? I'm running 1.3.6 with none of these problems.

Luck,

Dwarf

------------ If you don't see what you want, just ask --------------

---

From: Christoph Lameter <[email-masked]>
Date: Sat, 24 Aug 1996 20:14:15 -0700 (PDT)

dwarf>On Sat, 24 Aug 1996, Christoph Lameter wrote:
dwarf>
dwarf>> Seems that the man package cannot cope with some screwups of the dpkg
dwarf>> updates.
dwarf>> 
dwarf>Sounds like you upgraded to an experimental version of dpkg. Which version
dwarf>do you have? I'm running 1.3.6 with none of these problems.
1.3.9 as of today.

Any way to fix those problems?

---

From: Kevin M Bealer <[email-masked]>
Date: Mon, 26 Aug 1996 00:49:21 -0400 (EDT)

> Any way to fix those problems?

I would suggest removing any of the files that it lists as
problems, then remove and reinstall the manpages package, and
possibly the actual "man" utility as well.

[email-masked]/GNU__1.1___Linux__2.0.14___
"Don't worry about people stealing your ideas.  If your ideas
are any good, you'll have to ram them down people's throats."
		-- Howard Aiken

---

From: Ed Donovan <[email-masked]>
Date: 26 Aug 1996 02:00:55 -0400

> Any way to fix those problems?

This is going back a step: I waited, thinking I might be duplicating
Dale's answer--but I'd suggest one more thing.  I had this problem a
little while ago.  (I wasn't using an experimental version of dpkg,
though I didn't ever find out just what caused it.)  What worked for me
was running mandb with the -c option to completely rebuild the database:

-c, --create
              By default, mandb will try to update any previously
              created databases. If a database does not exist, it
              will create it. This option forces mandb to  delete
              previous databases and re-create them from scratch.
              This may be necessary if a database becomes corrupt
              or  if  a new database storage scheme is introduced
              in the future.                                           

I ran it from the command line as root, and without specifying any path,
letting it read /etc/manpath.config.  I don't recall what directory I
ran it from, but don't think it mattered.  Segfaults went away as silently as
they'd come.

I didn't get the impression you've tried this yet, and if you haven't,
do, because it sounds pretty much like my experience.  Hope it helps,
 
-- 

Ed Donovan			[email-masked]

---

From: Ian Jackson <[email-masked]>
Date: Mon, 26 Aug 96 14:26 BST

Christoph Lameter writes ("Re: "man" crashes"):
...
> mandb: warning: /usr/man/man1/dpkg-parsechangelog.1: bad symlink or ROFF
...
> Seems that the man package cannot cope with some screwups of the dpkg

Oops, I forgot to change the symlink target.  I'll fix this.

Ian.