Subject: EXT2-fs warning (device 16:0n)...

From: Luca Maranzano <[email-masked]>
Date: Thu, 22 Aug 1996 12:35:15 +0200 (MET DST)

Hi all,

I'm happily running Debian 1.1 with Kernel 2.0.10 on several different 
machines here, but last week one of these began to show these messages (after
a crash due to a power failure):

EXT2-fs warning (device 16:01): ext2_free_inode: bit already cleared for inode 24481
EXT2-fs warning (device 16:01): ext2_free_inode: bit already cleared for inode 24481
[...]
EXT2-fs warning (device 16:02): ext2_free_inode: bit already cleared for inode 136220
EXT2-fs warning (device 16:01): ext2_free_inode: bit already cleared for inode 24481
EXT2-fs warning (device 16:02): ext2_free_inode: bit already cleared for inode 136217
EXT2-fs warning (device 16:02): ext2_free_inode: bit already cleared for inode 136218
EXT2-fs warning (device 16:02): ext2_free_inode: bit already cleared for inode 136219
[....]

The PC is a Pentium 100, 32 MB Ram and the hard disk setup is this (from dmesg):

ide: i82371 PIIX (Triton) on PCI bus 0 function 57
    ide0: BM-DMA at 0x3000-0x3007
    ide0 timing: (0xa307) sample_CLKs=3, recovery_CLKs=1
         master: fastDMA=on  PreFetch=on  IORDY=on  fastPIO=on 
         slave : fastDMA=off PreFetch=off IORDY=off fastPIO=off
    ide1: BM-DMA at 0x3008-0x300f
    ide1 timing: (0xa307) sample_CLKs=3, recovery_CLKs=1
         master: fastDMA=on  PreFetch=on  IORDY=on  fastPIO=on 
         slave : fastDMA=off PreFetch=off IORDY=off fastPIO=off
hda: Conner Peripherals 1275MB - CFS1276A, 1221MB w/0kB Cache, LBA, CHS=2482/16/63
hdc: Conner Peripherals 1275MB - CFS1276A, 1221MB w/0kB Cache, LBA, CHS=2482/16/63
hdd: OTI-SCYLLA, ATAPI CDROM drive

The first question is this: which device are 16:02 and 16:01 ? I looked in /dev
searching for devices whith major number 16 but I didn't found any.
Shouldn't hda and hdc correspond to major 3 and 22 ?

The disks are so partitioned:

Filesystem         1024-blocks  Used Available Capacity Mounted on
/dev/hda1              31687    8721    21330     29%   /
/dev/hda3              63439      37    60126      0%   /tmp
/dev/hda5             495714  232237   237876     49%   /usr
/dev/hda6             297603   41177   241056     15%   /var
/dev/hda7             227349   22334   193274     10%   /usr/local
/dev/hdc1             495714  146812   323301     31%   /web
/dev/hdc2             715203   21411   656849      3%   /home

I've tryed to e2fsck /dev/hdc2 (thinking that device 16:02 corresponds
to /dev/hdc2) and it found a lot of errors, but it seemed that e2fsck
was able to correct them all; after rebooting similar messages appeared
again after some hours.

Any clue about this? 

Tahnks in advance and best regards,
Luca.

---

From: [email-masked] (Bruce Perens)
Date: Fri, 23 Aug 96 15:34 PDT

[regarding chronic filesystem errors]

About the only additional thing I can suggest is upgrading your kernel
(we are now at 2.0.13, I think) and watching to see if the problem goes
away.

	Bruce