Subject: Re: kernel size (was: How do I get GATEWAY2000 PS/2 mouse to work?)

From: [email-masked] (Bruce Perens)
Date: Tue, 20 Aug 96 23:21 PDT

> > The real question is whether the default kernel should be bloated with
> > features, or pared down.

From: Todd Tyrone Fries <[email-masked]>
> The default kernel need not contain anything that isn't necessary
> to boot.  This means floppy, minix, and ramdisk drivers.

This is the way it will be for 1.2 . I am testing it now. The default kernel
has no IDE, no SCSI, little else. When you set up the system, it builds a RAM
disk image that is loaded at boot time. The script on the RAM disk loads the
modules for your local hardware configuration _before_ it mounts the root.
Some things that still aren't modularized are in the default kernel.

The stripped-down kernel and the compressed installation root filesystem
fit on one 1200K floppy and run fine that way. The floppy also contains
a few of the most popular modules, and you get to feed it more floppies
(or a CD) containing other modules depending on your configuration.

No-floppy bootstrap should be possible for systems with 8MB RAM and a CD
or DOS hard disk. One-floppy NFS bootstrap should be possible.

See /usr/src/linux/Documentation/initrd.txt .

	Bruce

---

From: Casper BodenCummins <[email-masked]>
Date: Tue, 20 Aug 1996 13:01:42 +0100

Todd,

Do you disagree? Aren't you simply saying that you'd go down the 'pared
down kernel route'? (Note: when I say pared down, I don't preclude the
possibility of using modules.)

Casper Boden-Cummins.

>----------
>From: 	Todd Tyrone Fries[SMTP:[email-masked]]
>Sent: 	19 August 1996 21:06
>To: 	[email-masked]
>Subject: 	Re: kernel size (was: How do I get GATEWAY2000 PS/2 mouse to
>work?)
>
>I disagree. The default kernel need not contain anything that isn't
>necessary
>to boot.  This means floppy, minix, and ramdisk drivers.  Ide might be
>useful;
>this should (imho) be loadable as a module, though.   But anyway, to
>the
>mouse.  ps/2 mice can be loaded as modules.  As long as it is loaded
>when it
>is determined that the user has a ps2 mouse, I see no reason why it
>can't
>be included in the available modules at boot time, and at the same time
>see
>no reason why it should be in the default kernel; modules work. Use
>them.
>
>If someone decides they'd rather not load the ps2 module, but compile
>it into
>the kernel, well, they can.
>
>--
>Todd Fries .. [email-masked]
>
>

---

From: Casper BodenCummins <[email-masked]>
Date: Tue, 20 Aug 1996 16:09:45 +0100

There probably wouldn't quite be room to include the kitchen sink. :->

IMHO, a better alternative to the large, best-endeavours kernel would be
to ship a really tight kernel and use the installation front-end to
configure additional support (in modules where possible or desirable).

Casper Boden-Cummins.

>----------
>From: 	David J. Evans[SMTP:[email-masked]]
>Sent: 	16 August 1996 14:12
>To: 	[email-masked]'
>Cc: 	The recipient's address is unknown.
>On Thu, 15 Aug 1996 10:04:04 +0100 Casper BodenCummins 
><[email-masked]> wrote:
>
>[snipped stuff about PS/2 support not being present by 
>default ....]
>
>As a brand new Debian user who didn't even know how to 
>spell Colonel until recently, and who has been caught out 
>by the lack of PS/2 support, I'd vote for a large 
>"everything and the kitchen sink" kernel to cover most 
>eventualities.  This will give heart to new-users and 
>upgraders, and can trimmed and tweaked by the gurus.
>
>And thank you to all who responded with my "newbie" 
>question about telnetting in as root to a box without a 
>screen or keyboard - su and /etc/securetty were all new to 
>me.
>
>David
>
>______________
>David J. Evans
>AMS, Virology Research Group, The University of Reading
>Whiteknights, P.O. Box 228, Reading RG6 6AJ
>Tel : +44 (0)118 9318893  Fax : +44 (0)118 9316537
>http://skpc10.reading.ac.uk/
>
>
>

---

From: [email-masked] (Bruce Perens)
Date: Tue, 20 Aug 96 21:52 PDT

From: Casper BodenCummins <[email-masked]>
> configure additional support (in modules where possible or desirable).

The stripped-down kernel for 1.2 is currently 362K compressed,
a good deal smaller than the generic one for 1.1 . And that was with
AX.25 included in the kernel (because it's not modularized and I wanted
to experiment with it). The final one will no doubt be smaller.
As far as I can tell, everything that I left out of it is working in module
form. However, some of the modules do not auto-configure the device addresses,
while the linked in version of the same driver does. We might have to help the
user a bit with this, but hopefully it will be less of a mess than the
situation we have now, in which the generic kernel can't be made to work for
everyone.

	Thanks

	Bruce