Subject: syslogd stopped working

From: Dermot Bradley <[email-masked]>
Date: Sat, 3 Aug 1996 00:37:26 +0100 (BST)

I'm running Debian 1.1 on a machine here and as of a few days ago syslogd 
has stopped working. If I run the daemon manually it runs for about 30 
seconds and then stops. I've tried removing the sysklogd package (using 
the --force option) and re-installing it again to no avail.

-- 
Dermot Bradley                                Email: [email-masked]
Communications Director                       Tel: 01232 560552
Genesis Project Ltd                           Fax: 01232 560553
Belfast & Derry, Northern Ireland             WWW: http://www.gpl.net/

---

From: llucius <[email-masked]>
Date: Sat, 3 Aug 1996 00:09:26 -0500 (CDT)

> the --force option) and re-installing it again to no avail.
Make sure you have a domainname set or apply patch found in bug #3526.

Leland

__ Y_ a_ m_ b_ o_ | The leanest, meanest, fightinest sweet tater on Earth!
   oo o  oo o  o  | 
    o       o   o | [email-masked]
 o oo    o     o  | 
-- -- -- -- -- -- | http://www.millcomm.com/~llucius       (maybe one day)

---

From: "Richard G. Roberto" <[email-masked]>
Date: Mon, 5 Aug 1996 10:20:26 -0400 (EDT)

> the --force option) and re-installing it again to no avail.

I had the same problem and mis-diagnosed it too!  I wound up
upgrading the sysklogd package and thought it was the
answer, but it turns out it wasn't.  Here's basically what
happened on my system:

I went through the install and configured my system to be
called "debian" as the install does if you don't have a nic
card to configure.  I then restored my home directories (I
came over from Slackware) and configs and connected to the
net using ppp.  My ppp connect script updates my /etc/hosts
file with hte new dynamic IP address and changes my hostname
to dummypc.  This was intended to be a temporary setup, but
it worked so I never changed it :).  I was using a template
file to change the hosts file using sed.  The template file
didn't have an entry for "debian" as a valid host.  syslogd
wouldn't run, I'm assuming because it couldn't resolve the
hostname returned by "uname -n" to an IP address.

I changed my script to echo a series of commands to ed and
edit the existing hosts file (with a valid debian entry) and
all seems to work fine.  I don't know for sure if my
diagnosis is right here, but I haven't had any problems
since.  Please check this on your system and let me know if
something similar has happened.  I'm curious to see if that
was really it or not.  What ever name is returned by
"hostname" or "uname -n" (should be the same?) should have a
valid entry in /etc/hosts.

Thanks

Richard G. Roberto
[email-masked]
201-739-2886 - whippany, nj

--
*******************************************************************************
Bear Stearns is not responsible for any recommendation, solicitation, offer or
agreement or any information about any transaction, customer account or account
activity contained in this communication.
*******************************************************************************

---

From: Dermot Bradley <[email-masked]>
Date: Tue, 6 Aug 1996 16:44:52 +0100 (BST)

> Make sure you have a domainname set or apply patch found in bug #3526.

Hmm #3526 isn't on the UK bugs site.

Dermot

---

From: llucius <[email-masked]>
Date: Tue, 6 Aug 1996 11:58:57 -0500 (CDT)

> Hmm #3526 isn't on the UK bugs site.
I might have gotten the # wrong, but the latest sysklogd (1.3-10) has the 
patch applied.  (It's still in incoming.)

Leland