Subject: Q's about modifying a debian package install

From: Al Youngwerth <[email-masked]>
Date: Mon, 26 Aug 1996 11:08:21 -0600

I'm still trying to get a grip on the whole theory of debian package installations and I have a few questions about how one should go about modifying an installation.

I just installed the apache package. The debian installation sets up apache to run out of the rc.d stuff but I want it to run under inetd (it's for "intranet" access and security is more important than speed). What's the "right" way to make this modification? To take apache out of the start-up process should I:

Change the apache script in /etc/init.d to just exit whenever its called?

Run "update-rc.d apache remove" (this generates the error: "update-rc.d: error: /etc/init.d/apache exists during rc.d purge)?

Just delete apache from /etc/init.d and its symlinks in all the /etc/rc.d directories?

I guess the right way to fix this problem would be to change the apache .deb package installation script stuff so it allowed for either type of installation and then future upgrades (or purges) would be done correctly?

What about installing non-debianized programs into my system. I've seen people refer to installing all non-debian stuff in /usr/local. Why? I'm writing a lot of little perl script utilities for my system. Should they all go in /usr/local? What about the configuration files for the perl script utilities I write. I've been putting them in /etc, should they go someplace?

Thanks in advance for answers to any of my questions.

Al Youngwerth
[email-masked]

BTW is someone working on upgrading the debian apache package to 1.1.1?

---

From: Ed Donovan <[email-masked]>
Date: 27 Aug 1996 00:30:55 -0400

Hi Al, 

I can't answer everything, but:

Al Youngwerth <[email-masked]> writes:

> I'm still trying to get a grip on the whole theory of debian package =
> installations and I have a few questions about how one should go about =
> modifying an installation.
> 
> I just installed the apache package. The debian installation sets up =
> apache to run out of the rc.d stuff but I want it to run under inetd =
> (it's for "intranet" access and security is more important than speed). =
> What's the "right" way to make this modification? To take apache out of =
> the start-up process should I:
> 
> Change the apache script in /etc/init.d to just exit whenever its =
> called?

Not as clean as:

> Run "update-rc.d apache remove" (this generates the error: "update-rc.d: =
> error: /etc/init.d/apache exists during rc.d purge)?

I believe you're supposed to delete the script in /etc/init.d/.  Then
run update-rc.d, and it will remove all the symlinks.
 
> Just delete apache from /etc/init.d and its symlinks in all the =
> /etc/rc.d directories?

Yeah, this is the same as above, manually.

(snip)
> What about installing non-debianized programs into my system. I've seen =
> people refer to installing all non-debian stuff in /usr/local. Why? I'm =
> writing a lot of little perl script utilities for my system. Should they =
> all go in /usr/local? What about the configuration files for the perl =
> script utilities I write. I've been putting them in /etc, should they go =
> someplace?

That should be clarified: all unpackaged stuff _that belongs under /usr_
should go in /usr/local.  /etc is still /etc, and is yours; follow the
general layout, but it's not in a sort of 'distribution freeze' like
/usr.  Add special system-wide config files as you need, and Debian
packages whose existing configuration files have been modified should
respect that, offering you options like leaving your versions in place
and copying the new distribution versions in as /etc/*.dpkg-dist.

Nb: this is no kind of official statement.  If corrections are needed,
I'm sure they'll follow.  

-- 

Ed Donovan			[email-masked]