Subject: RE: a problem with "screen"

From: [email-masked] (Bruce Perens)
Date: Tue, 20 Aug 96 12:20 PDT

From: 	Pure Energy[SMTP:[email-masked]]
>i tried to run screen but it has just started to continiously
>terminate.
>	i have run screen now for weeks without this problem. the strange
>thing is that it does this on my personal account, root and one other.
>on
>all other accounts screen runs fine.

Do all of those users have a shell in common? For example are they all
tcsh users? Do they have features in their .profile, .login, or .cshrc
in common?

I'm a "tcsh" user, so I'd use "set verbose" in my .cshrc so that I
could see what the shell is doing, how far it's getting, etc. You can do
something similar with "bash", I think it's "set -x" in your .profile,
see the man page. Other shells support something similar. I surmise that
all of your sub-shells are exiting, and thus screen exits because it has
nothing to run. You should be able to track this down without expending
much adrenaline :-)

From: Casper BodenCummins <[email-masked]>
> THERE SEEMS TO BE SOMETHING WRONG WITH MY CAPS KEY!

We need a document on "Are you ready for Linux?" :-)

	Thanks

	Bruce

---

From: Casper BodenCummins <[email-masked]>
Date: Tue, 20 Aug 1996 13:19:11 +0100

MR. ENERGY,

CASPER BODEN-CUMMINS.

>----------
>Sent: 	20 August 1996 03:54
>To: 	Debian Users
>Cc: 	The recipient's address is unknown.
>Subject: 	a problem with "screen"
>
>hello all,
>	well not sure if i should ask here or not but here it goes. today
>it would look something like this:
>
>timberwolf >screen irc Adrenolin
>the screen then clears and i get a msg,
>[screen is terminating]
>and it returns to the prompt.
>
>all other accounts screen runs fine. i have exited out of the account
>and
>re-logged in to no avail. i did a complete shutdown and after i
>rebooted
>it still refuses to run on these 3 accounts. 
>	i know it is not a memery problem:
>
>             total       used       free     shared    buffers    
>cached
>Mem:         38828      15180      23648       5980       2372      
>8848
>-/+ buffers:             3960      34868
>Swap:        32252          0      32252
>	
>	and i'm not useing any sort of quotas on this system. any ideas
>out there as to how to correct this? thanx in advance :)
>-Rob
>
>	/---------------------------------------------------------\
>	|   	        Robert "Adrenolin" MacQuarrie             |
>	|		     [email-masked]                  | 
>	|	        [email-masked]	          |
>	|=========================================================|
>	|     ProvisioNet Distributions at New Jersey Branch      |
>	|	   Email: [email-masked]           |
>	\---------------------------------------------------------/
>
>
>
>
>
>