Subject: how to put ifconfig in startup script?

From: [email-masked]
Date: Fri, 16 Aug 1996 23:31:49 -0700

Hello;

After messing up my XDM and essentially locking myself
out of my system for a while, I have become interested
in setting up my ethernet card from a startup script.

Does one put the ifconfig and route statements in the usual
rc.inet1 and reference it somehow from rc6.d, or what?

I appreciate any suggestions here; the NET-2 HOWTO seems to be 
geared toward the Slackware kind of system.

Thanks!

---

From: Philippe Troin <[email-masked]>
Date: Sat, 17 Aug 1996 13:59:31 -0700

> geared toward the Slackware kind of system.

In a Debian system, these statements should go into /etc/init.d/network.
It contains a small script to be customized.
Here's a copy of mine:

#!/bin/sh
ifconfig lo localhost
route add -net localnet
IPADDR=207.104.147.129
NETMASK=255.255.255.248
NETWORK=207.104.147.128
BROADCAST=207.104.147.136
GATEWAY=none
INTERFACE=dummy0

[ $INTERFACE != none ] && \
    ifconfig $INTERFACE ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST} &&\
    route add -net ${NETWORK}
[ $GATEWAY != none ] && route add default gw ${GATEWAY} metric 1

Note that I have no default gateway (diald sets up its own).

Phil.

---

From: [email-masked] (Miquel van Smoorenburg)
Date: 18 Aug 1996 02:17:48 +0200

In article <[email-masked]>,  <[email-masked]> wrote:
>rc.inet1

Debian doesn't have a rc.inet1, but something that looks like it:
/etc/init.d/network

> and reference it somehow from rc6.d, or what?

rc6.d? That would be the reboot runlevel. Somehow I don't think that's
what you want :) But seriously, just put your commands in /etc/init.d/network
and they will be executed at boot time.

>geared toward the Slackware kind of system.

Alas, yes.

Mike.
-- 
+   Miquel van Smoorenburg   + Cistron Internet Services +  Living is a     |
|  [email-masked] (SP6)  | Independent Dutch ISP     |   horizontal     |
+ [email-masked] + http://www.cistron.nl/    +      fall        +