Subject: using procmail with emacs RMAIL

From: Stephen Masterman <[email-masked]>
Date: Sat, 24 Aug 96 17:42 EDT

Hi,

Can someone point me to info for the quickest, easiest way to use procmail
with Emacs RMAIL to separate, say, the debian list into a separate folder?
I normally have no problem putting hours into something like this, but lately
I'm incredibly busy and there seems to have been loads of traffic on debian
recently, so that I'd really like to get it working as quickly as possible.

Thanks in advance,
Steve

---

From: Ed Donovan <[email-masked]>
Date: 24 Aug 1996 20:51:09 -0400

Hi Steve,

I use Gnus & sometimes VM, so I can't tell you a thing about Rmail,
except that you should point at the separate spool file that procmail
will create.  How to do this so that it doesn't just chuck it back in
with the rest of your mail, I don't know, though it may be easy.

My procmail settings are mostly cribbed from the "Mail Filtering FAQ",
which I found to be very useful.  Among other places:

http://www.smartpages.com/faqs/mail/filtering-faq/faq.html 

I just copied the setup it outlines, and use these lines to catch Debian
mail:

  :0:
  * ^TOdebian-user
  debian-user.spool

  :0:
  * ^TOdebian-changes
  debian-changes.spool

Procmail uses one of those stanzas for each filter.  The '.spool' suffix
is a Gnus default that I went along with.  Following the FAQ, I have
these in "~/.procmail/rc.maillists"--in a more vanilla setup they'd be
in "~/.procmailrc".

Hth,

-- 

Ed Donovan			[email-masked]

---

From: Jean Orloff <[email-masked]>
Date: Mon, 26 Aug 1996 14:34:30 +0200

>>>>> On Sat, 24 Aug 96 17:42 EDT, Stephen Masterman <[email-masked]> said:
 Stephen> Can someone point me to info for the quickest, easiest way to use
 Stephen> procmail with Emacs RMAIL to separate, say, the debian list into a
 Stephen> separate folder?  I normally have no problem putting hours into
 Stephen> something like this, but lately I'm incredibly busy and there seems
 Stephen> to have been loads of traffic on debian recently, so that I'd really
 Stephen> like to get it working as quickly as possible.

I switched to MH about a year ago, so this is just theory:

1) set up procmail
==================
(with ~/.forward, etc) as explained by Dirk in a previous message

2) set up your ~/.procmailrc 
============================
# Please check if all the paths in PATH are reachable, remove the ones that
# are not.
PATH=$HOME/bin:/usr/bin:/bin:/usr/local/bin:
MAILDIR=$HOME
LOCKFILE=$MAILDIR/.lockmail # default lock

# default action: keep in username mailbox
DEFAULT="/var/spool/mail/username"

#------------------------------------------------------
# Debian mailing lists go into ~/debian/inbox
:0:debian/.lock
* ^X-Loop:[email-masked]
$MAILDIR/debian/inbox

3) from emacs,
==============
do M-x rmail-input RET ~/debian/rmail RET 
to open/create the file ~/debian/rmail

4) in that buffer,
==================
do M-x set-rmail-inbox-list RET inbox RET
to explain rmail where to get new messages from.

This all should work, now you only got to debug! ;-)

Amities,

		Jean Orloff
+++++++++	+	+	+	+	+	+	+	++++++
+Tel:(33)50.09.16.75   Fax:(33)50.09.94.95   http://lapphp0.in2p3.fr/~orloff/+
+++++++++	+	+	+	+	+	+	+	++++++
In a Bucharest hotel lobby:
       The lift is being fixed for the next day.  During that time we 
       regret that you will be unbearable.
+++++++++	+	+	+	+	+	+	+	+