Subject: FAQ: Work-Needing and Prospective Packages

From: Sven Rudolph <[email-masked]>
Date: Mon, 26 Aug 1996 22:36:24 +0200

Work-Needing and Prospective Packages for Debian GNU/Linux
  Sven Rudolph, [email-masked]
  $Id: packages.sgml,v 1.21 1996/08/26 20:29:54 sr1 Exp sr1 $

  1.  General Questions

  1.1.	What is Debian GNU/Linux

  Please read the Debian GNU/Linux FAQ.	The Debian GNU/Linux WWW server
  is at http://www.debian.org/ , the FAQ is located at
  http://www.debian.org/FAQ/ (This copy might be out of date). The FAQ
  is available via FTP at ftp.debian.org:/debian/doc .

  1.2.	Purpose of this document

  This document is intended to identify areas that need your
  contributions. It provides information that hopefully changes quite
  often, so it supplements the Debian GNU/Linux FAQ.

  1.3.	Feedback

  Please send additions, corrections, suggestions and wishes to Sven
  Rudolph [email-masked].  Please mention to which version of
  this document your comments refer.

  2.  Packages that have no current maintainer

  Packages listed in this section are still part of Debian (unless they
  have too many bugs), but the maintainer had reasons to not continue
  maintaining it. (Remember: Debian is mainly produced by volunteers who
  are not paid for maintaining Debian packages.)

  If you find that you need to discontinue maintaining a package, send
  me an e-mail.

  If you believe that the following list is incomplete, i.e., that there
  are other packages in the Debian distribution that currently have no
  active maintainer, send me an e-mail.

  If you would like to maintain one of the packages listed here, send me
  an e-mail.

  previously maintained by Ian Murdock [email-masked] :
  o  acm
  o  aout-librl (this package might be unnecessary now)
  o  pmake

  previously maintained by DJ Gregor [email-masked] :
  o  biff
  o  cdtool
  o  unclutter
  o  workbone
  o  xwpe

  others :
  o  elm
  o  ifrench, igerman

  3.  Packages that the maintainer wants to give away

  Packages listed in this section are still part of Debian, but the
  maintainer wants to find a new maintainer. It isn't as urgent to find
  a new maintainer as in the previous section.

  If you maintain Debian packages that you would like to hand off, send
  me an e-mail, then I will add this package to this section.

  If you would like to maintain one of the packages listed here, write
  to the current maintainer of this package.

  currently maintained by Sven Rudolph [email-masked] :
  o  seyon

  currently maintained by Christian Linhart [email-masked] :
  o  statserial
  o  tgif
  o  xarchie

  currently maintained by Jim Robinson [email-masked] :
  o  pari

  currently maintained by Michael Meskes [email-masked]
  Aachen.DE :
  o  xsysinfo
  o  xcolors
  o  xautolock

  currently maintained by Richard Kettlewell [email-masked] :
  o  aout-svgalib
  o  svgalib1
  o  svgalib1-bin
  o  svgalib1-dev

  currently maintained by Andrew D. Fernandes [email-masked] :
  o  acs

  4.  Packages that someone is working on

  Programs listed in this section aren't yet available as Debian
  packages, but someone is working on providing a package.

  If you would like to work on one of these packages please contact the
  responsible person listed below.

  Chris Fearnley [email-masked] :
  o  dome (http://www.netaxs.com/ cjf/jpegs.html)
  o  and probably : xli, Tix, povray

  [email-masked] (Karl R. Sackett) :
  o  CLX - Common Lisp Xlib implementation
  o  PCL - Portable Common Loops for GCL

  Richard Kaszeta [email-masked] :
  o  xmotd

  Mike Wilson [email-masked] :
  o  mule

  Sven Rudolph [email-masked] :
  o  xbill
  o  LPRng

  "behan (b.) webster" [email-masked]
  o  sxpc (Simple Xwindows Protocol Compresser)
  o  qfax (multi-user e-mail extension to efax).

  [email-masked]:
  o  tkHTML

  Darren [email-masked] :
  o  mew, giftool

  [email-masked] :
  o  BBDB (for Emacs: Big Brother Data Base, a rolodex with hooks into
     VM, GNUS, and RMAIL)

  Michael Alan Dorman [email-masked] :
  o  glimpsehttpd

  Warwick Harvey [email-masked] :
  o  mercury (a purely declarative logic programming language with
     strong modes, strong types, and strong determinism)

  [email-masked] :
  o  PAM (Pluggable Authentication Modules) (
     http://www.pilgrim.umass.edu/pub/osf_dce/RFC/rfc86.0.txt )

  [email-masked] :
  o  CLISP

  David H. Silber [email-masked] :
  o  dbackup - A Debian-specific backup program.
  o  lockstep - A program to keep various directory trees in sync.
  o  uucpconfig - A configuration program which will become part of my
     uucp package.
  o  latex2html

  Karl R. Sackett [email-masked] :
  o  libXg - UTF-2 fonts for Sam and 9term
  o  faces - visual list monitor

  Brian Sulcer [email-masked] :
  o  vile (vi-like editor)
  o  rogue
  o  umoria

  Martin Schulze [email-masked] :
  o  vtwm: Virtual Window Manager for X11

  Michael Shields [email-masked] :
  o  amanda, the University of Maryland's free network backup system.
  o  nntplink

  Bdale Garbee [email-masked] :
  o  spice (circuit simulation package)
  o  gforth

  Billy Chow [email-masked] :
  o  koules
  o  xbomb

  Alan Bain [email-masked] :
  o  gpc (GNU Pascal)

  Ed Petron [email-masked] :
  o  tkps (tk-based "top")

  Christophe Le Bars [email-masked] :
  o  Caml (A small, portable implementation of the ML language.)
  o  Objective Caml: Caml dialect extended with a complete class-based
     object system
  o  MMM: a WWW browser implemented in Caml

  Yves Arrouye [email-masked]> :
  o  ppd-gs (a set of PPD files for my Ghostscript drivers)
  o  btoa

  Erick Branderhorst [email-masked] :
  o  awk2c

  Jon Rabone [email-masked] :
  o  SISCAD

  Christian Lynbech [email-masked] :
  o  ilisp (emacs interface to a number of lisp systems)
  o  calc  (emacs calculator package)
  o  hyperbole (emacs hypertext/info management system)
  o  oobr (emacs package for browsing OO programs)
  o  STk (Scheme Tk, a scheme interpreter with Tk support)

  Lee Olds [email-masked] :
  o  Qt

  Christian Hudon [email-masked] :
  o  qmail

  Christoph Lameter [email-masked] :
  o  smartlist

  Tim Cutts [email-masked] :
  o  exim (a mail transfer agent,
     ftp://cus.cam.ac.uk/pub/software/programs/exim)

  5.  Programs that aren't available yet in Debian

  Programs listed in this section aren't yet available as Debian
  packages, but there has been an expressed desire to include them.

  If you want to create a Debian package, send me an e-mail.

  5.1.	Programming and development:

  o  UPS - the X-based debugger.  Probably not worth building until
     we've switched to ELF. (There are Linux-specific patches around.)
  o  checker
  o  Scheme->C
  o  SCM - Scheme interpreter which will soon be the basis of the GNU
     extension language.
  o  SLIB.
  o  CLISP - Common Lisp interpreter
  o  ECoLisp - a Common Lisp compiler that produces faster code but
     isn't as widely used as GCL
  o  CLiCC - Common Lisp compiler that generates stand-alone apps
     (rather large ones, though)
  o  Modula-3 (
     http://www.research.digital.com/SRC/modula-3/html/srcm3.html )

  5.2.	USENET news software:

  o  strn.

  5.3.	Math packages:

  o  SC (the spreadsheet). (oleo is already available)
  o  SciLab
  o  Yorick
  o  MuPAD (computer algebra tool from University of Paderborn, Germany
     http://gauss-mb.uni-paderborn.de/ cube/ , please look at the
     license conditions.)
  o  calctool
  o  felt
  o  LAPACK and BLAS (numerical libraries,
     http://nils.wustl.edu/schiotz/lapack-linux.html )

  5.4.	Graphics:

  o  Kubota Graphics Corporation's now-PD 3-D visualization system,
     Dore'.

  5.5.	Misc Tools:

  o  binhex

  5.6.	Editors:

  o  NEdit ( http://fnpspa.fnal.gov/nirvana/nedit.html , requires Motif)
  o  jed (small emacs-like)

  5.7.	Games:

  o  rocks and diamonds
  o  xgalaga (space-invaders style game)
  o  xibc (backgammon)
  o  xevil
  o  xjewel
  o  xgammon

  5.8.	X11:

  o  Andrew
  o  plan (calender with many functions)
  o  grok (database with many functions)
  o  xmem
  o  xidle
  o  xmcd (ftp://ftp.x.org/contrib/applications/xmcd/xmcd-2.0.README)
  o  olvwm

  5.9.	Communication

  o  BBS (Bulletin Board System) Software
  o  hylafax (http://www.vix.com/hylafax) a fax server with add-ons for
     alphanumeric paging

  5.10.	TeX

  o  tmview (svgalib DVI viewer) Kpathsea support should be added and
     the original author is already aware of this. Contact him first.

  5.11.	Networking

  o  other www servers (Spinner ( http://spinner.infovav.se/ ), WN (
     http://hopf.math.nwu.edu/docs/overview.html) )
  o  xinetd (replacement for inetd with many enhancements)
  o  ftptool

  5.12.	System Tools

  o  IBCS2 emulator

  5.13.	Text utilities

  o  HTML editors (tkHTML, asWedit, auc-html.el)
  o  mpage (GNU enscript is already available)
  o  texi2html

  6.  Programs that someone should write

  This section contains suggestions/wishes for programs. There is no
  known implementation of such a program for Linux.

  o  amspell (ms-dos) like spell checker, i.e. a spell checker what
     checks the complete text first, searching for alternatives (on the
     fly) and asking for user action at the very end of the checking
     process. This saves much time on low memory machines.

-- 
Sven Rudolph <[email-masked]> ; WWW : http://www.sax.de/~sr1/

---

From: Sven Rudolph <[email-masked]>
Date: Mon, 26 Aug 1996 22:36:24 +0200

1.  General Questions

  1.3.	Feedback

  others :
  o  elm
  o  ifrench, igerman

  Darren [email-masked] :
  o  mew, giftool

  [email-masked] :
  o  CLISP

  o  strn.

  5.3.	Math packages:

  5.4.	Graphics:

  5.5.	Misc Tools:

  o  binhex

  5.6.	Editors:

  5.7.	Games:

  o  rocks and diamonds

  5.8.	X11:

  o  Andrew

  5.9.	Communication

  5.10.	TeX

  5.11.	Networking

  5.12.	System Tools

  o  IBCS2 emulator

  5.13.	Text utilities