Subject: dselect and ftp

From: "David J. Evans" <[email-masked]>
Date: Thu, 22 Aug 1996 20:30:16 +0100 ()

My recent ftp debian 1.1 installation was a great success, 
except that I appear to have deleted a package needed for 
further ftp installations using dselect .... I don't know 
where I went wrong, but was trying to save some disk space 
and probably pressed a - when I should have selected an =.

Could this be wu-ftp ?  I've looked in the "packages" list 
and couldn't see any dependencies .... could anyone help me 
out with this one ?

Thanks in advance

David 

______________
David J. Evans
AMS, Virology Research Group, The University of Reading
Whiteknights, P.O. Box 228, Reading RG6 6AJ
Tel : +44 (0)118 9318893  Fax : +44 (0)118 9316537
http://skpc10.reading.ac.uk/

---

From: [email-masked] (Kevin Buhr)
Date: 23 Aug 1996 11:43:49 -0500

-----BEGIN PGP SIGNED MESSAGE-----

"David J. Evans" <[email-masked]> writes:
| 
| My recent ftp debian 1.1 installation was a great success, 
| except that I appear to have deleted a package needed for 
| further ftp installations using dselect ....

You need to reinstall "dpkg-ftp".

|                                              I don't know 
| where I went wrong, but was trying to save some disk space 
| and probably pressed a - when I should have selected an =.

You did nothing wrong: when I installed Debian 1.1.5, I noticed that
the "dpkg-ftp" had been *automatically* deselected, and I had to
manually fix that.  I just forgot to file a bug report about it.

Kevin <[email-masked]>

---

From: Ian Jackson <[email-masked]>
Date: Mon, 26 Aug 96 14:10 BST

Package: base
Version: ?

Kevin Buhr writes ("Re: dselect and ftp"):
...
> manually fix that.  I just forgot to file a bug report about it.

Ahh, the light dawns.  dpkg-ftp had been marked as installed in the
base system, but not as selected for installation.  dselect therefore
went for the default, which was to deinstall it because its priority
was too low.

This was three bugs:
 (a) The base system should have marked it as selected for
     installation.
 (b) When something is installed but with a wanted status of `unknown'
     dselect should not want to deinstall it.  I'll fix this in dpkg
     1.3.10.
 (c) dpkg-ftp should have been in the main distribution.  This is now
     fixed in unstable, I believe.

I'm reporting this to the bug system because of (a).

Ian.

---

From: Ian Jackson <[email-masked]>
Date: Mon, 26 Aug 96 14:10 BST

Package: base
Version: ?

This was three bugs:

Ian.