Subject: Re: kernel size (was: How do I get GATEWAY2000 PS/2 mouse to work?)

From: "David J. Evans" <[email-masked]>
Date: Fri, 16 Aug 1996 14:12:51 +0100 ()

On Thu, 15 Aug 1996 10:04:04 +0100 Casper BodenCummins 
<[email-masked]> wrote:

[snipped stuff about PS/2 support not being present by 
default ....]

> The real question is whether the default kernel should be bloated with
> features, or pared down.

As a brand new Debian user who didn't even know how to 
spell Colonel until recently, and who has been caught out 
by the lack of PS/2 support, I'd vote for a large 
"everything and the kitchen sink" kernel to cover most 
eventualities.  This will give heart to new-users and 
upgraders, and can trimmed and tweaked by the gurus.

And thank you to all who responded with my "newbie" 
question about telnetting in as root to a box without a 
screen or keyboard - su and /etc/securetty were all new to 
me.

David

______________
David J. Evans
AMS, Virology Research Group, The University of Reading
Whiteknights, P.O. Box 228, Reading RG6 6AJ
Tel : +44 (0)118 9318893  Fax : +44 (0)118 9316537
http://skpc10.reading.ac.uk/

---

From: Todd Tyrone Fries <[email-masked]>
Date: Mon, 19 Aug 1996 15:06:47 -0500 (CDT)

> > The real question is whether the default kernel should be bloated with

I disagree. The default kernel need not contain anything that isn't necessary
to boot.  This means floppy, minix, and ramdisk drivers.  Ide might be useful;
this should (imho) be loadable as a module, though.   But anyway, to the
mouse.  ps/2 mice can be loaded as modules.  As long as it is loaded when it
is determined that the user has a ps2 mouse, I see no reason why it can't
be included in the available modules at boot time, and at the same time see
no reason why it should be in the default kernel; modules work. Use them.

If someone decides they'd rather not load the ps2 module, but compile it into
the kernel, well, they can.

--
Todd Fries .. [email-masked]