Subject: HELP color-ls not working.....

From: "Michael J. Cotherman" <[email-masked]>
Date: Thu, 08 Aug 1996 22:34:46 -0700

I get the following when I eval color-ls, but do not get colors...
As you can see, I did do the color=yes thingy
any help would be appreciated...

LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:';
export LS_COLORS;
LS_OPTIONS='--8bit --color=tty -F';
export LS_OPTIONS;
alias ls='/usr/bin/color-ls $LS_OPTIONS ';
alias dir='/usr/bin/color-ls $LS_OPTIONS --format=vertical';
alias vdir='/usr/bin/color-ls $LS_OPTIONS --format=long';
alias d=dir;
alias v=vdir;

Thank you, mike cotherman
[email-masked]

---

From: Syrus Nemat-Nasser <[email-masked]>
Date: Fri, 9 Aug 1996 10:10:30 -0700 (PDT)

> any help would be appreciated...

Michael, if you are still running fileutils-3.12, and you have color-ls
installed, then the command `eval dircolors` should execute the commands
you show below, and your ls should be colorized on tty terminals.  By
default, this included the console, xterm-color, rxvt, etc.  If you are
using the latest fileutils-3.13, then you need to do something else (see
below).

> LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31
:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:';
> alias vdir='/usr/bin/color-ls $LS_OPTIONS --format=long';

With the integration of color-ls directly into the fileutils
package, a few things have changed.  dircolors no longer sets
up aliases or shell scripts to colorize ls, dir, and vdir.

Here is an excerpt from a .bashrc which sets up aliases after
running dircolors:

	# set up color-ls
	eval `dircolors /home/syrus/.dir_colors`
	alias d='ls -F --color=auto'
	alias v='ls -l --color=auto'
	alias vdir='ls -l --color=auto'
	alias dir='ls -F --color=auto'                                                 

Note that color=tty has been changes to color=auto.  See the
documentation for other change information.

Syrus.

----------------------------------------------------------
Syrus Nemat-Nasser <[email-masked]>    UCSD Physics Dept.

---

From: "Michael J. Cotherman" <[email-masked]>
Date: Fri, 09 Aug 1996 18:03:01 -0700

I recieved this info from Syrus Nemat-Nasser <[email-masked]>:

( I was unaware that I did not need color-ls )

        # set up color-ls
        alias dir='ls -F
--color=auto'                                                 

Thanks, no further help is needed.