Cyrus-SASL 2.1.26 Configuration
Mark <>

What is it

Cyrus-SASL 2.1.26 SASL is the Simple Authentication and Security Layer, a method for adding authentication support to connection-based protocols. To use SASL, a protocol includes a command for identifying and authenticating a user to a server and for optionally negotiating protection of subsequent protocol interactions. If its use is negotiated, a security layer is inserted between the protocol and the connection.

The installation of cyrus-sasl2 is controlled by the package subsystem, thus it is quite easy to install and upgrade when new versions become available.

The main web site for the software is

Installation Of The Software

Fetch the package and install it with:
    # pkgadd -d cyrus-sasl.2.1.26.SPARC.64bit.Solaris.10.pkg cyrus-sasl

Issues To Be Aware Of

This version of Cyrus-SASL has been compiled against the OpenSSL 1.0.1e software. However, (if using other packages from this site), some of the older dependancies such as OpenLDAP 2.4.33 were compiled against OpenSSL 0.9.8. It might all be fine, but I woudln't be surprised to see the linker complain that OpenSSL versions are incompatible. Please let me know, (with cut and paste output), if this happens.

Web Site
The main web site for Cyrus-SASL is

Solaris Issues
Each Cyrus-SASL package requires installation on the Solaris release it was built on. Only install the correct version for your system.

Source Code
You can download the source code from

Special Issues
See the main packages README for installation information.