Subject: Re: PDP-11/73 Cabling Questions

From: [email-masked] (Barton F. Bruce / CCA)
Date: 22 Aug 94 21:22:56 -0400

In article <[email-masked]>, [email-masked] (Megan) writes:
> 
> Another point about the 11/83 - it is additionally defined as a
> KDJ11-B with PMI memory.  Even if you have a KDJ11-B (18mhz and FPA),
> if the system doesn't have PMI memory, it won't be considered an
> 11/83 by system software.
> 
> This is what we in RT-11 Engineering were told by the hardware group
> that developed the board.  That's why if you look in the sources
> for RESORC, you will find code which flushes the cache hit/miss
> register, then does a couple of NOPs, which on a system with PMI
> will cause some ones to be shifted in.  If the hit/miss register
> is non-zero after the NOPs, it's an 11/83 - with PMI.

I thought ALL of the quad wide 11/73 class boards were PMI capable
and that DEC simply did not want you to know that by moving the CPU
down a few slots and stuffing the PMI memory in ahead of it (all
on a Q-CD backplane, of course), you got the PMI functionality.

Otherwise sticking vanilla 22 bit Q bus memory after the processor gave you 
a 'non-PMI' machine.

There are some Tech OEM "Micronotes" on Decuserve that Ozzi Perez kindly 
provided on a TK50 ages ago that cover some of this.

There are lots of 73s out there not in the first slot.

---

From: [email-masked] (Megan)
Date: Tue, 23 Aug 1994 03:52:42 GMT

>on a Q-CD backplane, of course), you got the PMI functionality.

	That's right.  They ALL are PMI capable.  I've converted
	many machines (including some at DECUS, back when I was
	going) from 11/73B to 11/83 simply by CORRECTLY ordering
	the boards.

>Otherwise sticking vanilla 22 bit Q bus memory after the processor gave you 

	Exactly ... what RT refers to as an 11/73B

					Megan Gentry
					Former RT-11 Developer